canon rumors FORUM

Gear Talk => EOS Bodies - For Video => Topic started by: cschwartzy on September 01, 2013, 07:11:53 PM

Title: Canon 7D Major Issue
Post by: cschwartzy on September 01, 2013, 07:11:53 PM
Hey all. I was out shooting some college football today (video) and the camera was working fine. Then all of a sudden I noticed that my record button was not working. Once I realized this I look closer and noticed that none of the other buttons (menu, iso, playback etc..) were working.

This evening I sat down and tried to research the issue. I didn't find much. I took out both batteries and even did a software update. The only mode that buttons actually work in (Menu, play back etc.) is Full Auto. If I put it in any of the others the buttons become non responsive. The only thing that works in manual is the wheel by the shutter button but instead of it doing the Shutter, it controls the aperture, oh that and the light button. I notice that the ISO is changing on it's own in Manual as well.

I've been able to get it to work a couple times with taking the batteries out and resetting the camera and also luck (not sure how it started working) but as soon as I put a card in, the camera wanted me to adjust the time, and as soon as that happened it went back to being borked.

I really have no clue what the deal is. I am guessing there is an issue with the camera and it will need to be sent in. Anyone have any ideas? I've tried different batteries, the power button is completely on and the lock isn't on.

Anything is appreciated!
Title: Re: Canon 7D Major Issue
Post by: duydaniel on September 01, 2013, 07:32:52 PM
Nikon is having a sale event  ;D

http://nikonrumors.com/2013/09/01/the-new-nikon-instant-rebates-for-september-now-include-30-different-lenses.aspx/ (http://nikonrumors.com/2013/09/01/the-new-nikon-instant-rebates-for-september-now-include-30-different-lenses.aspx/)

While waiting for your new Nikon Camera to arrive,
try flash your camera firmware via computer?  ;D
Title: Re: Canon 7D Major Issue
Post by: pwp on September 01, 2013, 07:35:11 PM
I had this happen with an EOS 100D/SL1 last week. The camera was less than 24 hours old. This qualified as a DOA and an exchange was made. But there was a suggestion that flashing the firmware or updating firmware may provide a fix.  Good luck, it's a fairly crippling fault.

-PW
Title: Re: Canon 7D Major Issue
Post by: paul13walnut5 on September 01, 2013, 07:39:20 PM
I had this happen with my 7D with the grip on it.  Took the grip off remounted, all fine.

Until my grip burned out itself and 2x lp-e6 batteries a few months later.

I think you need a trip to CPS to avert major issues down the line.
Title: Re: Canon 7D Major Issue
Post by: cschwartzy on September 01, 2013, 07:41:21 PM
Thanks so far all. I've tried a firmware update via compact flash card, I am now trying through the computer. To clarify I do not have a grip on the camera.
Title: Re: Canon 7D Major Issue
Post by: cschwartzy on September 01, 2013, 08:07:35 PM
Update:

Firmware flash #2 does nothing. Still the same issue. I guess I'll have to get this sent in. Of course this happens with a busy week ahead.
Title: Re: Canon 7D Major Issue
Post by: Janbo Makimbo on September 01, 2013, 08:40:54 PM
Remove the battery and the little battery that keeps the time info etc, I am sure I read somewhere that this might help
Title: Re: Canon 7D Major Issue
Post by: sama on September 01, 2013, 09:19:31 PM
 Check the voltage of the backup battery(C1616) to make sure that it is in working order or else get it replaced . See if it helps.

Title: Re: Canon 7D Major Issue
Post by: cschwartzy on September 01, 2013, 10:48:57 PM
Remove the battery and the little battery that keeps the time info etc, I am sure I read somewhere that this might help

I've done this many times. I can get the camera to reset (reseting time and date) but the issue still occurs.
Title: Re: Canon 7D Major Issue
Post by: pwp on September 02, 2013, 05:46:04 AM
Remove the battery and the little battery that keeps the time info etc, I am sure I read somewhere that this might help
I've done this many times. I can get the camera to reset (resetting time and date) but the issue still occurs.
OP, I think you know what to do next...it sounds like you're understandably hoping for a Silver Bullet...

Book a trip to Canon Service or CPS if you're a member. Unless your camera has been exposed to some extreme environmental situation, it is likely to be a simple matter. But from here, you've run out of options.

-PW
Title: Re: Canon 7D Major Issue
Post by: JasonATL on September 02, 2013, 09:45:44 PM
I had this happen with a week old 5D3. It was a bent pin in the CF slot. Try taking out the CF card, then take the battery out. Put the battery back in with no CF card. If the camera seems to function, then it is probably a bad CF pin. Also could be a bad CF card. Bad SD cards create this behavior on my T3i. Key is to remove cards, then battery. If it isn't the card, then cam will have to go in. Good news is that Canon service isn't terrible.
Title: Re: Canon 7D Major Issue
Post by: wsmith96 on September 02, 2013, 10:22:04 PM
I didn't find much. I took out both batteries and even did a software update. The only mode that buttons actually work in (Menu, play back etc.) is Full Auto.!


sounds to me like you sinned against the CR 10 commandments and are stuck on green square mode. ;D

http://www.canonrumors.com/forum/index.php?topic=16246.45 (http://www.canonrumors.com/forum/index.php?topic=16246.45)