canon rumors FORUM

Gear Talk => Technical Support => Topic started by: gtsomething on April 06, 2012, 10:29:20 PM

Title: 7D Cannot Comminucate with Battery
Post by: gtsomething on April 06, 2012, 10:29:20 PM
Hello! I always feel guilty when my first post to any forum is a cry for help, but I'm crying for help... ...and yes I've used the search function.

Last Sunday while I was preparing for a shoot, I turned on my 7D to see how much battery power I had left in the menu. Strangely, it said 100% for both batteries (Using a Zeikos Grip), but over 1000 shots each. I found this to be odd, and just for the sake of finding out how much battery I actually had, I turned the camera off, took the batteries out and put them back in, in hopes that it'll display correctly.

Instead, I was greeted with a message saying "Cannot Comminucate with battery" error - ...yay... Luckily, the camera still functioned and could shoot and even tether, phew. However, I no longer know how much battery power I have left. The top-LCD display is blank, and the menu display simply repeats the error message to me.

This bugged me - a lot. So I've done all the basics of fixing such a problem. Cleaning the contacts, trying variations of batteries (OEM, Aftermarkets, with & without grip), resetting the camera by removing both battery and internal battery, and I've come up with nothing. But since my camera can still shoot, I decided to let it go.

Then I found out that with this error, comes some severe battery drain. From Sunday until now, I've taken anywhere between 300-500 shutter actuations at most. I can't remember for sure, but normally the camera could go for 1600 actuations at the very least when running on 2 batteries (Genuine Canon). But just from 300-500 shots, both batteries are completely drained. After some more googling, I've learned that with this error, apparently the camera will still drain my batteries even when the camera is off. Now this is REAAAAAAALLY annoying for any type of shoot. The battery dies quickly, without me having any idea of when. Imagine doing a wedding with this kind of problem...  :-\

I am currently on the most recent firmware (1.125 or something like that), and updated that way back, so I don't think that could be the problem... but I haven't tried downgrading the firmware yet either, just cause other google answers says it made no difference.

So please, if you've ever had this problem or know of someone with this problem or just have an idea what it might be, for the love of jebus help me  :'(
Title: Re: 7D Cannot Comminucate with Battery
Post by: Mt Spokane Photography on April 06, 2012, 11:05:10 PM
Send it in for repair, we can't fix it for you, you have tried all the common fixes.  I've heard of this problem with some who were using third party grips, it might be coincidence or ???  They do have electronics that talk to the camera, and if that fails, who knows what might happen.
I'd not use the grip again after you get your camera fixed, for fear it might happen again.