canon rumors FORUM

Gear Talk => EOS Bodies - For Stills => Topic started by: hoacker on August 14, 2012, 06:53:18 AM

Title: EOS 7D FW2.0: Problems anyone?
Post by: hoacker on August 14, 2012, 06:53:18 AM
Hi, there. At some german speaking forums user report problems with EOS 7D FW2.0 which started after the firmware update.

Problems reported:
- 1 (!) user reported that third party battery packs (weiss) were no longer recognized. This could not be confirmed by anybody so far. I guess this issue is not related to the firmware update.
- Some users report that the 7D freezes from time to time and can only be revived be removing and inserting the battery pack. There are multiple reports also from experienced user, so there is a chance that this issue is indeed related to FW 2.0.

Can you confirm one of the problems above?
Did you experience other problems introduces with FW 2.0?
Please report.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Paul W. H on August 14, 2012, 07:21:12 AM
I have had the freezing problem twice and at first thought that it might be that my CF card could not keep up with the increased speed in burst mode, since then this problem has appeared on a few websites.

The battery level indicator also showed 50.00% when it was almost full ??

Removing and replacing the battery for a few seconds solved the problem.

I have re-installed FW 2.0.0 and removed the battery for a few seconds after completion as per the instructions. I missed this bit in the instructions first time round.

I have not had a chance to use the camera since.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: mayteuk on August 14, 2012, 07:31:07 AM
I have tested a third party battery on my 7D on v2.0 firmware and it fires up no problem . still get unable to communicate with Battery but had that before. I only have battery as backup in case of emergency but it does work
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: JohnEasterly on August 14, 2012, 07:57:57 AM
Hi, there. At some german speaking forums user report problems with EOS 7D FW2.0 which started after the firmware update.

Problems reported:
- 1 (!) user reported that third party battery packs (weiss) were no longer recognized. This could not be confirmed by anybody so far. I guess this issue is not related to the firmware update.
- Some users report that the 7D freezes from time to time and can only be revived be removing and inserting the battery pack. There are multiple reports also from experienced user, so there is a chance that this issue is indeed related to FW 2.0.

Can you confirm one of the problems above?
I have had a freeze-up, happened once second day of upgrade, removed battery, re-started and it has not happened in 6 days
Did you experience other problems introduces with FW 2.0?
Please report.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: hoacker on August 14, 2012, 08:05:37 AM
Thank you for your replies so far.

Just in case anyone would like to revert to FW 1.2.5: Use EOSUtility 2.9.* or 2.10.*. Downgrade is no longer possible with EOSUtility 2.11.4.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: isacsfoto on August 14, 2012, 10:55:52 AM
I allso had that problem?! It´s not so cool to take out the batteri from time to time...
But all the other new stuff was superb!
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Mt Spokane Photography on August 14, 2012, 11:20:13 AM
Canon tells you to reset the camera after upgrading firmware.  It can end up with a combination of settings that no longer exist in the new firmware and cause some weird thinngs to happen.  I've had no issues with mine after the update, other than restoring all the settings after resetting it.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: tiger82 on August 15, 2012, 10:02:32 AM
It's time for my 7D's annual CPS clean and check.  I think I will ask them to upgrade the firmware before they do their system checks.  Then it's their problem (and mine too if there are issues, but they will be responsible for the problems caused by the upgrade).
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Trovador on August 15, 2012, 10:28:29 AM
So far so good.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: RLPhoto on August 15, 2012, 10:55:22 AM
Nope. Like a Rock or should I say? Magnesium Alloy?
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Goshdern on August 15, 2012, 11:30:59 AM
Has worked like advertised for me too...  Lovin auto iso at 400!
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Bruce Photography on August 15, 2012, 01:17:19 PM
I wish to give Canon my highest commendation on a free feature upgrade to a mature product.  I want to believe that they are just being nice.  I know they have their reasons but I'm at a loss to really understand it.  For my 7D I put in the new Lexar 1000x udma7 card for a quick shot of my kitchen in auto iso mode and I was getting 33 to 34 shots before it took a breath.  My reading before shooting said a buffer of 22 (not 25), but when I actually began shooting it was 34 shots.  I reformatted the card and reapeated the experiment six times and every time it was at least 33.  I tried the same experiment on the 5d3 and got 29 to 33.  Both impressive!!!!!! 

Good going Canon.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: viggen61 on August 15, 2012, 02:24:45 PM
The only issue I noted was a "blank" line on the "My Menu" screen where I had date & time before. Had to go in and remove it and replace it with Date/Time/Zone.

Other than that, it seems just fine. I'm even pleasantly surprised that the star ratings you can now set in camera via the Quick menu also copy over in the RAW file to Apple Aperture.  :D
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: 1255 on August 15, 2012, 03:10:00 PM
been working fine for me
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: AprilForever on August 15, 2012, 03:19:08 PM
Works like a boss!!!

I love my 7D even more now.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Paul W. H on August 15, 2012, 07:01:07 PM
I have had the freezing problem twice and at first thought that it might be that my CF card could not keep up with the increased speed in burst mode, since then this problem has appeared on a few websites.

The battery level indicator also showed 50.00% when it was almost full ??

Removing and replacing the battery for a few seconds solved the problem.

I have re-installed FW 2.0.0 and removed the battery for a few seconds after completion as per the instructions. I missed this bit in the instructions first time round.

I have not had a chance to use the camera since.

The story continues, we went out today and had 3 more lockups, followed by 2 "Er 30's" and then it just died. Tried removing the CR1616 battery to do a reset and nothing.

It had a genuine Canon battery in & Canon Lens on so god knows what has happened. To say that I am not a happy bunny is a complete understatement as we are going away at the weekend so I need this like a bloody hole in the head.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: haole on August 17, 2012, 05:25:31 PM
I have a problem after updating my canon. The burst rate is limited to 3 images length in RAW and 4 images in JPEG mode. I cannot figure out why. In RAW mode, previously it was written 15 and now 3 when I half press it. It bursts only 3 or 4 pictures and then just slow down. I have tested with Sandisk 16GB at  60MB/s and 32GB at 90MB/s and same thing. I am really confused as I am shooting surf sports a lot.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: mdm041 on August 18, 2012, 06:02:10 PM
I've gone through 4 battery charges and a few thousand pics since I updated and haven't had a single glitch.  I don't have any 3rd party gear so I can't comment on it.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: degies on August 19, 2012, 12:32:13 AM
I updated to v2 of the firmware. The auto iso limit was something I was long looking forward to and had it set first thing. I mainly shoot Av with AF expanson or Zone AF, but have no probem changing to M or any of my presets for HDR or to get what I want. I mainly have the 70-200 f2.8II on with the 2xIII for some reach if needed. 

Something I noticed yesterday was the AF at times had difficulty locking onto the subject. I switched to AF expansion and it got better, but I cannot remember having this issue before. 
Secondly with Auto Iso the shots was over exposed. I had the blinkies shouting at me after most shots. I fiddled with the EC but really only got it sorted going to M or setting iso to a manual setting. I mainly have white balance in Auto ,but it's almost like the metering was missing. Shots with a lot of contrast really stuffed up. 

Maybe it was just a bad camera day or maybe I just need to adapt to the new firmware or maybe the light on the day was just off, but I shure hope I get it sorted soon. :)

Oh  and the other stuff is nice too:)
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Click on August 19, 2012, 07:49:06 AM
No problems here so far.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: dwe on August 19, 2012, 10:29:29 AM
I can confirm the freezing of the camera.
I use original battery's and a replica grip. Sometimes it think it only happens when playback  the recently shot image but right now i can't confirm / reproduce that.

Dennis
Title: 7D firmware upgrade problems
Post by: DianeK on August 21, 2012, 08:05:45 PM
Is anyone here on this forum having ERR 30 issues on their 7D since upgrading the firmware as is being reported here:
http://photography-on-the.net/forum/showthread.php?t=1201244&page=78 (http://photography-on-the.net/forum/showthread.php?t=1201244&page=78)?
Diane
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: DianeK on August 21, 2012, 08:10:35 PM
Canon tells you to reset the camera after upgrading firmware.  It can end up with a combination of settings that no longer exist in the new firmware and cause some weird thinngs to happen.  I've had no issues with mine after the update, other than restoring all the settings after resetting it.

Do you do this by going to "clear all camera settings"?
Diane
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: DaveQ on August 22, 2012, 07:59:36 AM
No problems for me...working perfectly.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: CanonTuga on August 22, 2012, 02:53:35 PM
Hi,
This is my fisrt post in this forum and not for the best reasons :(:(:(...

I have two 7D bodies with two original batteries... i have checked battery info in both of them before updrade.
it happen that after upgrade to V2.0 (folowing recommended procedures) one the cameras is displaying an error message about being impossible to communicate wit the battery. I have checked the battery in the other body and it works fine; also the camera works if ignore the error but without any info about the battery.
I have already :
- reinstalled firmware
- removed the small battery and left the camera without both during some minutes
- recharged the battery to 100%
- put another battery from the other camera
Nothing has solved the problem:(:(:(...

 Anyone had  something similar after upgrade? or anyone can give a hint?

Thanks
Title: Re: 7D firmware upgrade problems
Post by: mdm041 on August 23, 2012, 10:32:38 PM
Nope!
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: holmanc on August 26, 2012, 09:15:39 PM
My 7D was locking up very frequently - every 15 minutes.  I reloaded 2.0 and was sure to take the battery out after the update.  I am sure i did the first time - but maybe not.  Now i am not having the issue.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Richard8971 on August 26, 2012, 11:28:53 PM
Installed V2.0 and so far so good. :) No lockup issues or perfromance issues.

D
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: cezargalang on August 27, 2012, 12:19:49 AM
Only when saving the image I edit in cam, It says "Saving movie" or something like that.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: davidchang on August 27, 2012, 12:53:48 AM
after about a week, no problems whatsoever!
one happy camper here :)
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Paul W. H on August 27, 2012, 02:15:57 AM
I have had the freezing problem twice and at first thought that it might be that my CF card could not keep up with the increased speed in burst mode, since then this problem has appeared on a few websites.

The battery level indicator also showed 50.00% when it was almost full ??

Removing and replacing the battery for a few seconds solved the problem.

I have re-installed FW 2.0.0 and removed the battery for a few seconds after completion as per the instructions. I missed this bit in the instructions first time round.

I have not had a chance to use the camera since.

The story continues, we went out today and had 3 more lockups, followed by 2 "Er 30's" and then it just died. Tried removing the CR1616 battery to do a reset and nothing.

It had a genuine Canon battery in & Canon Lens on so god knows what has happened. To say that I am not a happy bunny is a complete understatement as we are going away at the weekend so I need this like a bloody hole in the head.

To finish the story. I sent the 7D off to a Canon Repair Centre in the UK (CPS Silver Member) and got it back a week later after having the Printed Circuit Board (PCB) replaced at a total cost of £234.00 UKP (370.00 USD), they originally thought that it was the Shutter Mechanism causing the problem.

Did the firmware update cause the fault, who knows !!
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: azamiruddin on August 27, 2012, 03:59:55 AM
Hi all, good day,

I dont know whether this problem exist with previous firmware, but, everytime I switch ON my 7D, i need to enable AF Micro Adjustment every time --> by lens. i does not stay enable even though i not changing the lens.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: mucher on August 27, 2012, 04:52:02 AM
1) in flash menu, auto detecting lense length doesn't work, like 50mm lense suppose to let my 580ex zoom to 85mm, but it didn't happen, the flash stayed at 50mm
2) my 50L, are completely two lenses when in low light and in ourdoor ambient light, in low light I have to add +10 in microadjust lense shift, in good light there is no problem.
3) 7D might not be able to focus objects over 25 meters, but I don't have longer lense, for in 50L's f/1.2, all that is over 25meters might be in hyperfocal distance so I really couldnt tell, but my two 50/1.8 lenses couldn't focus over that distance, and that occurs 100%.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: mustafa on August 27, 2012, 06:58:36 AM
I didn't get the articulated LCD I was hoping for. ::)
Title: Re: 7D firmware upgrade problems
Post by: marek.sykora on August 27, 2012, 03:03:30 PM
No issue found in my 7D.

Image preview is faster, image rating is fine feature, but too deeply nested, so I don't use it. Max auto ISO works as expected, but I don't use it because to slow times are offerred when shooting with 85/1.8, I need to keep 1/200s and faster, no way to set up it ;( I don't use any other new features.
Title: Re: 7D firmware upgrade problems
Post by: Timothy_Bruce on August 27, 2012, 03:10:23 PM
all fine :)
Title: Re: 7D firmware upgrade problems
Post by: papa-razzi on August 27, 2012, 03:41:32 PM
No problems at all.   8)
Title: Re: 7D firmware upgrade problems
Post by: jsexton on August 27, 2012, 04:41:48 PM
Only issue I've seen was my intervalometer (Promaster 3070 I believe) now only works as a standard remote shutter release and only if the device is in the off position.  I can set the device for delay, exposure time etc, but the camera only takes a single image based on the last settings I used.  Strange, but it's a 3rd party so I'm not exactly surprised and I guess it's a change you take. 
Title: Re: 7D firmware upgrade problems
Post by: Click on August 27, 2012, 04:57:54 PM
No problems here so far.
Title: Re: 7D firmware upgrade problems
Post by: Mt Spokane Photography on August 27, 2012, 08:34:19 PM
I haven't seen a problem.  Try a complete camera reset. 
Title: Re: 7D firmware upgrade problems
Post by: DianeK on August 28, 2012, 06:42:30 PM
I haven't seen a problem.  Try a complete camera reset.

Is that the "clear all camera settings" option right above the firmware version in the menu?
Title: Re: 7D firmware upgrade problems
Post by: viggen61 on August 28, 2012, 10:11:40 PM
No issue with mine, either. Note the instructions call for the main battery (or batteries if you have a grip, as I do)  to be removed from the camera for a brief time to allow the new firmware to take full effect.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Timothy_Bruce on August 29, 2012, 07:41:48 AM
no problems but that  the SET-Button and the Upperdial  are absolutely functionless  in the new Playback-Q-Menu are  really annoying.
The dial could easily be used to change between the options or to cycle truth pictures.
And every time I rate a picture or protect one I hit the Set-button and nothing happens.
Also this Menu is really not practical to protect or rate more than ONE picture because I have to close it go to next picture and have to reopen it ... CANON please that is far away from elegant !!!
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: hoacker on August 29, 2012, 10:26:22 AM
Thanks to anybody who responded so far. Canon New Zealand has kind of confirmed the freeze issue with firmware 2.0. Read on here: http://photography-on-the.net/forum/showthread.php?t=1222669 (http://photography-on-the.net/forum/showthread.php?t=1222669)
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Pieces Of E on August 29, 2012, 12:20:15 PM
My 7D quit displaying the shot image for the 4 second setting I had it on. After turning off then on again, it started displaying the shot image again. Otherwise, I believe it is performing better than it did prior to the firmware update.
Title: Re: 7D firmware upgrade problems
Post by: Paul W. H on August 30, 2012, 05:46:26 PM
Checkout this thread

http://www.canonrumors.com/forum/index.php?topic=8646.0 (http://www.canonrumors.com/forum/index.php?topic=8646.0)
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: offcamber on September 21, 2012, 02:27:22 AM
Found this thread while googling "dead 7d after firmware 2.0 update". So I updated my 7d a couple of days ago to FW 2.0. It seemed to work fine and then tonight I turn it on and an error flashed on the LCD. I turned it off and then when I turned it back on, nothing happens. It's dead as a rock. I'm a little pissed right now. Tried removing the backup battery and letting it sit, but it's still dead after putting them back in. Replaced the CR1616 and nothing.  I'm guessing there is no way to remove the new firmware since I can't even get the camera to turn on. I guess I'll call Canon tomorrow and see what they say.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Paul W. H on September 21, 2012, 02:47:03 AM
Found this thread while googling "dead 7d after firmware 2.0 update". So I updated my 7d a couple of days ago to FW 2.0. It seemed to work fine and then tonight I turn it on and an error flashed on the LCD. I turned it off and then when I turned it back on, nothing happens. It's dead as a rock. I'm a little pissed right now. Tried removing the backup battery and letting it sit, but it's still dead after putting them back in. Replaced the CR1616 and nothing.  I'm guessing there is no way to remove the new firmware since I can't even get the camera to turn on. I guess I'll call Canon tomorrow and see what they say.

The trouble is that you will never know if the F/W caused the problem or if it was pure coincidence.

All I know is that it cost me a lot of money (£234.00 UKP / 370.00 USD) to repair my 7D
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: serendipidy on September 21, 2012, 03:09:24 AM
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: ishdakuteb on September 21, 2012, 03:48:54 AM
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.

i am not sure if this is the case but update a new version 2.0.3 will probably solve your problem "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect."

here is little more details about it http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/ (http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/)
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Paul W. H on September 21, 2012, 03:59:35 AM
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.

i am not sure if this is the case but update a new version 2.0.3 will probably solve your problem "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect."

here is little more details about it http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/ (http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/)

If it is like mine and dead you cannot turn it on to do the 2.0.3 update.

Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Heavyweight67 on September 21, 2012, 04:28:40 AM
I updated to FW 2.0 and had no problems, I noticed the thread re 2.0.3...initially I thought Nahhhhh, won't update as I had no issues with 2.0, in the end I succumbed and decided to update to 2.0.3...
The update completed with no apparent issues...

The next day I went out shooting, when reviewing some pics the quick selector/toggle button started to play up, I couldn't scroll up from the central position, I couldn't scroll diagonally, going into the menu, I couldn't scroll left or right or up.

I removed and replaced the batteries, which did nothing, turned the camera on and off again nothing..

After about 20 minutes trying various remedies I gave up and was reconsidering reinstalling 2.0 or 2.0.3 when I returned home.

I left the camera for another 20 minutes or so, checked it again and noticed that the "glitch" had repaired itself and the toggle button now worked....

I've had my 7D for a little over a year now, it is used every day, I've had no issues until the 2.0.3 update...

I haven't been able to repeat this issue (nor do I want to)...guess will have to wait and see if it occurs again..
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Danielle on September 21, 2012, 04:45:20 AM
I went to use the pop up flash a few days ago, for fill during my partner's exposure of all things. It came up with an error, which I too preoccupied to catch the exact text and restarted as if I turned it off and back on (in manual mode if one wants to know).

However it hasn't done anything else odd, nor has it done it again (just played with the pop up thing just then to make sure). So I have no idea. It has 2.0.3 installed.

I guess it needed anti anxiety pills that day, thats all. *shrugs*
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: 2n10 on September 21, 2012, 05:29:12 AM
I have had no issues with either update.  I just followed the instructions exactly to include removing the battery for at least 2 seconds.  I am knocking on wood nothing shows up.  I hope all who have experienced glitches with a recovery see no more issues and those who have lost use let us know what the issue was so that everyone will know what to do to correct the issue and hopefully avoid it.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: ud4steve on October 09, 2012, 07:47:28 AM
My camera has been working fine since the update, and I'm loving the new free features.
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: mucher on December 13, 2012, 05:37:12 AM
With firmware 2.0.3, 7D cannot register focus points anymore
Title: Re: EOS 7D FW2.0: Problems anyone?
Post by: Lorraine on January 04, 2013, 02:10:24 PM
Right from the beginning my 7d, 2 months old with firmware 2.0.3 had the freezing problem. No action possible after it went in sleep mode. Have to take the battery out. Is in repair now. So it is not true that the newest firmware tackles this problem, although canon claims that the version 2.0.3. "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect.". No way!!! I think it is about time that canon solves this problem now for once and for all. It's really annoying that I had tot take back my 7d after 2 months.