November 21, 2014, 01:02:47 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - MSP

Pages: [1]
1
Technical Support / Possible 7D Autofocus Issues
« on: February 09, 2013, 09:20:00 PM »
Hi,

This is my first post but I've checked out the CR many times and seen some high quality advice and insights so I'm hoping that some experienced 7D users can help me out.

My experience: I learned to shoot on a fully manual Minolta with a 50mm f1.7 over fifteen years ago and I've been shooting with a 30D for the last five years, maybe longer. I bought the 7D in mid-January 2013 and I've watched several hours of video tutorials, read some 3rd party books and read up on the AF system and custom functions to fill in any knowledge gaps from the 30D to 7D jump. In total I've taken around a thousand shots with the 7D (not a lot really, it's been a slow month with a lot of cold days...).

The problem: The 7D AF system that I've heard so many good things about has been utterly disappointing. I'm missing focus at least 75% of the time on still subjects and slow moving subjects that my 30D never struggled with. I haven't used AI Servo enough to judge whether it performs any better or worse than One Shot focus. The problem has been consistently inconsistent so I haven't been able to tweak the AFMA to compensate. I mainly use Single Point AF and Spot AF and will lock focus but then end up with blurry subjects even with good lighting and good contrast. There doesn't seem to be a consistent back or front focus, it just seems to randomly miss, often to a large degree. To be clear I'm not focusing and recomposing with a shallow DOF causing the focal plane to shift; the misses are happening even with smaller apertures. I've also had issues with AF "hunting" for several seconds when lighting is adequate (minimal focal distance and settings haven't been the issue, and it has happened with CFn III-4/Focus Search turned on and off). I've switched between full manual, shutter priority and aperture priority and the AF misses have happened regardless of what mode I'm in and what lens I'm using. The AF has been poor when shooting handheld, on a tripod and with a monopod. I mainly shoot with a 35mm f1.4L and 70-200mm f2.8L IS II but I have a 50mm f1.8 and 180mm f3.5L that have also had AF issues with the 7D (I don't count the AF hunting on the 180mm as a problem since that can happen with any body). I find it hard to believe that the lenses are the problem, they all seem fine on the 30D.

So now I can't help but wonder if I'm just lacking good technique (not impossible), if the AF on my new 7D isn't working correctly, if there's a setting I'm missing somewhere that could be the culprit or if my expectations are just too high. I can post my Custom Function settings if it's necessary but I've reviewed each and every one of them and can't imagine they're causing the AF to miss focus like it is. I've tried different combinations of shutter speeds (particularly with the 70-200mm), apertures and ISO/exposure settings and can't find any rhyme or reason as to why the focus works when it works or why it misses as it does most of the time.

One more bit worth noting is that the AF point appears in the correct place when reviewing photos, so it is registering and supposedly locking focus on that point. Also worth noting is that I can still return or exchange the camera within the next week.

Is my miss rate typical? Do I suck at focusing? Is this camera a lemon? Is the AF this inconsistent with most 7D's? Should I exchange it? Should I get a refund and go back to the 30D? Should I get a refund and drop the extra coin for a 5D Mark III?

Any advice would be appreciated. Just ask if you want and additional or more specific info. Thanks!

Pages: [1]