November 26, 2014, 09:25:03 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - madspihl

Pages: [1]
1
Lenses / 16-35L or related primes
« on: December 09, 2012, 08:04:10 PM »
I own the Canon 16-35L (and a bunch of other lenses for that matter), and basically I'd love som feedback on a choice I feel I'd like to make.

Either

1) keep the 16-35 and be happy with a really good all-round wide zoom which is quite sharp, has fast autofocus, and is often stuck on one of my camerabodies (mostly the 5D Mark II),

or 2) Sell the 16-35 and buy the following setup:

  • Canon 14L 2.8 / Zeiss 15 2.8 / Rokinon(Samyang) 14 2.8 (autofocus not a must for me at this focal length)
  • Canon 24L 1.4
  • Sigma 35 1.4 (decided I prefer to get this one over the Canon 35L after reading reviews and seeing samples of image quality on FF

Setup is for full frame. Currently the 5D Mark II and III.

Keep the price out of this equation. I have just decided that if photography is what I want to do as much as I can, even if it's purely as a hobby, why not invest more in fast lenses, since I love the aperture versatility of 1.4s (and 1.2s for that matter).

Also, in theory I don't mind having more lenses to swap between in the 16-35 range if it means better glass and more possibilities in terms of lens speed. But what's your take on the combo of faster-glass-but-more-lenses-to-swap versus the walk-around-wide-zoom?

Has anyone else gone through this process, and do you have thoughts about making a change like this?

I am not going to keep the 16-35 . It doesn't make sense to me to have it if I buy the primes - even if it has a nice walk-around kind of versatility. I just have a feeling I wont use it with the primes hanging around.

Oh - and at these wider focal lengths I shoot mainly landscapes, night skies, and some action sports (snowmobiling, bmx).

Thanks!

Mads

2
Technical Support / 5D mark II reading light wrong after fall
« on: September 03, 2012, 06:16:23 PM »
My 6 months old 5D Mark II took a bad tumble off a bench in rough seas and dropped app. 1 1/2 feet to a hard wooden floor, and after that it started overexposing everything, as if there's not enough light reaching the sensor or something.

The 70-200 2.8 II lens that was on the camera was not hurt at all (which just proves how incredibly sturdy that wonder of a lens is, I guess) and the camera body also looks completely unhurt. No other functions seem to be affected by the accident, and all menu options are available. And the issue persists no matter what lens I test the camera with.

I tried updating the firmware (I hadn't installed the latest version for some reason) after the incident, just to check if it might just be a shake-up somewhere in the system. But that didnt work.

Obviously the camera needs service - but I am just wondering if anyone might have an idea what could've happened? Just seems strange to me that ONLY the light metering is off.

Pages: [1]