December 22, 2014, 04:28:17 PM

Author Topic: Unreliable AF on 7D with FW 2.0.3?  (Read 18293 times)

Chris_prophotographic

  • Rebel T5i
  • ****
  • Posts: 111
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #15 on: October 12, 2012, 02:36:09 PM »
REASON why i back-dated the burst amount when from 22 frames to 4 then buffer stutter, yes 4. I freaked and was lucky it was a easy enough fix.
1D X, 7D, 70-200mm MK II, 24 L MK II, 35 L, 10-22, 40mm,  Samyang 8mm, 50 1.8 mk II, PW II's
PW III's , MultiMax's, TT5's 580 II's, SB-28's

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #15 on: October 12, 2012, 02:36:09 PM »

Krob78

  • 1D X
  • *******
  • Posts: 1329
  • When in Doubt, Press the Shutter...
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #16 on: October 12, 2012, 03:15:07 PM »
My focus changed after updating.  Wasn't sure what was going on, like you guys said, the AF would signal for lock on, but the images were OOF. 

I set up my normal routine for MFA and all my lenses had to be recalibrated back to near -0- levels!  I was pleased that the corrections were needed and completely fixed it... my 70-200mm f/2.8 IS II was originally MFA'd to +5, now it's set to +1.  It's shooting excellent and tack sharp.  My 100-400mm had to be recalibrated as well and went from +3 to -1.  My 17-55mm needed no further MFA adjustments...

I haven't had any issues since.  I have my 7d set to "each lens" rather than set to mfa "All" the same...

MFA worked perfectly, that being said, I was curious as to why I need to AMFA again, but I'm loving it nonetheless... very pleased with the images my lenses and camera are producing...
Ken

5D Mark III, 100-400L, 70-200 2.8L II, 24-105L, 16-35L IS, 17-40L, 85mm 1.8, Samy 14mm 2.8,  600 EX-RT, 580EX II, 430EX II, 1.4X III, 2.0X III

JaxPhotographer

  • PowerShot G1 X II
  • ***
  • Posts: 35
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #17 on: October 12, 2012, 03:22:47 PM »
I just did the firmware update on my 7D but have not had a chance to test the AF. Hopefully I will have time this weekend and if I see issues do an AFMA. I will report back once I do and add my observations to this post.
5DMKIII | 7D | 16-35L f/2.8 II | 24-105L f4 | 70-200L f/2.8 IS I&II | 50 f/1.8 | 85 f/1.2 II |1.4x & 2x Ext | 100mm f/2.8L IS | MT-24EX Macro Twin Lite | 2x600EX-RT | ST-E3-RT | 430EX Speedlite | Sekonic L-758DR | Induro CT314 Tripod | Arca-Swiss Monoball Z1 dp  |

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #18 on: October 12, 2012, 06:55:24 PM »
Well I think it's really strange that others are experiencing (to various degrees) what I am.
Canon didn't officially change anything related to the AF-system, but obviously there is something wrong here.

Does anyone know if Canon has some kind of issue-report-system?

carlc

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #19 on: October 12, 2012, 08:02:29 PM »
UPDATE:  As I replied earler, I was also having focusing issues.  Believe it or not, a fresh battery solved my focusing and focusing confirmation in viewfinder issues.  All is working fine now and leads me to believe that the FW update may have adjusted power usage in some way.

FirstL

  • SX60 HS
  • **
  • Posts: 5
    • View Profile
    • SASIMAGES
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #20 on: October 12, 2012, 08:05:50 PM »
Ditto here, mine hunts and sometimes gives me a focused green symbol then starts hunting again and it wasn't in focus through the viewfinder when it gave me the green symbol to represent in focus....  If I manually focus it hunts a little and goes back to focus okay.  Same thing, 7D, new version of firmware, med to low light set to AF.

FirstL

  • SX60 HS
  • **
  • Posts: 5
    • View Profile
    • SASIMAGES
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #21 on: October 12, 2012, 08:25:06 PM »
Tried the new battery in mine also and it's focusing okay now.

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #21 on: October 12, 2012, 08:25:06 PM »

MARKOE PHOTOE

  • EOS M2
  • ****
  • Posts: 188
  • Photography is a love affair with life.
    • View Profile
    • http://www.markoe.smugmug.com
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #22 on: October 12, 2012, 08:26:29 PM »
ditto here too.  Having some of the same troubles with Ai Servo mode.  One thing I've noticed is mostly when using Canon battery grip, make sure batteries are fully charged when you start and the connection to the body is tight and clean.  I'm using a 70-200 2.8L II and a 70-300L and occasionally a 200 f2.8L prime.  Not too pleased with this latest firmware update.
A few cameras and lenses and a lot of creative energy and imagination.
"You never learn anything until you mess it up."

AudioGlenn

  • Canon 6D
  • *****
  • Posts: 351
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #23 on: October 12, 2012, 09:53:57 PM »
nice to know there's a simple fix out there.  hopefully Canon addresses the issue in the next firmware update.
5D mkIII  |  40 f/2.8 | 8-15 f/4L | 24-70 f/2.8L II | 70-200 f/2.8L IS II | 1.4x III TC | 600ex-rt | 430 ex ii | EOS M+22mm f/2 | EF to EF-M adapter

Richard8971

  • Canon 6D
  • *****
  • Posts: 388
  • "There is no spoon" - Neo
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #24 on: October 12, 2012, 11:07:18 PM »
I have been running the 2.0.3 firmware for a little while now and I haven't noticed any serious problems. In fact, IMO, the update has been great. I love my 7 even more and can't wait to get it out and shoot more photos. For what it's worth, I always charge my batteries (I use the BG-E7 grip) after each shoot. Focus for me has been fast and accurate. Hand held shots are always a risk, mainly because YOU may be the cause of blurry photos because of hand shake and moving around. (It does not take much at all...). :)

D
Canon 6D, 5D2, 7Dv2.03, 50D, 40D, T1i, XTi...XT (& lenses, flahses), various powershots... You get the idea... I have a problem. :)

Wife shoots Nikon, D7000, D7100, (lenses and flashes)... we constantly tease each other that our cameras are better than each others!

jrista

  • Canon EF 400mm f/2.8L IS II
  • *********
  • Posts: 4817
  • EOL
    • View Profile
    • Nature Photography
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #25 on: October 12, 2012, 11:36:13 PM »
I have noticed different problem in my 7D after upgrading the F/W. The top LCD display displays the camera setting values even when I switch off the camera. It is sort of hung, power on/off do not have any effect. The only option is to remove the battery and reinsert it. This happens quite frequently say once in two or three days. Very annoying.

I've noticed this as well. I have also noticed that the camera does not seem to automatically power off after my configured timeout...according to the LCD, it is always on. There does not seem to be any "wake up" delay when I press the shutter button, and my battery has not been lasting quite as long.

I am not sure I've noticed actual mis-focus after I take a shot, I have experienced increased AF hunting, and slower AF speed in general (I primarily use AI Servo). Phase detection does not seem to work quite as well as it did before the 2.0.3 update. Even when I am fairly close to already focused, I'll experience hunting rather than a short, direct adjustment like I used to. I've swapped my batteries a few times since updating the firmware...does not seem to have resolved the issue.

Sounds like the 2.0.3 firmware update is a bit screwed up. Canon needs to do some more rigorous testing before they release firmware updates. :(

2n10

  • Canon 7D MK II
  • *****
  • Posts: 497
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #26 on: October 13, 2012, 06:54:37 AM »
I have had no issues with mine since the update.
Canon EOS 7D Mark II and EOS 7D, EF-S 10-22, EF-S 17-55, EF 100 Macro, EF 50 1.4, EF 70-300, EF 100-400L

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #27 on: October 13, 2012, 08:55:13 AM »
Sorry, but a fresh newly charged battery does not work for me :(
I've tried both with and without the BG-E7 grip. No change :(

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #27 on: October 13, 2012, 08:55:13 AM »

CharlieB

  • Canon 70D
  • ****
  • Posts: 302
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #28 on: October 13, 2012, 09:46:32 AM »
With limited, and perhaps somewhat dangerous knowledge of things...  some precautions may be in order.

Sorry to say - writing down your AFMA settings, any other "must be set" CF's, and then resetting the camera to its default BEFORE doing the upgrade, may be a safer way.

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #29 on: October 13, 2012, 10:31:41 AM »
With limited, and perhaps somewhat dangerous knowledge of things...  some precautions may be in order.

Sorry to say - writing down your AFMA settings, any other "must be set" CF's, and then resetting the camera to its default BEFORE doing the upgrade, may be a safer way.
That is ofcourse a good rule to follow. But that's not what causes this issue Im afraid..

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #29 on: October 13, 2012, 10:31:41 AM »