July 23, 2014, 10:59:57 AM

Author Topic: Unreliable AF on 7D with FW 2.0.3?  (Read 15860 times)

FirstL

  • SX50 HS
  • **
  • Posts: 5
    • View Profile
    • SASIMAGES
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #45 on: October 15, 2012, 08:32:07 PM »
I found that the focus on mine had actually changed to zone focus, left side.  I've never used zone focus.  New battery and correcting focus setting corrected the issue.  That's the only thing I found wrong after the firmware upgrade.  Hope there's not any more lurking.  Next time I'm going to wait and see if there are issues before jumping in and upgrading.

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #45 on: October 15, 2012, 08:32:07 PM »

jrista

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 3707
  • POTATO
    • View Profile
    • Nature Photography
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #46 on: October 16, 2012, 01:27:22 AM »
Just to make sure everyone here followed the same procedure I did. The new battery trick...its not really a trick. That was actually explicitly listed as a REQUIREMENT in the instructions for flashing the firmware. Canon was fairly explicit about the fact that the firmware upgrade would not fully "kick in" until the camera was powered off and the battery removed for a little while.

If you flashed your 7D and have not yet powered it off and removed the battery, do so now. It is a required part of the upgrade procedure.
My Photography
Current Gear: Canon 7D | Canon EF 600mm f/4 L IS II | EF 100-400mm f/4.5-5.6 L IS | EF 16-35mm f/2.8 L | EF 100mm f/2.8 Macro | 50mm f/1.4
New Gear List: Canon 5D III/7D II | Canon EF 300mm f/2.8 L II

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #47 on: October 16, 2012, 04:13:41 AM »
Just to make sure everyone here followed the same procedure I did. The new battery trick...its not really a trick. That was actually explicitly listed as a REQUIREMENT in the instructions for flashing the firmware. Canon was fairly explicit about the fact that the firmware upgrade would not fully "kick in" until the camera was powered off and the battery removed for a little while.

If you flashed your 7D and have not yet powered it off and removed the battery, do so now. It is a required part of the upgrade procedure.
Did that, exactly as the update instructions said.

strikerwy

  • Power Shot G16
  • **
  • Posts: 16
    • View Profile
    • Tim Doolin Photography
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #48 on: October 16, 2012, 09:07:31 AM »
This issue frsutrated me so badly, as I had an essentially worthless body on my hands, that I started researching how to roll back the update.  In the process of finding out that such a manuever is essentially impossible for the consumer, I hooked the camera to my laptop and realized through EOS Utilities that I only had Firmware update 2.0.0.  With nothing better to do, I went ahead and installed 2.0.3 and it appears to have solved my problem.  Otherwise I had every symptom the OP was experiencing, to such a bad extent that I couldn't use the camera.  I've shot 120000+ images with the body, so to have it just go kaput after a firmware update is totally unacceptable and an obvious sign that the update was the clear culprit.  Canon needs to figure this one out in a big hurry.

You might try reinstalling the update and pray that solves the issue.
5D III, 7D, 70-200 2.8 MkII, 24-105, 16-35, 10-22 EF, Sigma 50-500 OS, 300-800 Sigmonster, Tamron 24-70 2.8 VC and a boatload of Canon speedlights.

Chris_prophotographic

  • Rebel T5i
  • ****
  • Posts: 111
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #49 on: October 16, 2012, 09:44:56 AM »
You can roll it back
1D X, 7D, 70-200mm MK II, 24 L MK II, 35 L, 10-22, 40mm,  Samyang 8mm, 50 1.8 mk II, PW II's
PW III's , MultiMax's, TT5's 580 II's, SB-28's

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #50 on: October 16, 2012, 02:05:36 PM »

Chris_prophotographic

  • Rebel T5i
  • ****
  • Posts: 111
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #51 on: October 16, 2012, 06:39:02 PM »
DID you read up on few of my posts here,  On a PC its basically a bait and switch get the EOS util to think you giving it he current firmware say 2.03 and just before it loaded it rename and replace it with the old one renamed to the current firmware (some guy online had all the firmwares stock piled, so you could go back to any version you want)


http://magiclantern.wikia.com/wiki/7D_support

http://www.canonrumors.com/files/eos7d125.zip

if you have a PC i could guide you, MAC only im a bit lax on the file tricks

1D X, 7D, 70-200mm MK II, 24 L MK II, 35 L, 10-22, 40mm,  Samyang 8mm, 50 1.8 mk II, PW II's
PW III's , MultiMax's, TT5's 580 II's, SB-28's

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #51 on: October 16, 2012, 06:39:02 PM »

K3nt

  • Canon 70D
  • ****
  • Posts: 269
  • "No good photo goes unnoticed!"
    • View Profile
    • Flickr
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #52 on: October 17, 2012, 05:55:00 AM »
Been running 2.0.3 on my 7D ever since it came out and haven't seen any of the issues reported.
Flickr

Canon EOS 7D * 10-22mm EF-S * 50mm f/1.4 * 70-20mm f/2.8L IS USM MkII * Nissin 866Di MkII * 430EXII + accessories

Chris_prophotographic

  • Rebel T5i
  • ****
  • Posts: 111
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #53 on: October 17, 2012, 11:37:10 AM »
Might be your Body, my body purchased in Nov of 09 feels a DOT heavier and the buttons different than a friends purchased in 2011. Especially the back wheel has a heavier click.
1D X, 7D, 70-200mm MK II, 24 L MK II, 35 L, 10-22, 40mm,  Samyang 8mm, 50 1.8 mk II, PW II's
PW III's , MultiMax's, TT5's 580 II's, SB-28's

Scratchen

  • Guest
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #54 on: October 21, 2012, 05:42:31 AM »
Just wanted to let you all know I redid the firmware update twice (same procedure as the first time, followed Canons update instructions). The AF seems to be OK now..
This is really strange!

Micos

  • SX50 HS
  • **
  • Posts: 4
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #55 on: June 28, 2014, 11:18:50 PM »
This topic has been quiet for a long time but it was the only answer to mu IMMENSE frustration with 7D.
I have been through hell with brand new 7D body since day one (Oct.2012), it had and still has exactly the same problem other were mentioning: intermittent HEAVY front focus while showing green light confirmation in the WF.
The lenses affected are in the 17-50 2.8 range of any make: be it Canon`s original 17-55 or Sigma 17-50 or Tamron 17-50 anywhere between 10-30% of images end up useless with catastrophic front focus AF failure. It has nothing to do with AFMA, all lenses focus correctly - until camera occasionally goes wild. At medium to long distance the error can be measured in meters not inches. Medium to low light conditions can 'improve" failure rate up to 50%!! I sent the camera back to Canon for check up almost straight out of the box, got it back the same with remark that "camera was within the specs" and since I had Sigma 17-50 2.8 OS at the time "it might not work correctly with Sigma." BTW that same Sigma worked flawlessly on my 40D and 50D...So much about canon`s support. So I sold Sigma and got canon 17-55 Is - only to get same if not worse results...  >:( so I got Sigma lens again. Camera came with 2.0.3 software installed so I could not compare with older versions but it seems that downgrading  to 2.0.0 or lower worked for someone here, right? Funny thing is that other lenses I have (50/1.4,  70-200/4 L IS, 85/1.8, 200/2.8 L, 18-55 kit lens ) work more or less fine, 18-55 3.5-5.6 cheapo kit lens being dead-on 99%  :o  Also,  I tried 3 brand new 7Ds (including mine) with 2.0.3 firmware - all three had exactly the same problem. Any comment and suggestion would have been HIGHLY appreciated. How I can get and try to downgrade firmware and is there any risk associated with that? Thanks...
UPDATE:  downloaded version 2.0.0 (would not go further than that) just waiting the comment is it safe to take this downgrade route.
« Last Edit: June 29, 2014, 02:22:06 AM by Micos »

zim

  • 5D Mark III
  • ******
  • Posts: 666
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #56 on: June 29, 2014, 03:41:23 AM »
Micos the latest version is 2.0.5, should you not try that first before downgraded?

Regards

Micos

  • SX50 HS
  • **
  • Posts: 4
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #57 on: June 29, 2014, 11:58:05 AM »
Micos the latest version is 2.0.5, should you not try that first before downgraded?
Regards

Right now I am on 2.0.5 and no change, problem is still there - if not worse.

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #57 on: June 29, 2014, 11:58:05 AM »

Micos

  • SX50 HS
  • **
  • Posts: 4
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #58 on: June 29, 2014, 02:13:15 PM »
So, I am out of hope, downgraded firmware to 2.0.0 and after about 100 shots got again that dreadful front focus error on Sigma 17-50 2.8 OS at 17mm. Even EF-S 18-55 3.5/5.6 had a few bad ones at 18mm, not as catastrophic as Sigma but still way out of focus. Time to ditch 7D and move on I think...too bad as I otherwise loved the camera.
« Last Edit: June 29, 2014, 02:31:48 PM by Micos »

sama

  • EOS M2
  • ****
  • Posts: 155
    • View Profile
Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #59 on: June 29, 2014, 03:40:11 PM »
Anybody tried this method : Canon 7D Missed Focus Hard Reset Fix


https://www.youtube.com/watch?feature=player_detailpage&v=yrJDjftcgX0
« Last Edit: June 29, 2014, 03:43:41 PM by sama »

canon rumors FORUM

Re: Unreliable AF on 7D with FW 2.0.3?
« Reply #59 on: June 29, 2014, 03:40:11 PM »