October 23, 2014, 10:18:38 AM

Author Topic: 430 EX II FLASH  (Read 1807 times)

BPO

  • SX60 HS
  • **
  • Posts: 4
    • View Profile
430 EX II FLASH
« on: October 14, 2012, 09:52:19 AM »
When my 430ex ii flash is on the camera it works great.  When it is not connected it will not fire a flash.  When I hit the test flash button it makes a loud noise and light comes out but it's not in a flash like its supposed to be.  Plus when I use it off camera with pocket wizards it wont flash either.  Anyone have any ideas.

canon rumors FORUM

430 EX II FLASH
« on: October 14, 2012, 09:52:19 AM »

Klaus

  • Guest
Re: 430 EX II FLASH
« Reply #1 on: October 14, 2012, 10:31:04 AM »
What camera body are you using it on? On my 60D if it is not connected I have to go into the menu and change it to allow off camera firing. All the same I don't recall my 430 ex II ever acting up like that.  :-\

Alrik89

  • PowerShot G1 X II
  • ***
  • Posts: 60
    • View Profile
Re: 430 EX II FLASH
« Reply #2 on: October 14, 2012, 11:01:50 AM »
rtfm

There is a whole topic about it.

BPO

  • SX60 HS
  • **
  • Posts: 4
    • View Profile
Re: 430 EX II FLASH
« Reply #3 on: October 14, 2012, 02:08:05 PM »
Do you remember what page Alrik.  I just read through the manual and didn't see anything like I am talking about.  I checked the troubleshooting tips also and didn't see anything either.

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14729
    • View Profile
Re: 430 EX II FLASH
« Reply #4 on: October 14, 2012, 02:21:32 PM »
When I hit the test flash button it makes a loud noise and light comes out but it's not in a flash like its supposed to be.

That sounds like modeling flash, which can be set to fire with the Pilot/Test button with C.Fn-02.
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

BPO

  • SX60 HS
  • **
  • Posts: 4
    • View Profile
Re: 430 EX II FLASH
« Reply #5 on: October 14, 2012, 02:32:01 PM »
Thanks Neuro.  That is what is was.  I don't know how it got set to that, must have been bumped before it was turned off last time I used it.  Thanks again.

Marsu42

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4817
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: 430 EX II FLASH
« Reply #6 on: October 14, 2012, 02:34:14 PM »
When I hit the test flash button it makes a loud noise and light comes out but it's not in a flash like its supposed to be.
That sounds like modeling flash, which can be set to fire with the Pilot/Test button with C.Fn-02.

It is, but on my 430ex2 it's more like a gentle buzz like from an electric shaver. Can't help you with the pw, but if the noise from the modeling flash is indeed loud something could be broken.

canon rumors FORUM

Re: 430 EX II FLASH
« Reply #6 on: October 14, 2012, 02:34:14 PM »