August 31, 2014, 04:22:48 AM

Author Topic: weird behavior on brand new t4i,plus some comments  (Read 760 times)

samkatz

  • PowerShot G1 X II
  • ***
  • Posts: 56
    • View Profile
weird behavior on brand new t4i,plus some comments
« on: November 30, 2012, 11:00:04 AM »
T4i  was taking some shots in the living room, and the lcd screen just went dead...no playback, no info, nothing.....had to do a battery pull to get it back. Battery charge is ok. I wasn't blocking the face sensor in back.  Anyone hear of this?



Overall, first 24 hours w/T4i + 18-135 IS STM very impressed, coming off a 60D and Xsi.

Pro's: Lens - Build much stronger than I expected. Fast focusing, really dead quiet(on stills)
Cons: Heavier than I expected(0f course, built is more like the 15-85 than the 18-55)
haven't test IQ yet

Body:
Pros
 Live view very improved over 60D. very easy to focus in ordinary room light using live view,
Like touch screen a lot, but not a game changer.
Shutter sound seems quieter than 60D
Small, light
Seems to focus faster in normal AF modes than 60D
Frame rate not bad for rebel
Big fat ISO button on top...never liked the D series small, indistinguishable buttons.

Cons:  4 way control buttons harder to push than on xsi...smaller, more indented.
I can't believe they can't give you more ISO options, how much would that cost? You go from 800 to 1600 w/nothing in between like on past Rebel series.

Battery/Charger. Don' like the two piece chord/charger set up vs having plug directly on charger.
Battery hard to get in and out of charger, almost like an off-brand battery I once bought.







canon rumors FORUM

weird behavior on brand new t4i,plus some comments
« on: November 30, 2012, 11:00:04 AM »