September 18, 2014, 05:55:34 PM

Author Topic: 5D III auto focus not working after using Reikan FoCal  (Read 2405 times)

melbournite

  • Rebel T5i
  • ****
  • Posts: 128
    • View Profile
5D III auto focus not working after using Reikan FoCal
« on: December 06, 2012, 09:21:32 PM »
Hi guys, wondering if someone has encountered same issue that might have an easy resolve and save me having to take the camera in under warranty.

I finally decided to buy FoCal and calibrate all my lenses together with my 5DIII and 5DII.  All went well except now the 5DIII is not auto focusing in any setting other than Full Auto (green) mode, and video mode while pressing AF-ON.  So basically the focus system simply does not respond (like it was in manual focus). 

I've tried:
-different lenses
-checked lens was in AF
-changed batteries
-'clear all camera settings'
-disable AF microadjustment

I'm assuming it will be a software issue and hoping someone might have an easy resolve.  I'd appreciate any ideas.

canon rumors FORUM

5D III auto focus not working after using Reikan FoCal
« on: December 06, 2012, 09:21:32 PM »

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14396
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #1 on: December 06, 2012, 09:27:39 PM »
Have you tried pressing the AF-ON button?
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

melbournite

  • Rebel T5i
  • ****
  • Posts: 128
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #2 on: December 06, 2012, 09:32:23 PM »
Hi neuro, yes that seems to work perfectly.

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14396
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #3 on: December 06, 2012, 09:42:40 PM »
Sounds like the Custom Controls settings got changed, and you've got back button AF (see the Canon DLC article) set up. 

My advice - leave it that way!  Back button AF is great, once you get used to it.  By separating the AF start from the shutter button, if you need to focus-recompose, you can take multiple shots without moving the camera. In AI Servo, you can control when to track and when not to, independent of when you take the shot.

But, you can go into the Custom Controls screen (Shooting menu 2), and re-assign Metering + AF Start to the shutter button to set things back to normal.
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

melbournite

  • Rebel T5i
  • ****
  • Posts: 128
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #4 on: December 06, 2012, 09:51:20 PM »
Neuro, you are a genius!  Problem solved but I did not change any custom controls myself (not consciously anyway)?  Maybe FoCal did somehow (it did crash on me twice).  Anyway, I am so happy.

Thank you for those tips, I might have to try them out.  Is that the way you have your cameras set up permanently?
« Last Edit: December 06, 2012, 09:53:52 PM by melbournite »

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14396
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #5 on: December 06, 2012, 10:13:15 PM »
Glad that helped!  FoCal changes several settings, but I wasn't aware that was one of them.  Often there's an option to restore camera settings after a crash, sometimes not, though.

Yes, I use back button AF exclusively.  Only time it's an issue is if you hand your camera to someone else.  On the 5DIII, though, you can just set it to green square/A+ in that case (no full auto on a 1-series).  As you learned in troubleshooting your issue, that mode cancels out customizations like back button AF (but it still shoots in RAW if that's how it was set).
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

melbournite

  • Rebel T5i
  • ****
  • Posts: 128
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #6 on: December 06, 2012, 10:32:12 PM »
Thank you again.  Very informative.

canon rumors FORUM

Re: 5D III auto focus not working after using Reikan FoCal
« Reply #6 on: December 06, 2012, 10:32:12 PM »

bvukich

  • Spam Assassin
  • Administrator
  • 5D Mark III
  • *****
  • Posts: 730
    • View Profile
    • My (sparse) ZenFolio Site
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #7 on: December 07, 2012, 12:20:43 AM »
Lol...  I had the same thing happen, but with Magic Lantern on my 60D.  Everything was cool for a month or two, then all of a sudden AF stopped working... of course I freaked out, but eventually figured it out.  It kept setting it like that every time the camera was turned off for a couple weeks, then stopped as suddenly as it started. All with the same version of ML too.  It was weird, and the fact I rarely turn off my camera except to swap batteries made it hard to correlate to some specific setting I changed.

fegari

  • Rebel SL1
  • ***
  • Posts: 91
    • View Profile
    • My 500px
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #8 on: December 11, 2012, 04:43:20 PM »
Same here with my 5D3...after the initial panick and after resetting the darn settings got the AF back...

Mt Spokane Photography

  • Canon EF 600mm f/4L IS II
  • ********
  • Posts: 8658
    • View Profile
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #9 on: December 11, 2012, 06:51:12 PM »
Reikan Focal has a option to save your camera settings and download them to your computer.  Do it before starting a AFMA.  That way, if the process fails, you can restore your camera settings.

EvilTed

  • Guest
Re: 5D III auto focus not working after using Reikan FoCal
« Reply #10 on: December 11, 2012, 07:38:01 PM »
What Neuro said.
Another advantage of back button focus on the 5D MK3 is it enables Zeiss manual lenses (at least the 35mm F/2 I have) to focus pretty damned accurately.

1) Tap shutter to meter.
2) Push and keep AF-ON button engaged.
3) Rotate focus ring slowly until focus highlight turns red and camera beeps.

I'm shooting at F/2.8 and F/4 and so far it works very reliably :)

ET

canon rumors FORUM

Re: 5D III auto focus not working after using Reikan FoCal
« Reply #10 on: December 11, 2012, 07:38:01 PM »