April 21, 2014, 01:12:51 AM

Author Topic: Error 01 lost comms with lens - should I get a repair ?  (Read 1177 times)

Dpickup

  • PowerShot G16
  • **
  • Posts: 7
    • View Profile
Error 01 lost comms with lens - should I get a repair ?
« on: February 04, 2013, 03:28:55 AM »
Hi All,

I've been using a Sigma 18-200 DC OS HSM lens for about 5 years now, and in July I replaced my 400d with a 650d.
Everything was fine, and I'd been using the lens on a regular basis with no issues until about two weeks ago when I started to get the Error 01 message.

tried var tricks seen in other places about cleaning the contacts, changing to AV mode and setting aperature, but it still does it, sometimes immediately sometimes after a dozen shots. Interestingly at the weekend (was -10 degrees C outside) it failed instantly as soon as I tried taking a picture outdoors.

was worried it may be the Camera but it worked perfectly with other lenses this weekend and when I got back home I could recreate the fault pretty reliably indoors after about a dozen shots.

So, anyone got any suggestions how to resolve or am I looking at a repair / replacement
Repair may be least favoured as its 5 years old and probably done about 90,000 shots with it, but if its a known fault and a quick fix the bank balance would prefer this option.

any suggestions ?

Thanks
David

canon rumors FORUM

Error 01 lost comms with lens - should I get a repair ?
« on: February 04, 2013, 03:28:55 AM »

Menace

  • 1D Mark IV
  • ******
  • Posts: 925
  • New Zealand
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #1 on: February 04, 2013, 03:35:43 AM »
IMHO, sounds like a repair / service issue. Depending on that cost, a new lens may be a better investment for the future.

cheers
5D III | 6D
50 1.2L | 85 1.2L II | 100 2.8 | 400 2.8L IS II 
24-70 2.8L II | 70-200 2.8L IS II

M.ST

  • Guest
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #2 on: February 04, 2013, 06:09:15 AM »
After a lot of years the lens is not worth to repair it. Better buy a new one.

pato

  • PowerShot G1 X II
  • ***
  • Posts: 56
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #3 on: February 04, 2013, 07:19:04 AM »
Just to be sure it's not a lens software issue. Put the camera into manual mode, change the aperture to 10 and take a picture.
Otherwise it indeed might be the lens. Do you live in a country where you get 10 years warranty from Sigma?

Dpickup

  • PowerShot G16
  • **
  • Posts: 7
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #4 on: February 04, 2013, 08:11:34 AM »
Hi Pato,

no tried that I'm afraid, sometime sit fixes it for a few shots, sometime no improvement.

Just called Sigma in the UK and they quoted £98.99 for a a repair as they think its the iris.
they will examine the lens, call me if its anything worse, otherwise would be a fixed price repair which seems reasonably fair.

However as a few of you have commented not sure i want to sink more money into a relatively old / cheap lens, so am currently looking at new replacement.

what is "normal" life expectancy of a lens ( I know the L series should last forever !) but other lenses ?
100,00 shots ?
200,00 ?
 
Thanks
David

sandymandy

  • 6D
  • *****
  • Posts: 598
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #5 on: February 04, 2013, 08:13:32 AM »
I dont think there is some kind of "life expectancy" for lenses. 18-200mm is not a good lens anyway maybe its just time to upgrade :)

J.R.

  • 1D X
  • *******
  • Posts: 1433
  • A Speedlight Junkie!
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #6 on: February 04, 2013, 08:25:05 AM »

what is "normal" life expectancy of a lens ( I know the L series should last forever !) but other lenses ?
100,00 shots ?
200,00 ?


Lens life is not related to the shutter actuations.

The usual factors affecting lens life are fungus (avoidable), electronics (non-avoidable) and if production of a lens is discontinued, the rubber rings and gaskets (in the absence of spares).
Light is language!

canon rumors FORUM

Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #6 on: February 04, 2013, 08:25:05 AM »

Dpickup

  • PowerShot G16
  • **
  • Posts: 7
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #7 on: February 04, 2013, 04:50:52 PM »
Right sod the budget - 24-105L has now been ordered and I'll play with a few different 70-300s to see if i go for the 4.5-5.6, the L series or the DO

(My wife is going to kill me)

David

sandymandy

  • 6D
  • *****
  • Posts: 598
    • View Profile
Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #8 on: February 05, 2013, 11:14:48 AM »
smart choice. 18-200 is like the worst lens from canon...

canon rumors FORUM

Re: Error 01 lost comms with lens - should I get a repair ?
« Reply #8 on: February 05, 2013, 11:14:48 AM »