September 26, 2017, 03:18:11 AM

Author Topic: Canon 100-400mm L EF mount alignment question  (Read 2893 times)

CANONisOK

  • EOS M5
  • ****
  • Posts: 160
Canon 100-400mm L EF mount alignment question
« on: April 22, 2013, 03:18:47 PM »
Good afternoon, I have a question for the group regarding the EF mount on the 100-400mm L. I just received the lens on Saturday and tested it out this weekend. I am very impressed with the optical performance of the copy I received. Will enjoy having the extra reach on my 5D3.

However, one issue that I noticed immediately is the difficulty in getting the proper alignment when mounting this lens to the camera. For a pretty simple system (align the red dots, insert lens to mount, rotate clockwise) this lens required 5 or 6 attempts to get aligned and mounted each time I put it on the camera. The lens hardware seemed to want to go in the mount in a non-normal orientation. I've never experienced this with any other lens on this or previous cameras I've owned.

Looking at the bayonet mount, I could not detect anything different than my other lenses which would cause these alignment issues - but I'll look closer again today after work.

My question to the brain trust is this: Has anyone else had issues with the EF mount on this specific lens (or specifically with a 5D Mark iii)? I hate to send back a lens which is optically good if this is a universal attribute of this specific lens. However, I don't want to keep it if this is not a common issue and risk damaging the mount on my 5D3.

Thanks in advance for any experience you all can share.
A few bodies, some flashes, a tripod here and there, a handful of lenses. Plenty of equipment, a lot of perseverance, but not enough talent (yet).

canon rumors FORUM

Canon 100-400mm L EF mount alignment question
« on: April 22, 2013, 03:18:47 PM »

neuroanatomist

  • CR GEEK
  • ************
  • Posts: 21494
Re: Canon 100-400mm L EF mount alignment question
« Reply #1 on: April 22, 2013, 03:28:51 PM »
Mine mounts easily, like every other lens I own (and has done so on three different bodies).
EOS 1D X, EOS M2, lots of lenses
______________________________
Flickr | TDP Profile/Gear List

vbi

  • EOS Rebel 300D
  • ***
  • Posts: 69
Re: Canon 100-400mm L EF mount alignment question
« Reply #2 on: April 22, 2013, 03:31:11 PM »
Never had a problem with mine either. Perhaps it is just the size of the lens that is a little awkward at first.
All politicians are scum
5D3, 5D2, 7D and too many lenses

RGF

  • Canon EF 300mm f/2.8L IS II
  • ********
  • Posts: 2405
  • How you relate to the issue, is the issue.
Re: Canon 100-400mm L EF mount alignment question
« Reply #3 on: April 22, 2013, 03:31:48 PM »
Never seen or heard about this problem.  Safe routine is to return the lens

CANONisOK

  • EOS M5
  • ****
  • Posts: 160
Re: Canon 100-400mm L EF mount alignment question
« Reply #4 on: April 22, 2013, 04:05:44 PM »
Thanks for the quick replies. Having searched the forum and google, I didn't see any other reports of this being a known issue. But it's nice to have actual confirmation from other users that this is not a consistent issue.

I already ordered a replacement from B&H... I'd gotten the first from Amazon when it was the lowest price, but they were out of stock now. Now B&H is in stock at the same price as I paid through Amazon PLUS they have the 2% credit going. Fair tradeoff, I suppose.

Now let's hope the second one is just as good as the first copy from a performance standpoint!
A few bodies, some flashes, a tripod here and there, a handful of lenses. Plenty of equipment, a lot of perseverance, but not enough talent (yet).

viggen61

  • EOS M5
  • ****
  • Posts: 170
Re: Canon 100-400mm L EF mount alignment question
« Reply #5 on: April 22, 2013, 04:21:05 PM »
Mine can be a little finicky, but it always mounts up properly in the end. Part of it is simply the weight of this lens. At 3 lbs plus, it's a heavyweight, and if your hands aren't used to it, it may take you a couple tries.
Canon 7D

CANONisOK

  • EOS M5
  • ****
  • Posts: 160
Re: Canon 100-400mm L EF mount alignment question
« Reply #6 on: April 22, 2013, 05:02:48 PM »
.
Perhaps it is just the size of the lens that is a little awkward at first.
At 3 lbs plus, it's a heavyweight, and if your hands aren't used to it, it may take you a couple tries.

I'd considered that at first - but my 70-200 f2.8 ii is heavier and longer when mounting. And I've never had any issues mounting it on several different bodies. I think this 100-400mm mount was a little bit off-spec when manufactured.

Thanks again for the feedback!
A few bodies, some flashes, a tripod here and there, a handful of lenses. Plenty of equipment, a lot of perseverance, but not enough talent (yet).

canon rumors FORUM

Re: Canon 100-400mm L EF mount alignment question
« Reply #6 on: April 22, 2013, 05:02:48 PM »