April 23, 2014, 05:32:24 AM

Author Topic: 5D mark 3 with BG-12 problem  (Read 2316 times)

Scott_McPhee

  • Rebel SL1
  • ***
  • Posts: 96
  • Canon 5D mark 3 with various L lenses
    • View Profile
    • SJL Photography
5D mark 3 with BG-12 problem
« on: February 28, 2013, 08:35:45 AM »
I use my Canon 5D mark 3 with the official BGE-11 battery grip and I have noticed a problem.

When using the grip to shoot, occasionaly the shutter button will stop functioning.
AF stops and the display is static.
If I remove the camera from my eye, release the shutter and then put it back to my eye the shutter button and AF starts working again.

Anyone else with this combination had this problem?

Battery grip is properly attached, camera on latest firmware and working perfectly apart from this.

canon rumors FORUM

5D mark 3 with BG-12 problem
« on: February 28, 2013, 08:35:45 AM »

jmontagu13

  • PowerShot G16
  • **
  • Posts: 3
    • View Profile
Re: 5D mark 3 with BG-12 problem
« Reply #1 on: February 28, 2013, 09:36:36 AM »
I just got a used 5D3 last week without a grip and have noticed something similar. I haven't used it enough to figure out exactly what it's doing, but your description pretty much nails it. I go to take a picture and nothing focuses (with back button focusing) and the shutter doesn't do anything. Pull back and look at the camera and try again and it works. I'll have to keep an eye on this and see if I can recreate it easily.

Scott_McPhee

  • Rebel SL1
  • ***
  • Posts: 96
  • Canon 5D mark 3 with various L lenses
    • View Profile
    • SJL Photography
Re: 5D mark 3 with BG-12 problem
« Reply #2 on: February 28, 2013, 10:08:11 AM »
I just got a used 5D3 last week without a grip and have noticed something similar. I haven't used it enough to figure out exactly what it's doing, but your description pretty much nails it. I go to take a picture and nothing focuses (with back button focusing) and the shutter doesn't do anything. Pull back and look at the camera and try again and it works. I'll have to keep an eye on this and see if I can recreate it easily.

I have always used mine with the grip but interesting to see you have had the same thing.
It's annoying as it happens frequently and taking the camera away from your eye can lose you a shot.

duydaniel

  • 7D
  • *****
  • Posts: 338
    • View Profile
Re: 5D mark 3 with BG-12 problem
« Reply #3 on: February 28, 2013, 10:25:47 AM »
make sure the connectors between lens and body are clean or do you have the latest firmware update?
One is coming out this April to address slow focus issue

Scott_McPhee

  • Rebel SL1
  • ***
  • Posts: 96
  • Canon 5D mark 3 with various L lenses
    • View Profile
    • SJL Photography
Re: 5D mark 3 with BG-12 problem
« Reply #4 on: February 28, 2013, 10:28:03 AM »
make sure the connectors between lens and body are clean or do you have the latest firmware update?
One is coming out this April to address slow focus issue

Connections are clean - checked them again but camera and grip were purchased new.
Latest firmware in the camera too.

The focus isn't slow - it's non-existant.
Only way round it is to take the camera from your eye, release the shutter button and try again.

canon rumors FORUM

Re: 5D mark 3 with BG-12 problem
« Reply #4 on: February 28, 2013, 10:28:03 AM »