December 18, 2014, 06:45:48 AM

Author Topic: 580EX C. fn issue  (Read 1096 times)

RS2021

  • 5D Mark III
  • ******
  • Posts: 720
    • View Profile
580EX C. fn issue
« on: March 30, 2013, 08:01:37 PM »
Hi guys,

I use two older, 580ex's as A & B slaves (shown below) and a third 580exII functions as disabled on-camera master.

Recently I have noticed 580EX "B" slave is underexposing a bit. When I swap the two 580EX's (A switched as B assignation), the "A" side is now underexposing. So I think this has something to do with the physical B unit and not an issue at the level of the master or settings.

I now see the B unit always displays "C. fn" on LCD whatever I do with the settings (see picture). The kicker is that both 580EX units are set at C.fn values of "1/0" when I check. There appears to be no way for me to get the B unit C.fn off on the display. To be fair, I really wouldn't even have noticed the display difference between the two 580EX units or cared had it not been for the underexposure issue, so can't rule out it had always displayed that way on this unit. But the exposure issue is recent. So I am not sure if I toggled something or if the unit is malfunctioning or if the C.fn display is normal.

1) Could the display difference be just due to variance based on when or where the 580 units were bought from? "A" is newer and was bought in Europe over a trip, while B is from the US...

2) Is there a way to reset the whole B unit? I am a tad worried if the C. fn funciton is somehow toggled "on" in B unit and is responsible for the exposure discrepency. I am not a speedlite whizz so I am hoping there is an easy answer.

Best, Ray
« Last Edit: March 31, 2013, 10:05:01 AM by RS2021 »
“Sharpness is a bourgeois concept” - Henri Cartier-Bresson

canon rumors FORUM

580EX C. fn issue
« on: March 30, 2013, 08:01:37 PM »

RS2021

  • 5D Mark III
  • ******
  • Posts: 720
    • View Profile
Re: 580EX C. fn issue
« Reply #1 on: March 30, 2013, 08:44:17 PM »
Amazing how many times I can mistype 580 as 530.. corrected now. ;)
“Sharpness is a bourgeois concept” - Henri Cartier-Bresson

RS2021

  • 5D Mark III
  • ******
  • Posts: 720
    • View Profile
Re: 580EX C. fn issue
« Reply #2 on: March 30, 2013, 09:50:34 PM »
None of the C.Fn's could affect the power output like you are getting, but flash tubes do get "tired" surprisingly quickly and lose efficiency and output. It could just be that the dimer one has been used much more.

Hey, thanks...i was able to get the C. fn indicator off, but you guessed right, it didn't make a difference in power level...so the flash tube is probably waning.  I do have a back up 430exII used for rim/background, I guess it will have to move up now. Not pleased. :/
“Sharpness is a bourgeois concept” - Henri Cartier-Bresson

RS2021

  • 5D Mark III
  • ******
  • Posts: 720
    • View Profile
Re: 580EX C. fn issue
« Reply #3 on: March 30, 2013, 10:19:35 PM »
You used to be able to get the tubes new off eBay for very little money. They are a bit of a fiddle to change but very doeable with a set of small screwdrivers. If you don't want to do it then any camera repair shop could do it for you too. Much better option than giving up on the flash.

Yup paid full price when it came out so may be worth saving. Not too good at do-it-yourself so I will have to take it to the local store and start there.
“Sharpness is a bourgeois concept” - Henri Cartier-Bresson

canon rumors FORUM

Re: 580EX C. fn issue
« Reply #3 on: March 30, 2013, 10:19:35 PM »