October 21, 2014, 05:39:21 AM

Author Topic: An error occurring randomly  (Read 2285 times)

rihanishtiaq

  • Power Shot G7X
  • **
  • Posts: 25
    • View Profile
    • My Flickr Account:
An error occurring randomly
« on: May 09, 2013, 05:58:51 PM »
I am getting this error message some times with my 60D attached with 50mm f/1.8 II :

"Err 01 Communications between camera and lens is faulty. Clean the lens contacts"

But when I turn off the camera, take out the battery and put it back on.. It solves temporarily.
Is this a serious problem? Can anyone tell me hot to get rid of it?

Lens is almost new, bought 5-6 weeks ago.


60D--50mm1.8 II--18-55 IS--YN 560--Lowepro Slingshot 102AW
http://www.flickr.com/photos/meftasadat/

canon rumors FORUM

An error occurring randomly
« on: May 09, 2013, 05:58:51 PM »

docholliday

  • EOS M2
  • ****
  • Posts: 186
    • View Profile
Re: An error occurring randomly
« Reply #1 on: May 09, 2013, 06:33:56 PM »
Try doing exactly as the message says: take a rubber pencil eraser over the gold-plated contacts on the back of the lens and the ones inside the lens mount (gold pins). The gold plating used in electronics nowadays are cheap, and oxidize easily.

If the error persists, get some DeOxit Progold (pen dispenser is cheapest and ideal), run over the contacts with it, then wipe with a cotton swab.

If it persists after that, I'd send the lens and body in for a service checkout at Canon.

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 8859
    • View Profile
Re: An error occurring randomly
« Reply #2 on: May 09, 2013, 10:43:36 PM »
Cleaning the contacts rarely works, and using a pencil eraser is extreme bad advise.
 
Something is wrong with either the lens or the camera, send them both to Canon to see if they can fix it.

docholliday

  • EOS M2
  • ****
  • Posts: 186
    • View Profile
Re: An error occurring randomly
« Reply #3 on: May 10, 2013, 12:50:33 AM »
Cleaning the contacts rarely works, and using a pencil eraser is extreme bad advise.
 
Something is wrong with either the lens or the camera, send them both to Canon to see if they can fix it.

That's funny...been cleaning gold plating for 20 years with an eraser...SIMMs, DIMMS, BGA, etc. Rule is don't press hard and don't use a filthy eraser coated with graphite. Always seems to work quite well - it resolves the problem and isn't seen again.
« Last Edit: May 10, 2013, 12:58:02 AM by docholliday »

M.ST

  • Guest
Re: An error occurring randomly
« Reply #4 on: May 10, 2013, 01:12:40 AM »
Forget the cleaning of the contacts.

If you had a chance change the lens aginst an other or send it in for repair.

To 95% it´s the lens, to 5% it´s the camera.

docholliday

  • EOS M2
  • ****
  • Posts: 186
    • View Profile
Re: An error occurring randomly
« Reply #5 on: May 10, 2013, 01:18:49 AM »
Forget the cleaning of the contacts.

If you had a chance change the lens aginst an other or send it in for repair.

To 95% it´s the lens, to 5% it´s the camera.

My 24-70 used to have an issue with random comm errors on my 1DsII. Cleaned it and was fine for the rest of the time I owned the DsII, and, still using the lens on my DsIII. Can't hurt to try something free before sending it off...

Just like the server that I was working on at the beginning of the year that was randomly locking up. New RAM, etc didn't resolve it. Reseating the proc (BGA style Xeon) 3 times, didn't help. Rubbing the contacts on the proc with an eraser fixed the issue - been on continuously since then (> 4 months) without a reboot and without problem hosting 2500+ users on a large SQL Server daily.

J.R.

  • 1D X
  • *******
  • Posts: 1512
    • View Profile
Re: An error occurring randomly
« Reply #6 on: May 10, 2013, 01:21:24 AM »

That's funny...been cleaning gold plating for 20 years with an eraser...SIMMs, DIMMS, BGA, etc. Rule is don't press hard and don't use a filthy eraser coated with graphite. Always seems to work quite well - it resolves the problem and isn't seen again.

It is certainly NOT endorsed by Canon so I'd take your advice with a pinch of salt.

http://www.canonrumors.com/forum/index.php?topic=12769.0
5D3, 6D, 600D, RX100
16-35L, 24-70L II, 70-200L II, 100-400L, 50L, 85L II, 135L, 24TSE, 40, 100 macro, 18-55 II, 55-250 II, 600RT x 4
I come here to learn something new, not to learn how bad my gear is - I know that already ;-)!

canon rumors FORUM

Re: An error occurring randomly
« Reply #6 on: May 10, 2013, 01:21:24 AM »

timmy_650

  • Rebel SL1
  • ***
  • Posts: 93
    • View Profile
Re: An error occurring randomly
« Reply #7 on: May 10, 2013, 01:32:41 AM »
If it is 5-6 weeks return it if you can or send it in to be fixed. You might be able to get it to stop for awhile but most likely it will come back.
I wouldn't clean with an eraser.

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14709
    • View Profile
Re: An error occurring randomly
« Reply #8 on: May 10, 2013, 08:15:50 AM »
It is certainly NOT endorsed by Canon so I'd take your advice with a pinch of salt.

True, but sometimes Canon's guidance needs a pinch of salt, too. The manual for my 600 II instructs me to send the lens to Canon to replace the tripod foot with the monopod foot. Apparently, a hex key and four screws are too complex for us normal folks to handle.  ::)
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

J.R.

  • 1D X
  • *******
  • Posts: 1512
    • View Profile
Re: An error occurring randomly
« Reply #9 on: May 10, 2013, 09:03:36 AM »
It is certainly NOT endorsed by Canon so I'd take your advice with a pinch of salt.

True, but sometimes Canon's guidance needs a pinch of salt, too. The manual for my 600 II instructs me to send the lens to Canon to replace the tripod foot with the monopod foot. Apparently, a hex key and four screws are too complex for us normal folks to handle.  ::)

True, some of the Canon's guidance is mundane to downright rubbish. Can't blame them though - some people are incredibly stupid and won't do even the basics right and will blame Canon for anything and everything that goes wrong with their equipment.
5D3, 6D, 600D, RX100
16-35L, 24-70L II, 70-200L II, 100-400L, 50L, 85L II, 135L, 24TSE, 40, 100 macro, 18-55 II, 55-250 II, 600RT x 4
I come here to learn something new, not to learn how bad my gear is - I know that already ;-)!

Menace

  • 1D X
  • *******
  • Posts: 1372
  • New Zealand
    • View Profile
Re: An error occurring randomly
« Reply #10 on: May 10, 2013, 04:12:53 PM »
I am getting this error message some times with my 60D attached with 50mm f/1.8 II :

"Err 01 Communications between camera and lens is faulty. Clean the lens contacts"

But when I turn off the camera, take out the battery and put it back on.. It solves temporarily.
Is this a serious problem? Can anyone tell me hot to get rid of it?

Lens is almost new, bought 5-6 weeks ago.

Had a similar problem on my brand new 70-200 2.8 IS II whilst mounted on a 5d III - had to return it to Canon or a service / fix.

Took a couple of weeks for it to come back - no problems since. It was done free of charge too.

My advice to OP is to get a new copy or return as faulty.

Cheers
1Dx | 5D III
85 1.2L II | 100 2.8 | 400 2.8L IS II 
24-70 2.8L II | 70-200 2.8L IS II

rihanishtiaq

  • Power Shot G7X
  • **
  • Posts: 25
    • View Profile
    • My Flickr Account:
Re: An error occurring randomly
« Reply #11 on: May 10, 2013, 05:14:37 PM »
thanks everyone! but cleaning didn't work.. I will return it immediately.
60D--50mm1.8 II--18-55 IS--YN 560--Lowepro Slingshot 102AW
http://www.flickr.com/photos/meftasadat/

canon rumors FORUM

Re: An error occurring randomly
« Reply #11 on: May 10, 2013, 05:14:37 PM »