September 19, 2014, 07:58:12 AM

Author Topic: Purple artifacts with 35mm f1.4L on long exposures  (Read 1683 times)

janmaxim

  • Power Shot G16
  • **
  • Posts: 17
    • View Profile
Purple artifacts with 35mm f1.4L on long exposures
« on: May 25, 2013, 12:26:16 PM »
Hello

Yesterday I experienced a strange problem. I was taking long night exposures of a village in greece with a tripod with exposure time ranging from 5 - 30 seconds.

After the longer exposures (10 seconds+) purple artifacts were visible in the images. They looked like a flare. But they appeared even if I turned around 180 degrees for a new exposure. The same with and without the UV-filter (B+W 080 MRC).

So there is indeed something between the first lens element and sensor causing this. Has anyone any idea of what this is?

I am using EOS600D with some custom functions like ISO noise reduction turned on.

canon rumors FORUM

Purple artifacts with 35mm f1.4L on long exposures
« on: May 25, 2013, 12:26:16 PM »

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14405
    • View Profile
Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #1 on: May 25, 2013, 12:58:53 PM »
Can you post an example?
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

Peerke

  • PowerShot G1 X II
  • ***
  • Posts: 72
    • View Profile
    • Photo Amora
Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #2 on: May 25, 2013, 02:32:22 PM »
Could it have to do with the IR filter of your 600D? I had the same with my 40D until I put a IR filter in front (B&W 486) and the margenta color cast was gone.
« Last Edit: May 25, 2013, 02:37:20 PM by Peerke »
7D, 40D, EF-S 10-22, EF-S 17-55 f/2.8, EF-S 18-135, EF 70-200 f/4 IS, EF 35 f2.0, EF 85 f/1.8, EF 50 f/1.8 II, EF 100 f/2.0, Sigma 150, Speedlite 430 II

janmaxim

  • Power Shot G16
  • **
  • Posts: 17
    • View Profile
Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #3 on: May 25, 2013, 02:37:21 PM »
I have three samples here. Sorry for the bad quality, had to take a picture with my ipad from the camera screen. You can clearly see the purple artifacts in the top section of the images.

http://imgur.com/9w1TjVF
http://imgur.com/Zuon0YH
http://imgur.com/5yUPRlU

Pi

  • 1D Mark IV
  • ******
  • Posts: 937
    • View Profile
    • Math and Photography
Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #4 on: May 25, 2013, 03:01:43 PM »
Those are severely overexposed images, for the highlights. Most likely flare. What f-stop?

Mt Spokane Photography

  • Canon EF 600mm f/4L IS II
  • ********
  • Posts: 8665
    • View Profile
Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #5 on: May 25, 2013, 03:13:31 PM »
Those are severely overexposed images, for the highlights. Most likely flare. What f-stop?
Yes, so badly overexposed that they can't be saved.  You need to shorten the exposure, use lowest ISO, smaller aperture, and possibly a neutral density filter.

canon rumors FORUM

Re: Purple artifacts with 35mm f1.4L on long exposures
« Reply #5 on: May 25, 2013, 03:13:31 PM »