October 24, 2017, 07:38:10 AM

Author Topic: Canon 600D flash problem  (Read 6693 times)

SkullBoy

  • PowerShot SX60 HS
  • **
  • Posts: 3
Canon 600D flash problem
« on: July 22, 2013, 04:16:43 PM »
Hi, I'm new to the forum so I'm sorry if this is not the right place to post questions. If its not, please let me know where to post.

I have a Canon 600D for almost a year now, and since I bought it the built in flash always had a problem. Whenever I take a photo, no matter what light conditions, the photo comes all black. I've been told by a friend that probably it was because the flash light was too strong.  Would really appreciate help from the forum. Thank you!

canon rumors FORUM

Canon 600D flash problem
« on: July 22, 2013, 04:16:43 PM »

dgatwood

  • EOS 5DS R
  • ******
  • Posts: 922
  • 300D, 400D, 6D
Re: Canon 600D flash problem
« Reply #1 on: July 22, 2013, 09:55:25 PM »
Hi, I'm new to the forum so I'm sorry if this is not the right place to post questions. If its not, please let me know where to post.

I have a Canon 600D for almost a year now, and since I bought it the built in flash always had a problem. Whenever I take a photo, no matter what light conditions, the photo comes all black. I've been told by a friend that probably it was because the flash light was too strong.  Would really appreciate help from the forum. Thank you!

Only when the flash is active, you mean?  Could the flash exposure compensation be set way too strong?

Random Orbits

  • EOS-1D X Mark II
  • *******
  • Posts: 1939
Re: Canon 600D flash problem
« Reply #2 on: July 22, 2013, 10:09:00 PM »
What mode are you shooting in?  You should use Av or M.  Av will meter for the ambient background, and M you can set to whatever you want.

SkullBoy

  • PowerShot SX60 HS
  • **
  • Posts: 3
Re: Canon 600D flash problem
« Reply #3 on: July 22, 2013, 10:18:36 PM »
What mode are you shooting in?  You should use Av or M.  Av will meter for the ambient background, and M you can set to whatever you want.

I usually shoot in A-DEP, M or AV. On all three I get the same results, if I use the flash, even on day light, the photos comes all black.

I'm still new to DSLR photography so I don't know if there is anything I'm doing wrong or if is a camera defect.

SkullBoy

  • PowerShot SX60 HS
  • **
  • Posts: 3
Re: Canon 600D flash problem
« Reply #4 on: July 22, 2013, 10:20:39 PM »
Hi, I'm new to the forum so I'm sorry if this is not the right place to post questions. If its not, please let me know where to post.

I have a Canon 600D for almost a year now, and since I bought it the built in flash always had a problem. Whenever I take a photo, no matter what light conditions, the photo comes all black. I've been told by a friend that probably it was because the flash light was too strong.  Would really appreciate help from the forum. Thank you!

Only when the flash is active, you mean?  Could the flash exposure compensation be set way too strong?

Yes, the camera works just fine, but when I use the flash, the photo comes all black. I've tried all the exposure compensation values and I see no difference.

rpt

  • Canon EF 300mm f/2.8L IS II
  • ********
  • Posts: 2723
Re: Canon 600D flash problem
« Reply #5 on: July 22, 2013, 10:30:37 PM »
Hi, I'm new to the forum so I'm sorry if this is not the right place to post questions. If its not, please let me know where to post.

I have a Canon 600D for almost a year now, and since I bought it the built in flash always had a problem. Whenever I take a photo, no matter what light conditions, the photo comes all black. I've been told by a friend that probably it was because the flash light was too strong.  Would really appreciate help from the forum. Thank you!

Only when the flash is active, you mean?  Could the flash exposure compensation be set way too strong?

Yes, the camera works just fine, but when I use the flash, the photo comes all black. I've tried all the exposure compensation values and I see no difference.
You will need to post pictures with and without flash. Same subject, same lighting conditions. Hard to guess. May be flash is not firing at the right time?

dgatwood

  • EOS 5DS R
  • ******
  • Posts: 922
  • 300D, 400D, 6D
Re: Canon 600D flash problem
« Reply #6 on: July 23, 2013, 12:02:28 AM »
Yes, the camera works just fine, but when I use the flash, the photo comes all black. I've tried all the exposure compensation values and I see no difference.

Completely black?  As in no pixels lit?  At all?

That's either a firmware bug or a power regulation failure.  My money is on bad hardware.

canon rumors FORUM

Re: Canon 600D flash problem
« Reply #6 on: July 23, 2013, 12:02:28 AM »

Jim Saunders

  • EOS 5DS R
  • ******
  • Posts: 1049
    • HHA Photo
Re: Canon 600D flash problem
« Reply #7 on: July 23, 2013, 12:09:01 AM »
You are within your sync speed limit?  Start with that maybe.

Jim
A good image might fit entirely into the histogram, might not.

Hannes

  • EOS 80D
  • ****
  • Posts: 279
Re: Canon 600D flash problem
« Reply #8 on: July 23, 2013, 10:27:47 AM »
try setting it to P mode and see if it works there. If it doesn't then you probably have a problem with your camera but if that works fine it's probably down to your settings. The small built in flash will generally prefer as wide open aperture as possible and a shutter speed of less than 1/200. Crank up the ISO a little to get more oompfh out of it.

canon rumors FORUM

Re: Canon 600D flash problem
« Reply #8 on: July 23, 2013, 10:27:47 AM »