October 21, 2014, 01:42:00 AM

Author Topic: 85mm EF is not recoginzed by my EOS M  (Read 2923 times)

lothar

  • SX60 HS
  • **
  • Posts: 4
    • View Profile
85mm EF is not recoginzed by my EOS M
« on: July 22, 2013, 11:28:30 AM »
While every other lens has worked, including third party, the 85mm EF does not register with my M. Error 01 comes on, on the back screen at times...any other experiences?

canon rumors FORUM

85mm EF is not recoginzed by my EOS M
« on: July 22, 2013, 11:28:30 AM »

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 14709
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #1 on: July 22, 2013, 11:56:23 AM »
Some clarifying questions:

Which '85mm EF'?  The EF 85mm f/1.8 USM, the EF 85mm f/1.2L USM, or the EF 85mm f/1.2L II USM?  I have the 85L II, have not tried it on my EOS M, but I can do so later today.

What do you mean by 'does not register'?  Does it not work at all, ever? Or does it work sometimes and give an Error 01 at other times?

Are you using the OEM mount adapter or a different one?

Does that lens work fine on other bodies (i.e. the problem could be the lens not the EOS M)?
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

Halfrack

  • Canon 7D MK II
  • *****
  • Posts: 480
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #2 on: July 22, 2013, 01:40:08 PM »
85mm f1.2 mk2 works fine for me...  damn that AF constantly hunts - and kills the battery.
"Me owning a lens shop is kind of like having an alcoholic bar tender." - Roger Cicala

lothar

  • SX60 HS
  • **
  • Posts: 4
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #3 on: July 22, 2013, 05:18:19 PM »
ef 85mm f1.8.
Camera info says "lens not recognized", and hunts, viciously!
I can set it to approximate subject focus manually, it then fine tunes, at times, and takes the image.
Otherwise, the lens hunts constantly, and will black the rear screen, with a message that says error 1!

nubu

  • PowerShot G1 X II
  • ***
  • Posts: 63
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #4 on: July 23, 2013, 03:56:27 AM »
"...  damn that AF constantly hunts - "

Switch off cont AF. I use the 85/1.2 II and it works fine with me on the m knowing that it is not a fast focusing lens even on my 5DIII...
5DII/III,7D,400D,m|EF14/2.8LII,EF24/1.4LII,EF35/1.4L,EF40/2.8,EF50/1.4,MPE65/2.8,EF85/1.2L,EF100/2.8LIS,EF135/2L,EF200/2.8L,EF300/2.8LIS,EF500/4LIS,Zeiss500/8,EF1.4xIII,EF2xIII,EF8-15/4L,EFS17-55/2.8IS,EFS18-55/3.5-IS,EF24-105/4,allEFM

bainsybike

  • Rebel T5i
  • ****
  • Posts: 118
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #5 on: July 23, 2013, 06:20:28 AM »
Mine works fine, and autofocuses reliably wide open, which it never did on my 50D.

dtaylor

  • 1D Mark IV
  • ******
  • Posts: 788
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #6 on: July 23, 2013, 08:09:02 AM »
My 85mm f/1.8 USM works with my M using the Canon adapter.

canon rumors FORUM

Re: 85mm EF is not recoginzed by my EOS M
« Reply #6 on: July 23, 2013, 08:09:02 AM »

michi

  • EOS M2
  • ****
  • Posts: 182
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #7 on: July 23, 2013, 08:23:06 AM »
My 85 1.8 works perfectly with the Canon adapter and the EOS M.

Since it doesn't seem to be a problem with any of us, see if you can clean the contacts of your lens.  Maybe that's the issue?  Are you using a original Canon adapter or one from another manufacturer?

sjprg

  • Power Shot G7X
  • **
  • Posts: 24
  • 1DSIII
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #8 on: July 23, 2013, 09:21:13 AM »
Which firmware are you using? I don't have the 85, but my 28-300 and the 100-400 work fine

eos650

  • PowerShot G1 X II
  • ***
  • Posts: 60
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #9 on: July 23, 2013, 10:14:00 AM »
I just tried my 85 f1.8 and it worked with no issues. I have a 3rd party adapter made by VilTrox.

drjlo

  • 5D Mark III
  • ******
  • Posts: 641
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #10 on: July 30, 2013, 04:09:45 PM »
I just tried my 85 f1.8 and it worked with no issues. I have a 3rd party adapter made by VilTrox.

Well, it must not be an adapter problem because my Canon 85 f/1.8 will not autofocus with Viltrox adapter on EOS-M.  Every other Canon lens works fine.  I suspect it probably has to do with 85 f/1.8's age/version..

This is a shame, too, since I was counting on 85 f/1.8 to act as shallow DOF portrait lens on EOS-M since I sold off my Canon 50 f/1.4 after getting 50L, which is really too large to use often on EOS-M.

michi

  • EOS M2
  • ****
  • Posts: 182
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #11 on: July 31, 2013, 01:29:37 PM »
My 85 1.8 is pretty darn old, pre 2000, and it works fine.

bholliman

  • 1D Mark IV
  • ******
  • Posts: 763
    • View Profile
Re: 85mm EF is not recoginzed by my EOS M
« Reply #12 on: July 31, 2013, 04:27:01 PM »
My 85 1.8 works perfectly with the Canon adapter and the EOS M.


+1

I just checked my 85 1.8 with the Canon adapter and it works fine!
Bodies:  6D, EOS-M (22/2 and 18-55)
Lenses: Rokinon 14mm 2.8, 35mm 2.0 IS, 85mm 1.8, 100mm 2.8L IS Macro, 135mm 2.0L, 24-70mm 2.8L II, 70-200mm 2.8L IS II, Extenders: EF 1.4xIII, EF 2xIII ; Flash: ST-E3-RT, 600EX-RT (x3)

canon rumors FORUM

Re: 85mm EF is not recoginzed by my EOS M
« Reply #12 on: July 31, 2013, 04:27:01 PM »