October 20, 2014, 02:44:29 PM

Author Topic: 7D silent mode not working?  (Read 951 times)

Valvebounce

  • 1D Mark IV
  • ******
  • Posts: 924
  • Still can't use most of it to it's full potential!
    • View Profile
7D silent mode not working?
« on: August 14, 2013, 04:26:54 AM »
Hi Guys, I tried the silent shooting modes on the 7D last night, mode 1 is supposed to be softer but still allows burst mode, I couldn't really tell, it may be a little softer but not so much I would say it would make a difference! Mode 2 is if I'm reading it right (yes I RTFM) supposed to hold the mirror return until the shutter is released to the half press position. This was not happening and I tried it several times to make sure I did hold the shutter release down!  ;D

I am wondering if there is a menu or custom setting of another option that disables this function? I am not using a 3rd party flash or any flash for that matter and that is all I could find that is listed as interacting with silent shoot.

Any help with this would be great as I am sure it is not working as it should, I have been wrong before though! ::)

How much difference in volume should it make, tons, not a lot, not worth turning on, I don't know some one please enlighten me.

Thanks in advance.
Cheers Graham.
7D + Grip, 40D + Grip, 20D, EF-S 17-85 Kit lens, EF 70-200 f2.8 L IS II USM, EF 2x III, Sigma 150-500, Sigma 17-70 f2.8-4 C, 50mm f1.8, 550EX some Filters Remotes Macro tubes Tripod heads etc!
20D, BG-E2N, 17-85mm, 50mm are pre loved. :)
(300D Saved a holiday, E-FS 18-55 Cosina 100-300 retired)

canon rumors FORUM

7D silent mode not working?
« on: August 14, 2013, 04:26:54 AM »

Schruminator

  • Rebel SL1
  • ***
  • Posts: 90
  • I'm just kidding, seriously.
    • View Profile
    • M Schrum Photography
Re: 7D silent mode not working?
« Reply #1 on: August 14, 2013, 05:34:20 AM »
Keep in mind that the 7D silent shooting modes are only pertinent to shooting with LiveView. If you are using the viewfinder to shoot there will be no difference in operation or noise regardless of the mode you've selected.
5D III | 14 2.8 L | 24 1.4 II L | 35 1.4 L | 50 1.2 L | 85 1.2 II L | 24-70 2.8 II L | 70-200 2.8 IS II L | 40 2.8 | 1.4x Mk. II T.C. | M Schrum Photography

thgmuffin

  • Rebel SL1
  • ***
  • Posts: 93
    • View Profile
Re: 7D silent mode not working?
« Reply #2 on: August 14, 2013, 05:53:46 AM »
If you RTFM'd you'd know that SS is only available in live view!  ::)

Valvebounce

  • 1D Mark IV
  • ******
  • Posts: 924
  • Still can't use most of it to it's full potential!
    • View Profile
Re: 7D silent mode not working?
« Reply #3 on: August 14, 2013, 12:35:19 PM »
Ok guys, I really did rtfm, I do try not to use the forum as my personal manual! I have it as PDF on my iPad and searched silent shooting, I have searched again and found the bit about live view, I guess the fact that the menu heading is live view is a big clue! Doh

Thanks guys you've been helpful as ever.

I am going to try it correctly in a bit!

Cheers Graham.
« Last Edit: August 14, 2013, 12:37:07 PM by Valvebounce »
7D + Grip, 40D + Grip, 20D, EF-S 17-85 Kit lens, EF 70-200 f2.8 L IS II USM, EF 2x III, Sigma 150-500, Sigma 17-70 f2.8-4 C, 50mm f1.8, 550EX some Filters Remotes Macro tubes Tripod heads etc!
20D, BG-E2N, 17-85mm, 50mm are pre loved. :)
(300D Saved a holiday, E-FS 18-55 Cosina 100-300 retired)

canon rumors FORUM

Re: 7D silent mode not working?
« Reply #3 on: August 14, 2013, 12:35:19 PM »