July 22, 2014, 03:49:26 PM

Author Topic: 7D technical error - no video & half black stills  (Read 873 times)

numra

  • SX50 HS
  • **
  • Posts: 2
    • View Profile
7D technical error - no video & half black stills
« on: November 19, 2013, 10:20:51 AM »
I'm having a weird problem with my 7D - a technical error telling me to turn my camera on and off and to reinstall my battery is coming up. It isn't allowing me to shoot video. It is also only half 'exposing' my shots - that is, only half the image comes up - the other half of the shot is black.
Does anyone know what this means? It happened all of a sudden when I wasn't having any problems prior - it is aproblem with the shutter?

canon rumors FORUM

7D technical error - no video & half black stills
« on: November 19, 2013, 10:20:51 AM »

AmbientLight

  • 6D
  • *****
  • Posts: 490
    • View Profile
Re: 7D technical error - no video & half black stills
« Reply #1 on: November 19, 2013, 10:36:07 AM »
Your best option is to bring your camera to either CPS or your local camera service and get your camera repaired.

paul13walnut5

  • Guest
Re: 7D technical error - no video & half black stills
« Reply #2 on: November 20, 2013, 10:30:41 AM »
Points towards a problem with the shutter.  A repair jobbie.

dgatwood

  • 6D
  • *****
  • Posts: 552
  • 300D, 400D, 6D
    • View Profile
Re: 7D technical error - no video & half black stills
« Reply #3 on: December 01, 2013, 08:57:22 AM »
Points towards a problem with the shutter.  A repair jobbie.

If the image were dark, I'd blame the shutter.  If it is half black, my bet would be the mirror.  Unless you're using a nonstandard lens on an adapter or something, yeah, it will almost certainly have to go to Canon for repairs.

canon rumors FORUM

Re: 7D technical error - no video & half black stills
« Reply #3 on: December 01, 2013, 08:57:22 AM »