July 30, 2014, 02:18:13 AM

Author Topic: Tamron 150-600mm focusing issue with Canon 7D body  (Read 880 times)

stegosaurus

  • SX50 HS
  • **
  • Posts: 1
    • View Profile
Tamron 150-600mm focusing issue with Canon 7D body
« on: March 10, 2014, 04:34:31 PM »
I had purchased this lens from my local camera shop and was disappointed when I discovered that it would only focus on my 5D Mark III body.  It would stall and quit trying to achieve focus on the 7D if I had focused on a near object, moved to focus on a far object and moved back to a nearer object.  I took it back and tried 2 more copies of the lens but all had the same issue.  That night after trying to solve it by carefully looking at the 7D setup, I realized that Custom Function III Option 4 was set to stop the lens drive if focus couldn't be achieved.  I reset this to "1" and then went back to my camera dealer to try the Tamron again.  Problem solved!

I've seen quite a few posts with similar problems on a couple different Canon bodies.  I don't know if what I did would fix those issues, but it certainly took care of me problem.  I am still just now trying the lens (I just got it today) but so far I am very happy with the focus and speed of focus.

Paul

canon rumors FORUM

Tamron 150-600mm focusing issue with Canon 7D body
« on: March 10, 2014, 04:34:31 PM »

wickidwombat

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4434
    • View Profile
Re: Tamron 150-600mm focusing issue with Canon 7D body
« Reply #1 on: March 10, 2014, 08:02:16 PM »
I had purchased this lens from my local camera shop and was disappointed when I discovered that it would only focus on my 5D Mark III body.  It would stall and quit trying to achieve focus on the 7D if I had focused on a near object, moved to focus on a far object and moved back to a nearer object.  I took it back and tried 2 more copies of the lens but all had the same issue.  That night after trying to solve it by carefully looking at the 7D setup, I realized that Custom Function III Option 4 was set to stop the lens drive if focus couldn't be achieved.  I reset this to "1" and then went back to my camera dealer to try the Tamron again.  Problem solved!

I've seen quite a few posts with similar problems on a couple different Canon bodies.  I don't know if what I did would fix those issues, but it certainly took care of me problem.  I am still just now trying the lens (I just got it today) but so far I am very happy with the focus and speed of focus.

Paul

the 5D3 wont focus with this lens either if this option is set incorrectly
APS-H Fanboy

Lightmaster

  • EOS M2
  • ****
  • Posts: 214
    • View Profile
Re: Tamron 150-600mm focusing issue with Canon 7D body
« Reply #2 on: April 01, 2014, 01:11:44 PM »
the lens will focus with the 7D it´s just that it has issues with AI servo mode.

the option you mention has nothing to do with the issues reported on some forums.
these are two different things.

canon rumors FORUM

Re: Tamron 150-600mm focusing issue with Canon 7D body
« Reply #2 on: April 01, 2014, 01:11:44 PM »