September 15, 2014, 09:06:21 PM

Author Topic: 40D USB Problem  (Read 468 times)

BennyBoo

  • SX50 HS
  • **
  • Posts: 1
    • View Profile
40D USB Problem
« on: April 22, 2014, 05:58:26 PM »
Hey All, new member ;)

I've had my 40D for a while now and I've got a problem.
It's not been a problem and still isn't, but if I plug it in via USB to my PC or Tablet, all I get is Busy on the lcd, then nothing..

It won't connect to the PC as a mass storage device, It won't even connect using EOSInfo to check the Shutter Count..

I took it to my local specialist shop and same thin, I can't connect my 40D to a PC using USB.. I've tried FW 1.0.8 and 1.1.1.

Anyone else have this issue..?
Thanks

canon rumors FORUM

40D USB Problem
« on: April 22, 2014, 05:58:26 PM »

Jim Saunders

  • 1D Mark IV
  • ******
  • Posts: 821
    • View Profile
Re: 40D USB Problem
« Reply #1 on: April 22, 2014, 07:00:50 PM »
Try taking both batteries out and letting it sit a moment; after that put them back in and see if it works.  If you've tried different computers and different cables then that is the next simple thing to try.

Jim
I'd probably do better to invest more time and less money.

Valvebounce

  • 1D Mark IV
  • ******
  • Posts: 854
  • Still can't use most of it to it's full potential!
    • View Profile
Re: 40D USB Problem
« Reply #2 on: April 22, 2014, 08:02:07 PM »
Hi Benny.
Don't know if I've got this problem on my 40D, I haven't connected with USB for years! Have you tried the Canon EOS utility, this is at least made by Canon to connect their cameras to a pc. What OS are you using, try restarting your pc while the camera sits without batteries, try connecting then power on camera and power on then connect camera.
I have just looked and can't find it in the menu, but it's late here and I may have missed it, I've had problems on one of my cameras not connecting because of a menu setting of ptp or normal output, may have been 20D.
Not a problem until you want remote shooting over USB! Hope you get to he bottom of this.

Edit
Welcome to the forum Benny.
End edit.

Cheers Graham.

Hey All, new member ;)

I've had my 40D for a while now and I've got a problem.
It's not been a problem and still isn't, but if I plug it in via USB to my PC or Tablet, all I get is Busy on the lcd, then nothing..

It won't connect to the PC as a mass storage device, It won't even connect using EOSInfo to check the Shutter Count..

I took it to my local specialist shop and same thin, I can't connect my 40D to a PC using USB.. I've tried FW 1.0.8 and 1.1.1.

Anyone else have this issue..?
Thanks
« Last Edit: April 23, 2014, 03:21:33 AM by Valvebounce »
7D + Grip, 40D + Grip, 20D, EF-S 17-85 Kit lens, EF 70-200 f2.8 L IS II USM, EF 2x III, Sigma 150-500, Sigma 17-70 f2.8-4 C, 50mm f1.8, 550EX some Filters Remotes Macro tubes Tripod heads etc!
20D, BG-E2N, 17-85mm, 50mm are pre loved. :)
(300D Saved a holiday, E-FS 18-55 Cosina 100-300 retired)

canon rumors FORUM

Re: 40D USB Problem
« Reply #2 on: April 22, 2014, 08:02:07 PM »