July 23, 2018, 04:06:22 AM

Author Topic: Canon 7d mark II video problems  (Read 3407 times)

Danzq

  • PowerShot G1 X II
  • ***
  • Posts: 25
Canon 7d mark II video problems
« on: March 05, 2015, 05:09:36 AM »
Hi!

I was shooting some video yesterday and noticed some unusual flickering of some sort I think..

Here's a video of the actual problem: https://www.youtube.com/watch?v=cnU4SB9t5E4

First I thought it's just some problems with the lcd screen but later I noticed it continues to show in the record itself (as seen in the video).

It does not appear when shooting stills in LiveView mode. Also worth mentioning that I tried it with all my lenses and it seemed to be equally bad with every lens.

Shutter speed seems to have something to do with it. Lowering shutter speed below 100 seems to make it disappear (you can see me swithcing shutter speed in the video).

Anyone know what might be causing this or has anyone noticed similar problems?

Thanks!
-Dan
7d mark II + Sigma 18-35mm f/1.8 + Canon 50mm f/1.4 + Canon 85mm f/1.8

canon rumors FORUM

Canon 7d mark II video problems
« on: March 05, 2015, 05:09:36 AM »

wyldeguy

  • EOS Rebel T7i
  • ****
  • Posts: 112
Re: Canon 7d mark II video problems
« Reply #1 on: March 05, 2015, 05:49:25 AM »
Hey Danzq,

This is a sync issue between the shutter speed, frame rate and cycle of your lighting.  The best quality video is achieved when you use a shutter speed that is as close to double your frame rate as possible. In NTSC format ( what I use) that would be 24fps and 1/50.  In North America the electricity cycles at 60 times a second so it's usually not a problem to film at that shutter speed.  In the UK the electricity cycles at 50 times a second so that is sometimes an issue.  I guess it's possible if you were shooting in the 60fps frame rate even though it's really only 59.94 it could be close enough that you might see the light cycle.  Any shutter speed higher than the frequency of electricity in your country will give you that effect.
Canon 7D2, T3i, 70-200 f4 L IS, 17-40 f4 L, 50 f1.4, Tamron 150-600, Sigma 24-70 f2.8, Canon EF-s 24 f2.8 pancake

Danzq

  • PowerShot G1 X II
  • ***
  • Posts: 25
Re: Canon 7d mark II video problems
« Reply #2 on: March 05, 2015, 06:47:22 AM »
Thanks for the quick reply!

I googled it a bit to understand the problem better and it seems like I've somehow managed to switch my format into something that makes the flickering problem appear. Not knowing the name of this problem caused me to panic and post a thread in CR! :D

I was so ready to send my camera in for some repeairs. Technology is sometimes just too complicated! =)

-Dan
7d mark II + Sigma 18-35mm f/1.8 + Canon 50mm f/1.4 + Canon 85mm f/1.8

canon rumors FORUM

Re: Canon 7d mark II video problems
« Reply #2 on: March 05, 2015, 06:47:22 AM »