May 26, 2015, 10:07:39 AM

Author Topic: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!  (Read 8378 times)

BL

  • Canon 6D
  • *****
  • Posts: 423
  • Great gear is good. Good technique is better.
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #15 on: August 26, 2013, 11:06:56 PM »
http://www.lensrentals.com/blog/2011/08/the-apocalypse-of-lens-dust

i wouldn't sweat it.

i had what looked like a fruit fly die inside the rear element of my 55mm mamiya-sekor.  was super upset about it until i realized it did absolutely nothing to my images.
M, 5Dc, 1Dx, some lenses, a few lights

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #15 on: August 26, 2013, 11:06:56 PM »

adhocphotographer

  • 5D Mark III
  • ******
  • Posts: 624
    • An ad hoc photographer
5D MkIII & 100D
17-40L, 24L II, 24-105L, 70-200L, 500L II
-------www.adhocphotographer.com--------

mrsfotografie

  • 1D X
  • *******
  • Posts: 1520
  • M.R.S. Fotografie www.mrsfotografie.nl
    • MRS fotografie
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #17 on: August 27, 2013, 01:37:13 AM »
...

the bug is really small. about 1.5mm in length.

Shall I keep it? Or sell it?

LOL, taken out of context this is really funny :) In any case, enjoy your new lens; seems like a good deal to me.
5D3, 5D2, Sony α6000, G16 | SY14 f/2.8, Ʃ20 f/1.8, 24 f/2.8, 35 f/2, Ʃ35 f/1.4A, 50 f/1.8 I, Ʃ50 f/1.4 EX, 100L Macro, 17-40L, 24-105L, 70-200 f/2.8L IS II, 1.4x II, 70-300L, 100-400L | E-mount: SY12 f/2, Ʃ19 & 30 f/2.8 EX DN, 16-70 ZA OSS, 55-210 OSS, Metabones SB | FT-QL, AE-1P | FD(n) & FL lenses

shashinkaman

  • PowerShot G1 X II
  • ***
  • Posts: 38
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #18 on: August 28, 2013, 02:22:33 AM »
"Dust to dust..." the seller told you the truth  8)
Don't be such a Pixel Peeper!

LetTheRightLensIn

  • Canon EF 400mm f/2.8L IS II
  • *********
  • Posts: 4338
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #19 on: August 28, 2013, 04:20:03 AM »
I don't think you'll get much for the bug, and after eBay and Paypal fees, it will hardly be worth it.

+1

doesn't make sense to try to sell off the bug on ebay, try CL instead

LetTheRightLensIn

  • Canon EF 400mm f/2.8L IS II
  • *********
  • Posts: 4338
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #20 on: August 28, 2013, 04:34:50 AM »
Man, after reading all of this I'm sort of bummed I don't have a bug behind the front element of any of my lenses. Maybe I should dump my Canon (and Tamron) junk and pick up some Sigmas. Sure, sure it has a red ring.... well BIG freaking deal! Now a bug. Now that's class. Now you're talking. That's style. That's pizzazz. If that doesn't speak of luxury then nothing does. You know when people talk about things having a special magical je ne sais quoi? Well, I do know what. And it's having a bug behind my front element.

And for the techies out there: Who cares about fluorite elements when you can have a bug in the optical pathway? I bet the longitudinal CA performance of his lens is at a near unheard of level. Forget APO designs those are so 20th century. What you really want are BBFE designs.

About what about my precious Zeiss! Does it have bugs behind its front element? Does it? ANY? Not a one?! Enough is enough! I have had it without these monkey fighting bugs inside this MF lens!


« Last Edit: August 28, 2013, 04:45:14 AM by LetTheRightLensIn »

Ewinter

  • EOS M2
  • ****
  • Posts: 221
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #21 on: August 28, 2013, 04:44:03 AM »
They've already got the bug, it's why they bought the Lens!

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #21 on: August 28, 2013, 04:44:03 AM »

TommyLee

  • EOS M2
  • ****
  • Posts: 155
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #22 on: August 28, 2013, 06:21:19 AM »
we all have to go sometime

maybe if he was still alive...
you could hook up the Sigma Dock..
and he could walk out...on the dock


« Last Edit: August 28, 2013, 06:31:35 AM by TommyLee »

troy19

  • PowerShot G1 X II
  • ***
  • Posts: 32
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #23 on: August 28, 2013, 07:30:27 AM »
no need to argue with Sigma / the seller.

This is Sigmas recent attempt to search for lighter material than glass. So they chose amber. We all know sometimes there are little insects included, millions of years old. So the bug is a sign of quality. You may ask an archaeologist and if the species is yet unknown, you - as the first to see it - are allowed to give a name to it. Think of "Sigmania buginienis", doesn't that sound good, tribute to the developer included.  ;D

padmasana

  • Power Shot G7X
  • **
  • Posts: 14
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #24 on: August 28, 2013, 09:56:22 AM »
Though I hate that there was a bug in the Sigma 50, I have to say this has been a tremendously entertaining thread.

distant.star

  • 1D X
  • *******
  • Posts: 1703
    • Tracy's Shooting Gallery
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #25 on: August 28, 2013, 12:07:00 PM »
.
Be thankful it wasn't in your soup!
You're offended? Oh, really! Life IS offense -- get used to it.

sandymandy

  • 5D Mark III
  • ******
  • Posts: 618
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #26 on: August 28, 2013, 01:16:36 PM »
Be happy ur not one of those unlucky guys who got an insect inside their tft screen!! it happened to me once only...but i was so mad lol...like some black pixels moving around -.-turned off screen and luckily the insect decided to leave when i came back next day :)

anthonyd

  • Rebel T5i
  • ****
  • Posts: 138
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #27 on: August 28, 2013, 01:47:43 PM »
.
Be thankful it wasn't in your soup!

Oh yeah, a 50mm Sigma would definitely ruin a good soup.  ;)

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #27 on: August 28, 2013, 01:47:43 PM »