July 25, 2014, 04:49:04 PM

Author Topic: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!  (Read 6980 times)

BL

  • 7D
  • *****
  • Posts: 379
  • Great gear is good. Good technique is better.
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #15 on: August 26, 2013, 11:06:56 PM »
http://www.lensrentals.com/blog/2011/08/the-apocalypse-of-lens-dust

i wouldn't sweat it.

i had what looked like a fruit fly die inside the rear element of my 55mm mamiya-sekor.  was super upset about it until i realized it did absolutely nothing to my images.
M, 5Dc, 1Dx, some lenses, a few lights

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #15 on: August 26, 2013, 11:06:56 PM »

adhocphotographer

  • 6D
  • *****
  • Posts: 509
    • View Profile
    • An ad hoc photographer
5D MkIII + an every expanding array of lenses and accessories!
-------www.adhocphotographer.com--------

mrsfotografie

  • 1D X
  • *******
  • Posts: 1213
  • M.R.S. = my initials! www.mrsfotografie.nl
    • View Profile
    • MRS fotografie
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #17 on: August 27, 2013, 01:37:13 AM »
...

the bug is really small. about 1.5mm in length.

Shall I keep it? Or sell it?

LOL, taken out of context this is really funny :) In any case, enjoy your new lens; seems like a good deal to me.
5D3, 5D2, NEX-6 | SY14mm f/2.8, Ʃ20mm f/1.8, 24mm f/2.8, 35mm f/2, Ʃ35mm f/1.4A, 50mm f/1.8 I, Ʃ50mm f/1.4 EX, 100mm f/2.8L Macro, 17-40L, 24-105L, 70-200 f/2.8L IS II, 1.4x II, 70-300L, 100-400L | E-mount: SY12mm f/2, Ʃ19mm & 30mm f/2.8 EX DN, 16-50 & 55-210 OSS | 2x FT-QL, AE-1P, FD(n) & FL primes

shashinkaman

  • Power Shot G16
  • **
  • Posts: 38
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #18 on: August 28, 2013, 02:22:33 AM »
"Dust to dust..." the seller told you the truth  8)
Don't be such a Pixel Peeper!

LetTheRightLensIn

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 3284
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #19 on: August 28, 2013, 04:20:03 AM »
I don't think you'll get much for the bug, and after eBay and Paypal fees, it will hardly be worth it.

+1

doesn't make sense to try to sell off the bug on ebay, try CL instead

LetTheRightLensIn

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 3284
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #20 on: August 28, 2013, 04:34:50 AM »
Man, after reading all of this I'm sort of bummed I don't have a bug behind the front element of any of my lenses. Maybe I should dump my Canon (and Tamron) junk and pick up some Sigmas. Sure, sure it has a red ring.... well BIG freaking deal! Now a bug. Now that's class. Now you're talking. That's style. That's pizzazz. If that doesn't speak of luxury then nothing does. You know when people talk about things having a special magical je ne sais quoi? Well, I do know what. And it's having a bug behind my front element.

And for the techies out there: Who cares about fluorite elements when you can have a bug in the optical pathway? I bet the longitudinal CA performance of his lens is at a near unheard of level. Forget APO designs those are so 20th century. What you really want are BBFE designs.

About what about my precious Zeiss! Does it have bugs behind its front element? Does it? ANY? Not a one?! Enough is enough! I have had it without these monkey fighting bugs inside this MF lens!


« Last Edit: August 28, 2013, 04:45:14 AM by LetTheRightLensIn »

Ewinter

  • EOS M2
  • ****
  • Posts: 221
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #21 on: August 28, 2013, 04:44:03 AM »
They've already got the bug, it's why they bought the Lens!

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #21 on: August 28, 2013, 04:44:03 AM »

TommyLee

  • Rebel T5i
  • ****
  • Posts: 126
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #22 on: August 28, 2013, 06:21:19 AM »
we all have to go sometime

maybe if he was still alive...
you could hook up the Sigma Dock..
and he could walk out...on the dock


« Last Edit: August 28, 2013, 06:31:35 AM by TommyLee »

troy19

  • Power Shot G16
  • **
  • Posts: 19
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #23 on: August 28, 2013, 07:30:27 AM »
no need to argue with Sigma / the seller.

This is Sigmas recent attempt to search for lighter material than glass. So they chose amber. We all know sometimes there are little insects included, millions of years old. So the bug is a sign of quality. You may ask an archaeologist and if the species is yet unknown, you - as the first to see it - are allowed to give a name to it. Think of "Sigmania buginienis", doesn't that sound good, tribute to the developer included.  ;D

padmasana

  • Power Shot G16
  • **
  • Posts: 14
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #24 on: August 28, 2013, 09:56:22 AM »
Though I hate that there was a bug in the Sigma 50, I have to say this has been a tremendously entertaining thread.

distant.star

  • 1D X
  • *******
  • Posts: 1426
    • View Profile
    • Tracy's Shooting Gallery
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #25 on: August 28, 2013, 12:07:00 PM »
.
Be thankful it wasn't in your soup!
Walter: Were you listening to The Dude's story? Donny: I was bowling. Walter: So you have no frame of reference here, Donny. You're like a child who wanders into the middle of a movie and wants to know...

sandymandy

  • 6D
  • *****
  • Posts: 599
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #26 on: August 28, 2013, 01:16:36 PM »
Be happy ur not one of those unlucky guys who got an insect inside their tft screen!! it happened to me once only...but i was so mad lol...like some black pixels moving around -.-turned off screen and luckily the insect decided to leave when i came back next day :)

anthonyd

  • PowerShot G1 X II
  • ***
  • Posts: 62
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #27 on: August 28, 2013, 01:47:43 PM »
.
Be thankful it wasn't in your soup!

Oh yeah, a 50mm Sigma would definitely ruin a good soup.  ;)

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #27 on: August 28, 2013, 01:47:43 PM »