September 19, 2014, 06:08:23 AM

Author Topic: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!  (Read 7156 times)

00Q

  • Guest
I bought a 2nd hand Sigma 50mm f/1.4 on ebay. Its literally new, and boxed, all papers inside crisp.

It was advertised as having a singl piece of "dust" inside. Which doesnt affect the images as it is be beyond the resolution of the lens. So I managed to get it half price. Which is a damn good deal.

It arrived today. And I had a look. The "dust" is a small, tiny dead bug!! WTF. on the inside of the front element....WTF??

Anyway, as described, it doesnt affect the iamges at all. And Im really happy to have got the Sigma 50mm 1.4 literally new for half price. Now the question is.... will this bug cause me future problems? like is it gonna come off the front element? What if it then get to the inside of the back element? will that cause serious problems?

the bug is really small. about 1.5mm in length.

Shall I keep it? Or sell it?

canon rumors FORUM


TinaLovesCanon

  • Guest
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #1 on: January 28, 2012, 08:24:43 PM »
I don't think you'll get much for the bug, and after eBay and Paypal fees, it will hardly be worth it.

TexPhoto

  • 1D Mark IV
  • ******
  • Posts: 920
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #2 on: January 28, 2012, 08:39:10 PM »
I have to agree with Tina.  ;D  And if you are happy with the lens, keep it, use it.  I'd check with a camera repair place and see what the cost to have the bug removed is.I know having a front element replace is usually more than $100, but they are not replacing it.  Anyway, can't hurt to ask.  Heck, call Sigma they might do it for free.

tron

  • 1D X
  • *******
  • Posts: 1825
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #3 on: January 28, 2012, 08:49:58 PM »
Alternatively, take a picture with a close-up lens, send it to Sigma and ask them how the bug got there!!!

You can say that if their hardware has a bug one can only think about their software ...  ;D
They might even offer to clean it for free...  ;D

P.S I still laugh with Tina's post  ;D

tron

  • 1D X
  • *******
  • Posts: 1825
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #4 on: January 28, 2012, 08:55:12 PM »
This incident must be known. Then ebay sellers will have to advertise their Sigma lenses as bug free...   ;D

Seriously now, I would also ask for lens cleaning (debugging?   ;D)


picturesbyme

  • Canon 70D
  • ****
  • Posts: 255
    • View Profile
    • AtlanticPicture.com
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #5 on: January 28, 2012, 11:04:24 PM »
Send it in to sigma for cleaning. I had good experiences with their customer service.You'll  get a cleaned calibrated updated lens back at a decent price.
I sent in a 50 for focus issues.
Not that long ago I sent canon a brand new 60 macro b/c it had a shiny piece of glass behind the front.e. So it can happen to anyone..
Good luck.

wickidwombat

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4506
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #6 on: January 29, 2012, 06:43:46 PM »
you could try a vacuum cleaner, yeah I read about this on the internet, and thought i would give it a go for dust
put you hand over the lens to body mount to sort of seal around it then put the vacuum cleaner tube into the top of your hand, I kept the vacuum on low speed and you can feel the air sucking throught the lens and out the back, I dont think low speed provides enough sucktion to risk damaging any internals.
APS-H Fanboy

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #6 on: January 29, 2012, 06:43:46 PM »

nikkito

  • 7D
  • *****
  • Posts: 371
  • Argentine freelance photographer
    • View Profile
    • Facebook photo page
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #7 on: January 29, 2012, 07:03:47 PM »
Mother of Bug!  ;D
www.nicolaszonvi.com - www.facebook.com/zonviphoto

1D X, 5D Mk III, 5D Mk II, 16-35L, 24-70L, 70-200L IS, 85 f1.2, 40 f2.8, 50 f1.4, Sigma 10-20 and many other toy cameras.

mjbehnke

  • Rebel T5i
  • ****
  • Posts: 134
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #8 on: January 29, 2012, 07:49:10 PM »
I'd get ahold of Sigma and see if they have an upgraded version that is bug free. Most beta items always have a few bugs to work out before a final release.

.......... You need to take a photo and post it here so we can see this.

But really.... My photography friend has sent lenses back to Sigma and has gotten great service. They are pretty good here in the states anyway.
Gripped Canon 60D \ EF-S 15-85 F3.5-5.6 IS USM \ EF 70-200 F4L IS USM \ 430ex II Speedlite \ Love for photography.

bchernicoff

  • 6D
  • *****
  • Posts: 550
    • View Profile
    • My Photos
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #9 on: January 30, 2012, 05:23:54 PM »
The bug might have enough mass that a good sideways whack of the lens would dislodge it from the element and off to the side. I bumped my used Sigma 50mm and suddenly found an eyelash against the inside of the front element. I gave it a good sideways whack into the palm of my other hand and it's gone. I figure it's stuck to the side in there somewhere...
6D, Fuji X-E1
Tamron 24-70 2.8 VC, Canon 50mm f/1.2L, 70-200 f/2.8L IS II, 400mm f/2.8L II, 100mm L IS Macro, Sigma 85mm, & 35mm f/1.4's, Rokinon 14mm f/2.8, Canon 2x Extender II, Kenko 1.4x, 430 EX II, Elinchroms

Leg

  • SX50 HS
  • **
  • Posts: 1
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #10 on: August 26, 2013, 08:53:38 PM »
I have just bought a second hand lens, and seem to have a fruit fly on the inside!

It's a Mamiya 50mm 1.4

Pi

  • 1D Mark IV
  • ******
  • Posts: 937
    • View Profile
    • Math and Photography
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #11 on: August 26, 2013, 08:58:25 PM »
Put a spider inside.  :) Sorry, could not resist...

paul13walnut5

  • Guest
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #12 on: August 26, 2013, 09:05:36 PM »
Is it a shutterbug?

Does the af buzz?


canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #12 on: August 26, 2013, 09:05:36 PM »

jdramirez

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 2343
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #13 on: August 26, 2013, 09:06:03 PM »
you could try a vacuum cleaner, yeah I read about this on the internet, and thought i would give it a go for dust
put you hand over the lens to body mount to sort of seal around it then put the vacuum cleaner tube into the top of your hand, I kept the vacuum on low speed and you can feel the air sucking throught the lens and out the back, I dont think low speed provides enough sucktion to risk damaging any internals.

 I've done that for lenses I planned to sell.   dust barely moved. 
Upgrade  path.->means the former was sold for the latter.

XS->60D->5d Mkiii:18-55->24-105L:75-300->55-250->70-300->70-200 f4L USM->70-200 f/2.8L USM->70-200 f/2.8L IS Mkii:50 f/1.8->50 f/1.4->100L->85mm f/1.8 USM-> 8mm ->100L & 85L

Don Haines

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 3186
  • Posting cat pictures on the internet since 1986
    • View Profile
Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #14 on: August 26, 2013, 09:10:39 PM »
I bought a 2nd hand Sigma 50mm f/1.4 on ebay. Its literally new, and boxed, all papers inside crisp.

It was advertised as having a singl piece of "dust" inside. Which doesnt affect the images as it is be beyond the resolution of the lens. So I managed to get it half price. Which is a damn good deal.

It arrived today. And I had a look. The "dust" is a small, tiny dead bug!! WTF. on the inside of the front element....WTF??

Anyway, as described, it doesnt affect the iamges at all. And Im really happy to have got the Sigma 50mm 1.4 literally new for half price. Now the question is.... will this bug cause me future problems? like is it gonna come off the front element? What if it then get to the inside of the back element? will that cause serious problems

the bug is really small. about 1.5mm in length.

Shall I keep it? Or sell it?
Keep the bug, sell the lens... :)
The best camera is the one in your hands

canon rumors FORUM

Re: Dead bug on the inside of my Sigma 50mm f/1.4 front element!! WTF???!!!
« Reply #14 on: August 26, 2013, 09:10:39 PM »