December 21, 2014, 10:38:45 PM

Author Topic: HELP! Can't remove dirt from 1Ds MkIII sensor!  (Read 4311 times)

traveller

  • 5D Mark III
  • ******
  • Posts: 661
    • View Profile
HELP! Can't remove dirt from 1Ds MkIII sensor!
« on: February 06, 2012, 01:08:11 PM »
A mate of mine is having problems with his 1Ds MkIII's sensor  :'(, he keeps seeing the dust bunnies in shots, but he has cleaned the sensor five or six times with swabs and this hasn't cleared them.  He's also sent the camera off for cleaning (not to Canon yet) and they don't think it's dirt... I've attached a sample image. 

Does anyone have any suggestions as to what this could be, or how to get rid of it?

Thanks in advance.

canon rumors FORUM

HELP! Can't remove dirt from 1Ds MkIII sensor!
« on: February 06, 2012, 01:08:11 PM »

cfargo

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #1 on: February 06, 2012, 01:24:46 PM »
The dust can get underneath the filter too which is not cleanable by the consumer or your local camera store. If this is the case, Canon doesn't even clean the back side of the filter, they will just replace the sensor (big $$).  There are companies out there like Precision Camera in CT. that will actually remove the filter and clean or replace it. Not having your camera in my hands I can't tell you for sure that this is the case nor can anyone tell you this from looking at the picture you posted.

Take it to a bona fide camera rear shop (not a camera store) and have them look at it.  If you have a problem of finding one, let me know where you are and I will let you know who might be near you.

For tips on how to clean your sensor, you can visit my www site www.cleaningdigitalcameras.com

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • ***********
  • Posts: 9407
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #2 on: February 06, 2012, 01:29:12 PM »
I see some dark areas in the cloud images, it doesn't look like dust to me.  I hope he did not get cleaning fluid under the AA filter, that would ruin the sensor.  Cleaning with wet swabs when you apply excessive fluid can cause this.  You can see the dust on the sensor with a low powered microscope.

There is one tiny speck in the lower left corner, nothing to worry about.


cfargo

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #3 on: February 06, 2012, 01:42:15 PM »
I see some dark areas in the cloud images, it doesn't look like dust to me.  I hope he did not get cleaning fluid under the AA filter, that would ruin the sensor.  Cleaning with wet swabs when you apply excessive fluid can cause this.  You can see the dust on the sensor with a low powered microscope.

There is one tiny speck in the lower left corner, nothing to worry about.

If you download the full size image you can there is a whole lot of dust on it.  Yes on the smaller screen image here you only see the larger one in the lower left hand corner. Click on the image to see the full size version.

TW

  • PowerShot G1 X II
  • ***
  • Posts: 55
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #4 on: February 06, 2012, 02:11:31 PM »
Have you tried using a Brillo pad? :o :P ;D
35+ years of Canon gear...good grief! Still have 2 FTb cameras in working order, too!

zim

  • 1D Mark IV
  • ******
  • Posts: 794
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #5 on: February 06, 2012, 03:06:04 PM »
yuck that’s dirty, looks like someone threw a doughnut in the air bottom right  ;D

traveller

  • 5D Mark III
  • ******
  • Posts: 661
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #6 on: February 06, 2012, 05:55:13 PM »
Doesn't sound good so far! He is a CPS Platinum member and Canon have offered him a full service for £180, obviously not including any major damage they might find.  My thought was that there may be something broken inside that is spraying oil and muck around whenever the mirror moves.  If it was that then cleaning the sensor wouldn't help as the dirt would return when you returned the mirror. 

canon rumors FORUM

Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #6 on: February 06, 2012, 05:55:13 PM »

RuneL

  • EOS M2
  • ****
  • Posts: 201
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #7 on: February 07, 2012, 07:09:52 PM »
He should take it to service, have them look at it. Mucking about in there is serious business.

Edit: I dl'ed the pic and it just seems, to me, to be a regular dusty sensor. I've had mine look like this. Also, this get's real bad when shooting directly at the sky like this. I'm sure CPS could get rid of it, they use proper tools, magnifying classes and all sorts of witchery instead of what is effectively just a cotton swap with some rubbing alcohol on it.

Also, why is he cleaning such an expensive camera himself? IMO you're apt to do more damage than if you just leave it dusty, although I clean my older 1D myself I'd never do it to my new one.
 I take mine to cps once or twice a year for a dust off. I rarely shoot at anything higher than f5-10 or in daylight and the dust I have I'm able to kill of pretty easily with some copy-pasta of dust-removal points.
« Last Edit: February 07, 2012, 07:15:33 PM by RuneL »

D.Sim

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #8 on: February 07, 2012, 10:57:20 PM »
might be better to shoot a white background, bit hard to pick out the spots from that pic... but Canon might be the better people do do it, one of those spots almost looks like a scratch... unless its not a spot and my screen is deceiving me... *squints*

wockawocka

  • Canon 6D
  • *****
  • Posts: 394
    • View Profile
    • Wedding Photography
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #9 on: February 11, 2012, 05:45:00 PM »
That's dirt on the sensor, send it in to Canon and get an arctic butterfly for future use. Or just get one and try it out.

When I used some cleaning fluid I used (can't remember what but it was highly regarded) and it just left a load of residue. To the point I thought I'd done something to screw up the sensor.

Bought some other stuff and it cleaned it fine.

So, whenever cleaning a sensor with fluid you should leave that to Canon - and just Canon as you'll never get it all off and you can push it into the edges giving you really rubbish vignette. ESPECIALLY with full frame sensors as you have limited room to work and can pull in gunk from the sides.
1DX, 5D3 and Hasselblad H Series owner.

StacyC

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #10 on: February 13, 2012, 02:21:20 PM »
Have you tried using a Brillo pad? :o :P ;D

Surely you must be joking?!

D.Sim

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #11 on: February 15, 2012, 01:05:30 AM »
Have you tried using a Brillo pad? :o :P ;D

Surely you must be joking?!

I would think thats why he's got more expressions going on at once than Jim Carrey in the Mask...  :-X

iaind

  • Canon 70D
  • ****
  • Posts: 313
    • View Profile
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #12 on: February 15, 2012, 05:53:47 PM »
Have you tried using a Brillo pad? :o :P ;D

Surely you must be joking?!

If it's as indestructable as the 400d in the Digital Rev video just chuck it into the washing machine/dishwasher.
No guarantee is implied in the effectiveness of this solution ;D;D

Or send it to canon for an expensive service
5DIII + BGE11 / 5DII + BGE6 / 40D + BGE2N /8-15 4L / 17-35 2.8L / 24 3.5L TS-E /24-70 2.8II L / 24-105 4L IS /Zuiko 50 1.4/ 100 2.8L Macro IS / 70-200 2.8L /180 3.5L/ 300 4L / 100-400L

canon rumors FORUM

Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #12 on: February 15, 2012, 05:53:47 PM »

kenjancef

  • Guest
Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #13 on: February 19, 2012, 02:48:21 PM »
I would say it's dirt. I went through the same thing with a 5D Classic back in October. Went to a local camera repair shop, they couldn't clean it, and I couldn't do it as well, wasting $$ on cleaning fluid and such. Sent it to Canon, they cleaned it just fine.

One question: if he tries cleaning himself, do the dust particles move around, or are they in the same areas? For me, the particles were always there, but when I tried cleaning they moved around, they weren't always in the same place.

Hope that question made sense...

canon rumors FORUM

Re: HELP! Can't remove dirt from 1Ds MkIII sensor!
« Reply #13 on: February 19, 2012, 02:48:21 PM »