August 02, 2014, 02:07:10 AM

Author Topic: Canon 580 EX II hotshoe problem  (Read 4641 times)

SillyMike

  • Guest
Canon 580 EX II hotshoe problem
« on: July 21, 2010, 03:27:55 PM »
I found my flash would not communicate with the camera when tilted to the left, but would start communicating again when tilted to the right.  My flash is now back for a second time at one of their repair facilities.  The first time they did not believe anything was wrong with it and this time around I included detailed photos and an explanation along with the camera body. 

Just thought I might report this common problem.  There are a few instances on the internet about the loose hotshoe

www.sillymikephoto.com

canon rumors FORUM

Canon 580 EX II hotshoe problem
« on: July 21, 2010, 03:27:55 PM »

bopie

  • Guest
Re: Canon 580 EX II hotshoe problem
« Reply #1 on: November 27, 2010, 02:47:54 AM »
I don't want to offend, but you are aware of the locking mechanism right?

If you don't properly lock it down it could be loose on the contacts.

Other than that you're probably better off asking around on camera tech boards, rather than a rumor speculation site.

fotografiasi

  • Power Shot G16
  • **
  • Posts: 34
  • fotograf nunta iasi
    • View Profile
    • fotograf nunta iasi Daniel Condurachi
Re: Canon 580 EX II hotshoe problem
« Reply #2 on: November 29, 2010, 11:57:48 AM »
It happened to me also, and when tilted to the back. It would just not fire. I tried different modes on the camera and it did not work. I had to put it in the "normal" position and after a few miss-fired ones the flash started to work
fotograf nunta Iasi - Daniel Condurachi
Canon EOS 5D mark III, Canon EF 28mm f/1.8, Canon EF 85mm f/1.8, Canon EF 70-200mm f/2.8 IS II, 580EX II, manfrotto tripod, Paul C Buff Einstein, lightstands & radio triggers

canon rumors FORUM

Re: Canon 580 EX II hotshoe problem
« Reply #2 on: November 29, 2010, 11:57:48 AM »