July 26, 2014, 07:58:21 AM

Author Topic: Focusing problem while using 50mm 1.4 on 7D  (Read 2998 times)

rj79in

  • Guest
Focusing problem while using 50mm 1.4 on 7D
« on: March 11, 2012, 12:10:26 PM »
Hi,

I am having a weird problem with autofocus using the 50mm 1.4 on the 7D. Autofocus using the viewfinder is resulting in the images suffering from substantial blur. However, focusing at 10x using liveview is giving perfect focus.
 
I've tested considerably using a tripod and a cable release to eliminate any blur caused by camera shake but the problem remains as it is.

Any suggestions ...

canon rumors FORUM

Focusing problem while using 50mm 1.4 on 7D
« on: March 11, 2012, 12:10:26 PM »

zachdluchs

  • Guest
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #1 on: March 11, 2012, 01:26:08 PM »
I've heard of focusing issues with the 50mm 1.4 where the autofocus quits or breaks. Have you tried a different lens on your 7D to ensure that it isn't the focusing system on your camera?

rj79in

  • Guest
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #2 on: March 11, 2012, 01:31:20 PM »
Have tried other lenses and all are working fine. The 50mm is the only lens I am having trouble with

DJL329

  • 6D
  • *****
  • Posts: 467
    • View Profile
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #3 on: March 11, 2012, 02:43:49 PM »
Shooting with a fast (sub f/2.0) prime will give you a very shallow DOF, so your point of focus has to be precise.  Try stopping down (f/2.8-4.0) and see if it's still an issue.
Canon EOS 5D Mark III | EF 14mm f/2.8L | EF 28mm f/1.8 | EF 50mm f/1.4 | EF 85mm f/1.8 | EF 100mm f/2.8L IS Macro | EF 300mm f/4L IS

rj79in

  • Guest
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #4 on: March 11, 2012, 02:56:28 PM »
Shooting with a fast (sub f/2.0) prime will give you a very shallow DOF, so your point of focus has to be precise.  Try stopping down (f/2.8-4.0) and see if it's still an issue.

Will try that ... but still it begs the question, why perfect focus using LiveView and imperfect focus using the viewfinder

Mt Spokane Photography

  • Canon EF 600mm f/4L IS II
  • ********
  • Posts: 8255
    • View Profile
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #5 on: March 11, 2012, 03:31:16 PM »
Shooting with a fast (sub f/2.0) prime will give you a very shallow DOF, so your point of focus has to be precise.  Try stopping down (f/2.8-4.0) and see if it's still an issue.

Will try that ... but still it begs the question, why perfect focus using LiveView and imperfect focus using the viewfinder

Livefiew focus uses a contrast detect method, and will always be near perfect.  it is slow though.  The viewfinder uses phase detect which is very fast, but might need to be adjusted.  Use your 7D AFMA feature to tweak the phase detect AF.  If it cannot be corrected, send the lens (perhaps body too) to Canon for adjustment.

jwong

  • Guest
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #6 on: March 11, 2012, 03:31:36 PM »
Shooting with a fast (sub f/2.0) prime will give you a very shallow DOF, so your point of focus has to be precise.  Try stopping down (f/2.8-4.0) and see if it's still an issue.

Will try that ... but still it begs the question, why perfect focus using LiveView and imperfect focus using the viewfinder

Could be bad AF parts within the lens.  LiveView AF uses contrast detection which is more body driven.  I had an issue with a lens that was blurry from f/1.4 to f/4 with phase-detection but was fine with LiveView as well.  Sent it to Canon last week; hopefully I'll find out soon what's wrong with the lens.

canon rumors FORUM

Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #6 on: March 11, 2012, 03:31:36 PM »

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 13553
    • View Profile
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #7 on: March 11, 2012, 06:42:07 PM »
I'd try AF microadjusting the lens. Some suggestions in this tutorial, or check out Reikan FoCal software.
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

rj79in

  • Guest
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #8 on: March 12, 2012, 01:00:18 AM »
Nothing is setting it right. After considerable testing and trying out the microadjust, I have packed up the lens and sent it to Canon. It looks like a lens issue rather than a body issue because all my other lenses are working fine.

neuroanatomist

  • CR GEEK
  • ********
  • Posts: 13553
    • View Profile
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #9 on: March 12, 2012, 09:43:56 AM »
Probably best.  The AF system on the 50/1.4 is not the most robust (it's micromotor USM and achieves full-time manual focusing via a clutch mechanism, the only lens like that in the lineup).
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

EOBeav

  • 7D
  • *****
  • Posts: 402
    • View Profile
    • My Landscape Photoblog
Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #10 on: March 13, 2012, 12:47:00 AM »
The AF on the 50mm f/1.4 is notoriously unreliable. I owned mine for two years before I figured it out. If your 7D has microadjusting, try using that, but understand that you will still have some stray focus issues from time to time. Depending on what you're shooting, the Live View mode is probably your best bet. I recently discovered that on my 5DmkII and am glad I did. I call this lens the Mae West of camera lenses. When it's good, it's really really good. But when it's bad...

With all of that said, I love using my 50mm f/1.4.
In landscape photography, when you shoot is more important than where.

Gear: Canon 5DmkII, 17-40mm f/4 L, 50mm f/1.4, 70-200mm f/4.

canon rumors FORUM

Re: Focusing problem while using 50mm 1.4 on 7D
« Reply #10 on: March 13, 2012, 12:47:00 AM »