October 01, 2014, 07:08:12 AM

Author Topic: Poll: 5Dmkiii top LCD malfunction  (Read 714 times)

@!ex

  • Canon 70D
  • ****
  • Posts: 295
    • View Profile
    • My portfolio
Poll: 5Dmkiii top LCD malfunction
« on: April 06, 2012, 01:21:21 AM »
Just noticed this today while shooting with a friend.  She was using exposure compensation a lot (the way she shoots, rather than meter locking she just leaves in it evaluative and uses EV comp, I know kind inefficient but thats another story, anywho...), and she kept wondering why the little marker under the compensation scale on the top lcd wasn't moving.  it was, but we realized that when it went over +1/3 it would disappear, the exposure values would still increase as you scrolled up but on the lcd the little moving mark would just disappear until you went over +3 then the little arrow would show up informing you that you are over +3 EV comp.  on the negative EV comp side of the scale everything works perfectly, and in the optical viewfinder the EV comp scale on the bottom everything works fine + and -.  I am gonna have to exchange the body tomorrow, but just wanted to see if anyone else has this problem, and also make sure that everyone checks, because i might not have noticed this for a while as I normally just use it in the viewfinder.


canon rumors FORUM

Poll: 5Dmkiii top LCD malfunction
« on: April 06, 2012, 01:21:21 AM »

wickidwombat

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4515
    • View Profile
Re: Poll: 5Dmkiii top LCD malfunction
« Reply #1 on: April 06, 2012, 01:32:24 AM »
insert obligatory must be user error post here :P

I took mine back yesterday, just waiting for a replacement to come in now :(
APS-H Fanboy

@!ex

  • Canon 70D
  • ****
  • Posts: 295
    • View Profile
    • My portfolio
Re: Poll: 5Dmkiii top LCD malfunction
« Reply #2 on: April 06, 2012, 01:35:02 AM »
insert obligatory must be user error post here :P

I took mine back yesterday, just waiting for a replacement to come in now :(

Same exact problem I take it, ya Wombat?

wickidwombat

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4515
    • View Profile
Re: Poll: 5Dmkiii top LCD malfunction
« Reply #3 on: April 06, 2012, 02:31:57 AM »
insert obligatory must be user error post here :P

I took mine back yesterday, just waiting for a replacement to come in now :(

Same exact problem I take it, ya Wombat?

Nah mine had all sorts of wierd AF issues, it just wasn't working properly, getting 00 errors on top etc
I think its likely there will be a few faulty units come out but generally it looks like the bulk seem to be going well
you looked like yours was going fine until this popped up out of no where. I love the camera just want one that works like my other cameras
APS-H Fanboy

canon rumors FORUM

Re: Poll: 5Dmkiii top LCD malfunction
« Reply #3 on: April 06, 2012, 02:31:57 AM »