November 26, 2014, 11:10:29 AM

Author Topic: 430ex II assist beam - is this normal??  (Read 2094 times)

CowGummy

  • EOS M2
  • ****
  • Posts: 168
    • View Profile
    • www.smrphotoart.com
430ex II assist beam - is this normal??
« on: April 20, 2012, 08:22:06 PM »
Hi all,

I was shooting a stag-do (aka: bachelor party) last weekend and noticed that my assist beam on my 430ii was not firing. I didn't have time to work out what was going on then and there, but am now trying to figure out if my flash is faulty or if there is something I simply don't know about.

I always shoot with my 5Dii in full manual mode, and usually the flash as well. Although in this case I switched the flash to ETTL. So full manual on the body side, AF set to AI Servo, drive set to continuous shooting and I use backbutton focusing, which I've swapped with the * button just to right of the AF-ON button on my 5Dii. This was the setup I was using, and the flash assist beam didn't fire a single time.

So after a little bit of research I figured out that the assist beam will only fire in One Shot mode, not AI Servo. Fair enough, makes sense really. But when I change the above mentioned configuration to One Shot and leave everything else as it is, only the right hand side of the flash assist beam fires, whereas when I switch to Full Auto (green square) both sides of the flash assist beam light up. What gives?? For me the assist beam works a treat especially with the 5Dii AF issues... But I hate not being able to shoot full manual!

Anyone have any ideas what's going on here?
5DmkII   |  50 f/1.4  |  24-105L f/4  |  135L f/2  |  70-200L f/2.8 IS II  |  430exII

canon rumors FORUM

430ex II assist beam - is this normal??
« on: April 20, 2012, 08:22:06 PM »

PeterJ

  • Canon 6D
  • *****
  • Posts: 342
    • View Profile
Re: 430ex II assist beam - is this normal??
« Reply #1 on: April 20, 2012, 09:44:13 PM »
What lens were you using? I've got a 580EX II and 28mm and longer is listed as the compatible focal range, I'd got caught before with it not firing with a 24-70 when used at the wide end.

PaperTiger

  • Guest
Re: 430ex II assist beam - is this normal??
« Reply #2 on: April 20, 2012, 10:42:39 PM »
The AF assist beam won't work in AI Servo. Only Focus or One Shot.

CowGummy

  • EOS M2
  • ****
  • Posts: 168
    • View Profile
    • www.smrphotoart.com
Re: 430ex II assist beam - is this normal??
« Reply #3 on: April 26, 2012, 08:47:44 AM »
Okay, I think I've worked it out...

Yes, assist beam won't work on Servo mode, I did mention this to start with. As for why only one side lights up, I believe that the right side of the assist beam (when looking at the flash straight on) is for the centre AF point, the left assist beam for the peripheral AF points. As I always shoot with centre point only, this would explain the issue at hand.

I just wanted to share this in case anyone else notices similar things with their assist beam.
5DmkII   |  50 f/1.4  |  24-105L f/4  |  135L f/2  |  70-200L f/2.8 IS II  |  430exII

canon rumors FORUM

Re: 430ex II assist beam - is this normal??
« Reply #3 on: April 26, 2012, 08:47:44 AM »