December 20, 2014, 12:29:50 PM

Author Topic: Canon 5d Mark iii and 580 ex ii issues  (Read 9605 times)

jwlister

  • Guest
Canon 5d Mark iii and 580 ex ii issues
« on: May 07, 2012, 09:49:14 PM »
I just shot a wedding with my new 5d mark iii and had many annoying issues.  My pocket wizards wouldn't work so I used my 580 ex ii to trigger my 430 ex ii optically.  First off, the flash on camera would always fire even when I turned it off in the settings.   So instead of my nice soft light shot through an umbrella, I got the deer in the headlights look.  I ended up having to turn the 530ex ii way down and point it to the side.  Also high speed sync wouldn't work when on wireless, although it has been so long since I used the 430ex ii so I can't remember if this is within its capabilities.  That's not all,  when just using the 530ex ii on camera, the autofocus assist beam would not work even though it was on.    All these problems add up to an awesome camera with very annoying quirks I'm hoping were not by design to make us by the new canon flash...

canon rumors FORUM

Canon 5d Mark iii and 580 ex ii issues
« on: May 07, 2012, 09:49:14 PM »

Drizzt321

  • 1D X
  • *******
  • Posts: 1675
    • View Profile
    • Aaron Baff Photography
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #1 on: May 08, 2012, 12:56:36 PM »
Yes, there's been word on the forums here at the PW doesn't seem to work with the 5d3 unfortunately. Can't speak to the 580EX II triggering a 430EX II, I have never used either as a optical remote trigger.

There's no setting in the flash itself to disable firing but still use it as a master? Never took a look, and haven't had the opportunity to use it with my 5d3 at all yet.
5D mark 2, 5D mark 3, EF 17-40mm f/4L,  EF 24-105mm f/4L IS USM, EF 135mm f/2L, EF 85mm f/1.8
Film Cameras: Mamiya RB67, RB-50, RB-180-C, RB-90-C, RB-50, Perkeo I folder, Mamiya Six Folder (Pre-WWII model)
http://www.aaronbaff.com

dericcainphoto

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #2 on: May 08, 2012, 01:33:11 PM »
I don't now if this is much help, but I shot a wedding a couple of weekends ago, and my PWs worked flawlessly. I am using the PW Plus III's and I do not know if that has anything to do with it. I did notice one quirk, though. When the bride and groom were leaving, I had the camera set to AV and as I fired off a series of shots, a couple of them were tremendously underexposed. Most of the time I use manual, so I did not notice this until I shot in AV. There series of shots were all at f2.8 and about 1/500th of a second, except for about three of them which were 1/3200th of a second. That's a pretty big shift in exposure. I will pay attention and see if it happens again. Anyways, sorry and I didn't mean to hijack your thread.

Ryant

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #3 on: May 08, 2012, 01:40:12 PM »
I wonder what the issue is. My 580ii turns off find in the mark iii menus. You still had the problems without the pocket wizards?

Ryan

JerryKnight

  • EOS M2
  • ****
  • Posts: 186
    • View Profile
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #4 on: May 08, 2012, 02:15:13 PM »
I'm pretty sure the reported PW problems have been referring to the TT1/TT5's, but I used them last weekend and they worked perfectly. However, I used them with manual flashes, so maybe it's the TTL features that don't yet work with the 5D3. I haven't tested them with E-TTL.

Jamesy

  • 5D Mark III
  • ******
  • Posts: 728
    • View Profile
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #5 on: May 08, 2012, 02:25:29 PM »
I believe you will always get a 1/32 pre-flash on the master, even if it is configured to not contribute to the exposure.

In terms of the AF assist light, what are your settings in the flash menu? I think there are a few options if I recall. OFF, IR or Disco ball mode (where the flash lights up the scene).

jwlister

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #6 on: May 08, 2012, 03:31:01 PM »
I realize there still is a flash but on my 7d it doesn't expose. I had the af assist beam on in the 5d menu so I don know what the problem is there. As for the wireless trigger I had it on master off in the 5d flash menu and still fired and exposed. Frustrating.

canon rumors FORUM

Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #6 on: May 08, 2012, 03:31:01 PM »

Jamesy

  • 5D Mark III
  • ******
  • Posts: 728
    • View Profile
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #7 on: May 08, 2012, 03:49:43 PM »
A buddy of mine has a 60D and he has the issue of the built-in flash contributing to the exposure in a master/slave setup, even when it is off for some reason. I will try  this with mine when I get a moment - I have two 580EXII's.

Jamesy

  • 5D Mark III
  • ******
  • Posts: 728
    • View Profile
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #8 on: May 08, 2012, 10:57:47 PM »
On my 5d3, I played around with an on camera 580ex2 in master mode (group A), set to not fire and a slave in group B and the master flash definitely contributed to the exposure.

I tried the same test on my 40D and got the same results. That said, I don't know if your issue is limited to the 5D3.

Canon wireless uses light to communicate, except on the St-E2, which uses IR.

Ryant

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #9 on: May 09, 2012, 05:27:58 AM »
Just another thought, were you trying to get the focus assist beam to turn on while using AI Servo?  I thought mine was broken when it first happened then found out it never turns on in that mode. Which is annoying since the mark iii's AI Servo mode is awesome.

Ryan

jwlister

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #10 on: May 09, 2012, 06:38:58 AM »
That's it! I was in AI Servo. I have to use it with my fasts prime lenses or nothing would ever be in focus!  I tested wireless with master off o. Ettl on my 7 d and it did not contribute. I hope this is just a firmware glitch. Do u think I should notify canon?

Jamesy

  • 5D Mark III
  • ******
  • Posts: 728
    • View Profile
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #11 on: May 09, 2012, 07:19:14 AM »
I tested wireless with master off o. Ettl on my 7 d and it did not contribute. I hope this is just a firmware glitch. Do u think I should notify canon?
You could notify them and ask why it does this but as I said I tested the 5D3 and my 40D with the same results.

Can anyone else test this on their end?

Ryant

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #12 on: May 09, 2012, 05:41:16 PM »
That's it! I was in AI Servo. I have to use it with my fasts prime lenses or nothing would ever be in focus!  I tested wireless with master off o. Ettl on my 7 d and it did not contribute. I hope this is just a firmware glitch. Do u think I should notify canon?

Unfortunately this is not a bug. This is how the 5D 2 and 5D 1 work as well. I want it, but I doubt asking them for it will get you anywhere since its as designed.

Ryan

canon rumors FORUM

Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #12 on: May 09, 2012, 05:41:16 PM »

jwlister

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #13 on: May 09, 2012, 10:49:18 PM »
Thanks for all your help everyone.

CMI

  • Guest
Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #14 on: May 22, 2012, 10:08:45 AM »
Bottom line here is PW needs to get off their butts!  We have waited long enough for the firmware update.  If pocket wizard wants to be part of canon gear then they need to step up, not canon's problem!

I have 3 tti5's and a mini I can't even think about using the mark iii with.  my brand new camera stays in the bag and i shoot with my mark ii's   1/200 is not fast enough and some photographers are saying that can't even get that without problems.

canon rumors FORUM

Re: Canon 5d Mark iii and 580 ex ii issues
« Reply #14 on: May 22, 2012, 10:08:45 AM »