April 16, 2014, 12:50:36 PM

Author Topic: Lightroom 4.1 Running SLOW!  (Read 18237 times)

hhelmbold

  • Rebel T5i
  • ****
  • Posts: 116
    • View Profile
Re: Lightroom 4.1 Running SLOW!
« Reply #45 on: November 11, 2012, 03:42:25 PM »
I keep all my RAW files in CR2 format, could that be the problem?


Yes, that's it - the solution is convert them to dng and check the "embed fast-load data" option, that's specifically made for speeding up raw rendering. You can still embed cr2 in the dng if you never ever want to loose the original format, though of course required hd doubles. Personally, I like dng since all programs I ever looked at (except dxo) work with raw dng nowadays.


Sorry guys but I have to disagree... I know a lot of people preach converting to dng but I found that DNG IS the problem for Lightroom being so slow. I run an i7 processor with 24GB of RAM and when I convert to dng, I will click on the crop tool, wait 10 seconds... crop... wait 10 seconds... adjust a slider... wait 10 seconds etc etc. All my other catalogues are in CR2 format, so it made me think and I came across this article : http://www.foto-biz.com/Lightroom/The-case-against-dng

I kept the dng files I already worked on, deleted the rest from the catalogue and re-imported the CR2 files from the memory card... Suddenly Lightroom was working the way it is supposed to again. So my experience tells me that the dng file is indeed the problem.

canon rumors FORUM

Re: Lightroom 4.1 Running SLOW!
« Reply #45 on: November 11, 2012, 03:42:25 PM »

Marsu42

  • 1D X
  • *******
  • Posts: 4089
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: Lightroom 4.1 Running SLOW!
« Reply #46 on: November 11, 2012, 03:56:32 PM »
So my experience tells me that the dng file is indeed the problem.

Did you use LR4's dng version with "Embed Fast Load Data"? That's exactly made to speed up rendering, though at the cost of a bit larger filesize - and still smaller than the original cr2.

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7701
    • View Profile
Re: Lightroom 4.1 Running SLOW!
« Reply #47 on: November 11, 2012, 04:52:58 PM »
I've run tests on DNG converted files with my D800.  The time to render them is faster, but not by much. 

JMA

  • Guest
Re: Lightroom 4.1 Running SLOW!
« Reply #48 on: January 05, 2013, 08:40:32 PM »
I’ve only noticed LR 4.3 running painfully slow just recently, I’ve done heaps of searching but nothing people were recommending was fixing it, so I thought, what have I changed in the last month, then I remembered that I installed a new anti-virus, (bitdefender), where previously I was using AVG, so I uninstalled it, LR is now running perfect.
Not sure if this will work for everyone, but it might be worth a try.

Etienne

  • 6D
  • *****
  • Posts: 505
    • View Profile
    • Photography by Steve Brule
Re: Lightroom 4.1 Running SLOW!
« Reply #49 on: September 19, 2013, 11:10:55 PM »
My LR 4.4 is soooo sloowwww on import, that the program has become useless to me
I have about 50,000 images

Any suggestions?

Marsu42

  • 1D X
  • *******
  • Posts: 4089
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: Lightroom 4.1 Running SLOW!
« Reply #50 on: September 20, 2013, 02:21:50 AM »
My LR 4.4 is soooo sloowwww on import, that the program has become useless to me
I have about 50,000 images Any suggestions?

Get LR5 which is speed-optimized - and I just split up my 60k image catalog into 2x 30k, big improvement, watch out in task manager (Windows) for lr using virtual memory ("commit size") which slows down lr to a crawl.

Etienne

  • 6D
  • *****
  • Posts: 505
    • View Profile
    • Photography by Steve Brule
Re: Lightroom 4.1 Running SLOW!
« Reply #51 on: September 20, 2013, 09:58:43 AM »
My LR 4.4 is soooo sloowwww on import, that the program has become useless to me
I have about 50,000 images Any suggestions?

Get LR5 which is speed-optimized - and I just split up my 60k image catalog into 2x 30k, big improvement, watch out in task manager (Windows) for lr using virtual memory ("commit size") which slows down lr to a crawl.

Thanks!... what do youdo about the virtual memory? can you clear or delete it?

canon rumors FORUM

Re: Lightroom 4.1 Running SLOW!
« Reply #51 on: September 20, 2013, 09:58:43 AM »

Marsu42

  • 1D X
  • *******
  • Posts: 4089
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: Lightroom 4.1 Running SLOW!
« Reply #52 on: September 20, 2013, 10:12:57 AM »
Thanks!... what do youdo about the virtual memory? can you clear or delete it?

If LR maxes out your "real" memory and swaps to the hard drive, you're sunk and the program slows to a crawl. Try these:

* upgrade your memory (unfortunately my laptop only accepts 4gb)
* split up your catalogs, good idea for bulk operations anyway
* close background programs
* disable windows superfetch except for boot (use google for step-by-step) if your computer after some time sometimes slows down significantly for no apparent reason

mackguyver

  • 1D X
  • *******
  • Posts: 1472
  • Who Dares Wins
    • View Profile
    • My Website
Re: Lightroom 4.1 Running SLOW!
« Reply #53 on: September 20, 2013, 10:28:07 AM »
That's exactly why I gave up on Lightroom.  It's SO SLOW.  I use Photomechanic for previews, and then DxO or ACR in Photoshop to process.

If you just need a fast way to view your photos (pre-editing), check out the FastpictureViewer Codec Pack.  It's $15-20 and integrates with Windows 7 & later.  It runs in 64-bit and creates thumbnails from CR2 files insanely fast.  It also generates full previews of CR2 files with Windows Picture Viewer extremely quickly as well.  They have a free trial, which sold me on it.

http://www.fastpictureviewer.com/codecs/

Before Photomechanic (and back when DxO was also really slow), I would use it to select the photos I wanted to edit.
EOS M | 5D III | 1D X
EF 24 1.4L II | 50 1.2L | 85 1.2L II | 180 3.5L Macro | 300 2.8L IS II 16-35 2.8L II | 24-70 2.8L II | 70-200 2.8L IS II
TS-E 24 3.5L II :: Extender 1.4x III | 2x III :: EF-M 22 2 | 18-55mm 3.5-5.6 IS

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7701
    • View Profile
Re: Lightroom 4.1 Running SLOW!
« Reply #54 on: September 20, 2013, 11:15:10 AM »
Lightroom has always been fast for me.  However, there are some ways to speed it up.
1.  Put the catalog on a SSD, preferably the main drive.  You can put your images on a separate drive.  SSD's are now relatively cheap.
 
2.  Make sure you have enough memory installed, 8GB is often not enough to edit large files efficiently.  try to get 16GB or more installed. 

terminatahx

  • PowerShot G16
  • **
  • Posts: 14
    • View Profile
    • Aubrey Williams photography
Re: Lightroom 4.1 Running SLOW!
« Reply #55 on: September 21, 2013, 06:54:02 PM »
You need better hardware.

I run the intel i7 3770k overclocked to 4.5ghz, win7 x64, 16gb ram , dual evga gtx670s. This config let's me run above apps with amazing speed. Upgrading to ssd provided another huge speed benefit as well. You need cores, ram, ssd and fast gpus.
5DMkIII | 24-70 f2.8LII | 100 f2.8L | 16-35 f2.8LII | TSE-17 f4L

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7701
    • View Profile
Re: Lightroom 4.1 Running SLOW!
« Reply #56 on: September 21, 2013, 07:53:08 PM »
My LR 4.4 is soooo sloowwww on import, that the program has become useless to me
I have about 50,000 images

Any suggestions?

Can you determine if its lightroom, or a card issue?  Try copying image files to a folder on lightroom , and then importing them from that location.  If still slow, then lightroom or the computer needs work.   The lightroom catalog is a first target when there are issues, so rebuild it first. 
Secondly, I'd create a new catalog for test purposes and import images into it to see how that works.
 
Then, I'd start checking my computer hardware, test the memory, test the hard drive, since one of those could be a issue.  Be sure to install the latest video card drivers, they cause a huge amount of trouble.
 
Finally, reinstall Lightroom with a new catalog.  if that fixes things, then switch to the old catalog and verify its working.  Then remove the test catalogs.

Marsu42

  • 1D X
  • *******
  • Posts: 4089
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: Lightroom 4.1 Running SLOW!
« Reply #57 on: September 22, 2013, 02:55:36 AM »
You need cores, ram, ssd and fast gpus.

And with the money left after these purchases, shoot with a Rebel 550d and a 50/1.8 :-> ... nothing against helping the economy, but for my money I'd first split large catalogs, allocate catalog & data on different disks, turn off sharpening/nr until exporting - lr5 also has smart previews to prevent working on the full resolution.

canon rumors FORUM

Re: Lightroom 4.1 Running SLOW!
« Reply #57 on: September 22, 2013, 02:55:36 AM »

Etienne

  • 6D
  • *****
  • Posts: 505
    • View Profile
    • Photography by Steve Brule
Re: Lightroom 4.1 Running SLOW!
« Reply #58 on: September 22, 2013, 02:01:04 PM »
You need better hardware.

I run the intel i7 3770k overclocked to 4.5ghz, win7 x64, 16gb ram , dual evga gtx670s. This config let's me run above apps with amazing speed. Upgrading to ssd provided another huge speed benefit as well. You need cores, ram, ssd and fast gpus.

I have an i7 920 processor, Windows 7 64bit, 12 GB RAM
Lightroom is the only thing that runs slowly now. It ran fine a year ago

Marsu42

  • 1D X
  • *******
  • Posts: 4089
  • ML-66d / 100L / 70-300L / 17-40L / 600rts
    • View Profile
    • 6D positive spec list
Re: Lightroom 4.1 Running SLOW!
« Reply #59 on: September 22, 2013, 02:03:37 PM »
I have an i7 920 processor, Windows 7 64bit, 12 GB RAM
Lightroom is the only thing that runs slowly now. It ran fine a year ago

In that case, it also could be a bug - to debug: a) try disabling all plugins, b) use a new catalog (write all metadata to files, new catalog, read metadata)

canon rumors FORUM

Re: Lightroom 4.1 Running SLOW!
« Reply #59 on: September 22, 2013, 02:03:37 PM »