September 18, 2014, 10:06:18 AM

Author Topic: Anyone heard of this problem before???  (Read 1358 times)

adhocphotographer

  • 6D
  • *****
  • Posts: 537
    • View Profile
    • An ad hoc photographer
Anyone heard of this problem before???
« on: June 14, 2012, 07:04:06 AM »
For some time now, my camera (450D), intermittently decides it does not want to start. It is never permanently, lasts for about 30-60sec then decides it has finished its little tantrum and wants to play again…  It does not appear to be a battery problem as I have interchanged batteries and still won’t start. It also has happened in normal and aberrant conditions (cold/hot) alike.
It is 3 years old and only has about 140k actuations (shutter still works fine)…
So, just wondered if anyone else has come across this kind of thing?  And if so, any advice?
Don’t know if I can be bothered to send it off to Canon as it has not exactly been a big problem yet, but I know that if a miss a great shot because of it, I would be a little sad! Time for its retirement?

Thanks,

John
5D MkIII + an every expanding array of lenses and accessories!
-------www.adhocphotographer.com--------

canon rumors FORUM

Anyone heard of this problem before???
« on: June 14, 2012, 07:04:06 AM »

rwmson

  • Rebel T5i
  • ****
  • Posts: 122
    • View Profile
    • Spirit Studios
Re: Anyone heard of this problem before???
« Reply #1 on: June 14, 2012, 07:21:42 AM »
Maybe clean the camera's battery contacts?  Better yet, use this opportunity to rationalize an upgrade to a 5Dmk3! ;D
Rebel T1i | G12 | 5D Mk III | Canon 24-105mm f/4L IS USM AF | Canon Telephoto EF 100mm f/2.8 USM Macro | Canon EF 70-200mm f/2.8L IS II USM Telephoto Zoom | EF 24-70mm f/2.8L II USM Zoom Lens

adhocphotographer

  • 6D
  • *****
  • Posts: 537
    • View Profile
    • An ad hoc photographer
Re: Anyone heard of this problem before???
« Reply #2 on: June 14, 2012, 07:23:13 AM »
Maybe clean the camera's battery contacts?  Better yet, use this opportunity to rationalize an upgrade to a 5Dmk3! ;D

Thanks, didn't think of bat conections (doh)...  will get on it and see if it helps...  :) Otherwise i guess i will *have* to upgrade...  :D
5D MkIII + an every expanding array of lenses and accessories!
-------www.adhocphotographer.com--------

Marine03

  • Rebel T5i
  • ****
  • Posts: 138
    • View Profile
Re: Anyone heard of this problem before???
« Reply #3 on: June 14, 2012, 09:36:28 AM »
I was shooting a wedding this past week and had 2 instances with my 450 where I knew I had turned it on and a min or two later, it wont do anything, no LCD turn on or focus etc,  even after turning the switch on and off a few times.    Then magically it came back to life.     OOO and I have way less clicks than you so doubt thats the issue.
6D, 450D(collecting dust), Nifty Fifty, 565EX Flash

adhocphotographer

  • 6D
  • *****
  • Posts: 537
    • View Profile
    • An ad hoc photographer
Re: Anyone heard of this problem before???
« Reply #4 on: June 14, 2012, 02:24:39 PM »
I was shooting a wedding this past week and had 2 instances with my 450 where I knew I had turned it on and a min or two later, it wont do anything, no LCD turn on or focus etc,  even after turning the switch on and off a few times.    Then magically it came back to life.     OOO and I have way less clicks than you so doubt thats the issue.

That's exactly it! makes me feel a wee bit better, though i could just mean both or cameras are dieing!  :)
5D MkIII + an every expanding array of lenses and accessories!
-------www.adhocphotographer.com--------

canon rumors FORUM

Re: Anyone heard of this problem before???
« Reply #4 on: June 14, 2012, 02:24:39 PM »