November 27, 2014, 03:16:17 PM

Author Topic: Eos Utility camera not recognized  (Read 28871 times)

Fytos

  • Guest
Eos Utility camera not recognized
« on: June 13, 2012, 01:48:12 PM »
I bought a 5D mkIII last week and I still can't connect it to the computer with the Eos utility.
Every time I try to connect it I get camera not recognized, I tried 5 different computers 15 different usb ports and 5 usb cables, mac and windows, 64bit and 32 bit so the problem is the actual software from Canon.
Anyone  have a solution for that? or have the same problem?
The camera came with the latest firmware installed.

Thanks

canon rumors FORUM

Eos Utility camera not recognized
« on: June 13, 2012, 01:48:12 PM »

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 9182
    • View Profile
Re: Eos Utility camera not recognized
« Reply #1 on: June 13, 2012, 05:35:55 PM »
I bought a 5D mkIII last week and I still can't connect it to the computer with the Eos utility.
Every time I try to connect it I get camera not recognized, I tried 5 different computers 15 different usb ports and 5 usb cables, mac and windows, 64bit and 32 bit so the problem is the actual software from Canon.
Anyone  have a solution for that? or have the same problem?
The camera came with the latest firmware installed.

Thanks

No problem here, windows 7 recognizes the camera just fine.  EOS utility was only needed for remote shooting.
 
Its possible that the camera has a issue.  Seems unlikely to be a Canon software issue, since you have installed it on multiple computers, and other than on certain Mac OS, there are no issues for most users.

Hillsilly

  • 1D Mark IV
  • ******
  • Posts: 792
    • View Profile
Re: Eos Utility camera not recognized
« Reply #2 on: June 13, 2012, 08:11:34 PM »
I installed a new version of EOS utility recently when I purchased a new computer (running Windows 7) and now can't connect my 1Ds Mk ii via firewire.  A bit frustrating, but I don't use it enough to warrant a lot of time trying to fix it.  Good (?) to hear I'm not the only one with problems.  I think my issue is a driver problem.  I can see my camera listed as a device (if you click on devices and printers).  But it has a red mark on it and the error message talks about driver issues.  Looking at the Canon site, my camera doesn't seem to have a driver.  I just assumed Canon no longer supports my camera and I need to track down an older version of the software.  But maybe its a bigger issue.
Camera Obscura

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 9182
    • View Profile
Re: Eos Utility camera not recognized
« Reply #3 on: June 13, 2012, 08:59:12 PM »
I installed a new version of EOS utility recently when I purchased a new computer (running Windows 7) and now can't connect my 1Ds Mk ii via firewire.  A bit frustrating, but I don't use it enough to warrant a lot of time trying to fix it.  Good (?) to hear I'm not the only one with problems.  I think my issue is a driver problem.  I can see my camera listed as a device (if you click on devices and printers).  But it has a red mark on it and the error message talks about driver issues.  Looking at the Canon site, my camera doesn't seem to have a driver.  I just assumed Canon no longer supports my camera and I need to track down an older version of the software.  But maybe its a bigger issue.

Its not suprising, since the 1Ds MK II is no longer supported.  There is nothing wrong except that it Canon dropped firewire support a couple of years ago for this camera.  Thats why you don't find drivers on the canon site, there are none.
 
This is not the same as someone being unable to connect his camera when 1 million others can.  He has a real issue to work out.

Fytos

  • Guest
Re: Eos Utility camera not recognized
« Reply #4 on: June 15, 2012, 04:46:17 PM »
I send an email to canon UK for the problem and they send me How to fix it, http://www.canon.co.uk/Support/Consumer_Products/products/cameras/Digital_SLR/EOS_5D_Mark_III.aspx?faqtcmuri=tcm:14-917248&page=1&type=faq

Didn't work for me I still can't connect my camera to EOS Utility for remote shooting :(

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 9182
    • View Profile
Re: Eos Utility camera not recognized
« Reply #5 on: June 15, 2012, 08:29:59 PM »
I send an email to canon UK for the problem and they send me How to fix it, http://www.canon.co.uk/Support/Consumer_Products/products/cameras/Digital_SLR/EOS_5D_Mark_III.aspx?faqtcmuri=tcm:14-917248&page=1&type=faq

Didn't work for me I still can't connect my camera to EOS Utility for remote shooting :(

I'd return the camera or exchange it.  The computer can be a problem, but you should be able to connect. 
 
Sometimes conflicts with other software can be a issue as well.  You can boot with other software drivers temporarily disabled by running msconfig and unchecking unnecessary software that runs automatically at startup.  If that fixes the issue, you can narrow it down to the offending software and remove or update it.

pwp

  • 1D X
  • *******
  • Posts: 1615
    • View Profile
Re: Eos Utility camera not recognized
« Reply #6 on: June 15, 2012, 10:00:43 PM »
I bought a 5D mkIII last week and I still can't connect it to the computer with the EOS utility.

My 5D3 wasn't seen by EOS Utility at first as I was running a previous version that shipped with my 1D4. Ran the latest software that shipped with the camera and everything connects & functions as expected. Same story with both my Macbook Pro and Windows 7 64 PC's.

PW

canon rumors FORUM

Re: Eos Utility camera not recognized
« Reply #6 on: June 15, 2012, 10:00:43 PM »

swampler

  • Rebel T5i
  • ****
  • Posts: 140
    • View Profile
Re: Eos Utility camera not recognized
« Reply #7 on: June 15, 2012, 11:32:54 PM »
I bought a 5D mkIII last week and I still can't connect it to the computer with the EOS utility.

My 5D3 wasn't seen by EOS Utility at first as I was running a previous version that shipped with my 1D4. Ran the latest software that shipped with the camera and everything connects & functions as expected. Same story with both my Macbook Pro and Windows 7 64 PC's.

PW
I was going to suggest updating the EOS Utility program too.

spinworkxroy

  • Canon 70D
  • ****
  • Posts: 261
    • View Profile
Re: Eos Utility camera not recognized
« Reply #8 on: June 16, 2012, 12:20:38 AM »
i had the same problem before..i somehow suspect if you had a previously installed EOS utility, even if you uninstalled it, it doesn't remove it cleanly? Installing the new version over it doesn't really help..maybe try to find out how to really completely remove all instances of the software and driver and do a fresh install?

muldereric

  • Guest
Re: Eos Utility camera not recognized
« Reply #9 on: June 16, 2012, 03:30:21 AM »
Have you installed the EOS Utility BEFORE you connected your camera to you computer?
If you did not, then it's your own fault. With USB devices, ALWAYS install software first, then connect devices.
When you connected your camera to your computer before you actually installed the software, Windows could not find a driver and probably marked your camera as Unknown Device in the Windows Device manager.
Google a bit to find out how to remove the Unknown Devices from the Device Manager, if applicable...
Also, you didn't actually try to connect your camera to a USB 1.1 port did you? Only USB2.0 and upwards is supported. See the system requirements of the utility for that.
« Last Edit: June 16, 2012, 03:35:08 AM by muldereric »

Fytos

  • Guest
Re: Eos Utility camera not recognized
« Reply #10 on: June 16, 2012, 04:23:12 AM »
I notice that my software disk that came with canon 5d mark 3 is the old version EOS DIGITAL Solution Disk v23.0 >:(
Eos Utility is the 2.10.2.0 and it doesn't even works on my mac with 10.7 because was only for 10.6
I think thats the reason that doesn't work.
 

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 9182
    • View Profile
Re: Eos Utility camera not recognized
« Reply #11 on: June 16, 2012, 04:37:32 PM »
I notice that my software disk that came with canon 5d mark 3 is the old version EOS DIGITAL Solution Disk v23.0 >:(
Eos Utility is the 2.10.2.0 and it doesn't even works on my mac with 10.7 because was only for 10.6
I think thats the reason that doesn't work.

Disk 25.0 comes with the 5D MK III, but you can always update to the latest version by downloading it.  I wonder how you got a old disk with the Camera?
 
Disk 23.0 is bundled with the 60D.  I wonder if the dealer swapped them out.  The 5D MK III is made in its own production line, there whould never be any wrong CD's packed with it.
 
Was the CD sealed in shrinkwrap??

JerryB

  • Guest
Re: Eos Utility camera not recognized
« Reply #12 on: June 17, 2012, 08:14:17 PM »
I had the same problem.  You have to update all of your drivers.  I called CanonUSA and they walked me through it.  The correct disk is 25.  Unfortunately, Canon hasn't put that drive on the net yet.

canon rumors FORUM

Re: Eos Utility camera not recognized
« Reply #12 on: June 17, 2012, 08:14:17 PM »

AdventureRider

  • Guest
Re: Eos Utility camera not recognized
« Reply #13 on: June 23, 2012, 10:28:05 AM »
With my system, Windows 7 and EOS 5D-I and 5D-II, EOS utility (2.10) doesn't recognizes the camera's when my Nokia X3 phone is connected to the computer using the USB cable.

Thor

  • SX60 HS
  • **
  • Posts: 1
    • View Profile
Re: EOS Utility camera not recognized (Solved)
« Reply #14 on: April 25, 2013, 11:13:43 AM »
Experienced similar problems and after numerous calls to Canon support (very nice people by the way) I was still unable to resolve the problem. I kept searching for the answer and have finally fixed it on my system:

Canon Rebel T3
Latest EOS Utility software
Windows XP - home
Pentium 4 Prescott Technology
2GB Ram

Error "Can not recognize camera"

Downloaded Microsoft .NET Framework removal tool - removed any trace (all versions) of .NET Framework from the computer then downloaded and installed fresh .NET Framework 3.5. Went to Windows update for required .NET Framework 3.5 security patches downloaded and installed all recommended updates. Restarted computer and ALL IS WELL!

Summary:

Error - "EOS Utility can not recognize camera"

Problem - .NET Framework corrupted

Solution - (A) Download and use Microsoft .NET Framework removal tool to remove .NET Framework from computer (B) Reinstall .Net Framework and Reboot computer.

Hope this helps you like it did me!

Thor 

canon rumors FORUM

Re: EOS Utility camera not recognized (Solved)
« Reply #14 on: April 25, 2013, 11:13:43 AM »