April 20, 2014, 06:23:44 AM

Author Topic: 50mm 1.4 rear element broke?  (Read 938 times)

jaayres20

  • Rebel SL1
  • ***
  • Posts: 92
    • View Profile
    • Joshua Ayres Photography
50mm 1.4 rear element broke?
« on: June 15, 2012, 11:27:25 AM »
I hardly use my 50mm 1.4 because I have the 1.2.  I just keep it as a backup.  My 1 year old daughter managed to pick it up while it was out of my bag and it dropped on the hard wood floor.  When I picked it up I discovered the rear element had popped out.  I pushed it back in and it snapped into place.  After a short test the lens seems to be focusing and working just fine.  Does anyone know if that the rear element is just pressed into place or when it fell did it break something I don't know about?  I hate to rely on it one day and find out it is broken but I also hate to send it in if it is fine.  Anyone know?

canon rumors FORUM

50mm 1.4 rear element broke?
« on: June 15, 2012, 11:27:25 AM »

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7711
    • View Profile
Re: 50mm 1.4 rear element broke?
« Reply #1 on: June 16, 2012, 03:57:47 PM »
There is likely a broken plastic piece or at least cracked, I'd have it repaired.  Canon has a flat rate for repairinng them, or have it inspected at a local camera repair shop, if its ok, it will likely just cost $80 for a cleaning and inspection.

bdunbar79

  • 1D X
  • *******
  • Posts: 2430
    • View Profile
Re: 50mm 1.4 rear element broke?
« Reply #2 on: June 16, 2012, 05:09:44 PM »
I hardly use my 50mm 1.4 because I have the 1.2.  I just keep it as a backup.  My 1 year old daughter managed to pick it up while it was out of my bag and it dropped on the hard wood floor.  When I picked it up I discovered the rear element had popped out.  I pushed it back in and it snapped into place.  After a short test the lens seems to be focusing and working just fine.  Does anyone know if that the rear element is just pressed into place or when it fell did it break something I don't know about?  I hate to rely on it one day and find out it is broken but I also hate to send it in if it is fine.  Anyone know?

I'm paranoid, so when I bought the 50 f/1.4 and read all the horror stories regarding the AF breaking and quit working after awhile, I leave the lens hood on it all the time and overexessively keep a B+W Slim UV haze filter on it at all times :)

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7711
    • View Profile
Re: 50mm 1.4 rear element broke?
« Reply #3 on: June 16, 2012, 09:29:00 PM »
I hardly use my 50mm 1.4 because I have the 1.2.  I just keep it as a backup.  My 1 year old daughter managed to pick it up while it was out of my bag and it dropped on the hard wood floor.  When I picked it up I discovered the rear element had popped out.  I pushed it back in and it snapped into place.  After a short test the lens seems to be focusing and working just fine.  Does anyone know if that the rear element is just pressed into place or when it fell did it break something I don't know about?  I hate to rely on it one day and find out it is broken but I also hate to send it in if it is fine.  Anyone know?

I'm paranoid, so when I bought the 50 f/1.4 and read all the horror stories regarding the AF breaking and quit working after awhile, I leave the lens hood on it all the time and overexessively keep a B+W Slim UV haze filter on it at all times :)

I bought a used one that turned out to have a cracked plastic internal part, Canon fixed it for their flat rate.  I had to buy a replacement new one, because I had a job needing it.  I sold the repaired one after Canon repaired it (it was perfect), and have never had a issue with the new one.  Its almost certain to do some internal damage if dropped, those plastic parts crack or break, and then when you need it, it stops completely.

canon rumors FORUM

Re: 50mm 1.4 rear element broke?
« Reply #3 on: June 16, 2012, 09:29:00 PM »