October 02, 2014, 01:25:45 AM

Author Topic: New 5D Owner. Why can't I autofocus? [video included]  (Read 4763 times)

voyager

  • Guest
Re: New 5D Owner. Why can't I autofocus? [video included]
« Reply #15 on: July 23, 2012, 08:40:03 PM »
Hi Guys. I just couriered the body back to the shop. They called me an hour later after trying their own lens on it and confirmed that the camera is faulty. Now the wait begins for warranty repair. Thanks for all your help.

canon rumors FORUM

Re: New 5D Owner. Why can't I autofocus? [video included]
« Reply #15 on: July 23, 2012, 08:40:03 PM »

wickidwombat

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4515
    • View Profile
Re: New 5D Owner. Why can't I autofocus? [video included]
« Reply #16 on: July 23, 2012, 08:42:41 PM »
why didnt you just ask for a full replacement?
APS-H Fanboy

Rat

  • Canon 70D
  • ****
  • Posts: 269
    • View Profile
Re: New 5D Owner. Why can't I autofocus? [video included]
« Reply #17 on: July 24, 2012, 08:46:29 AM »
why didnt you just ask for a full replacement?
In the Dutch example I posted the camera eventually was returned and got replaced immediately under warranty. I'd try and give 'em a call, as wickidwombat suggests, because if you pay 3K+ for a camera you shouldn't have to wait for weeks for it... hope it works out for you :)
5DIII, 17-40, 24-105, 70-200/4IS, 50/1.8II, 85/1.8 and a truckload of gimmicks and bits.

canon rumors FORUM

Re: New 5D Owner. Why can't I autofocus? [video included]
« Reply #17 on: July 24, 2012, 08:46:29 AM »