October 01, 2014, 09:21:34 AM

Author Topic: 5dm2 multicontroller help needed (maybe)  (Read 785 times)

CharlieB

  • Canon 70D
  • ****
  • Posts: 302
    • View Profile
5dm2 multicontroller help needed (maybe)
« on: July 30, 2012, 08:52:03 PM »
The multi-controller button on my 5d2 seems to act weird - maybe - as I have nothing to compare it to.

Pressing it straight in - to bring up the display screen - sometimes it comes up, sometimes it needs a quick jab, sometimes it needs a long press, and never works unless the camera  is first "awake" via the shutter release.

I really don't know the nature of the beast.   Can somebody clue me in on this?

It seems to be "not hardware" as once I have the screen up, I can maneuver, choose, alter, save all just fine with the multi-controller.  Its only that initial activation of the screen that seems to be weird.  Yes... I'm very careful to press directly in, not at an angle...(as in maneuvering).

Thanks in advance!~

canon rumors FORUM

5dm2 multicontroller help needed (maybe)
« on: July 30, 2012, 08:52:03 PM »

CharlieB

  • Canon 70D
  • ****
  • Posts: 302
    • View Profile
Re: 5dm2 multicontroller help needed (maybe)
« Reply #1 on: August 01, 2012, 06:01:49 PM »
Update -

This appears to be lens specific.  I dont know why it should be so.  Pressing the multicontroller should be the same as remapping the set button to do the same thing, but... the set button works nearly instantly and positively, whole the multicontroller has some lag and is not as positive.   Again, once the screen is displayed with the mf controller, the response on the screen is snappy, positive, sure...

Does anyone else experience this?  That is, my 24-105 takes a bit of doing to get the screen on, while the 28/1.8 or 50/1.4 are instant.  Other lenses vary....

My initial though was contact cleanliness.  They're clean.  Then I started thinking about lens/camera firmware interaction, and perhaps the way the camera makes the screen access is more convoluted (in firmware) when the mf button is pushed. 

Canon themselves... clueless as to even what the problem is that I'm trying to describe, giving the stock response of "send it in for evaluation".

Any feedback sure would be appreciated

canon rumors FORUM

Re: 5dm2 multicontroller help needed (maybe)
« Reply #1 on: August 01, 2012, 06:01:49 PM »