April 21, 2014, 07:11:07 AM

Author Topic: EOS 7D FW2.0: Problems anyone?  (Read 16433 times)

hoacker

  • PowerShot G16
  • **
  • Posts: 5
    • View Profile
EOS 7D FW2.0: Problems anyone?
« on: August 14, 2012, 06:53:18 AM »
Hi, there. At some german speaking forums user report problems with EOS 7D FW2.0 which started after the firmware update.

Problems reported:
- 1 (!) user reported that third party battery packs (weiss) were no longer recognized. This could not be confirmed by anybody so far. I guess this issue is not related to the firmware update.
- Some users report that the 7D freezes from time to time and can only be revived be removing and inserting the battery pack. There are multiple reports also from experienced user, so there is a chance that this issue is indeed related to FW 2.0.

Can you confirm one of the problems above?
Did you experience other problems introduces with FW 2.0?
Please report.
« Last Edit: August 14, 2012, 06:55:14 AM by hoacker »

canon rumors FORUM

EOS 7D FW2.0: Problems anyone?
« on: August 14, 2012, 06:53:18 AM »

Paul W. H

  • PowerShot G16
  • **
  • Posts: 14
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #1 on: August 14, 2012, 07:21:12 AM »
I have had the freezing problem twice and at first thought that it might be that my CF card could not keep up with the increased speed in burst mode, since then this problem has appeared on a few websites.

The battery level indicator also showed 50.00% when it was almost full ??

Removing and replacing the battery for a few seconds solved the problem.

I have re-installed FW 2.0.0 and removed the battery for a few seconds after completion as per the instructions. I missed this bit in the instructions first time round.

I have not had a chance to use the camera since.
2x EOS 7D, EOS 600D
EF 28-300L, 70-200L, 2x100-400L, 500L, 10-22, 15-85, 17-55, 70-300, 1.4x II, 2.0x II And More

mayteuk

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #2 on: August 14, 2012, 07:31:07 AM »
I have tested a third party battery on my 7D on v2.0 firmware and it fires up no problem . still get unable to communicate with Battery but had that before. I only have battery as backup in case of emergency but it does work

JohnEasterly

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #3 on: August 14, 2012, 07:57:57 AM »
Hi, there. At some german speaking forums user report problems with EOS 7D FW2.0 which started after the firmware update.

Problems reported:
- 1 (!) user reported that third party battery packs (weiss) were no longer recognized. This could not be confirmed by anybody so far. I guess this issue is not related to the firmware update.
- Some users report that the 7D freezes from time to time and can only be revived be removing and inserting the battery pack. There are multiple reports also from experienced user, so there is a chance that this issue is indeed related to FW 2.0.

Can you confirm one of the problems above?
I have had a freeze-up, happened once second day of upgrade, removed battery, re-started and it has not happened in 6 days
Did you experience other problems introduces with FW 2.0?
Please report.

hoacker

  • PowerShot G16
  • **
  • Posts: 5
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #4 on: August 14, 2012, 08:05:37 AM »
Thank you for your replies so far.

Just in case anyone would like to revert to FW 1.2.5: Use EOSUtility 2.9.* or 2.10.*. Downgrade is no longer possible with EOSUtility 2.11.4.

isacsfoto

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #5 on: August 14, 2012, 10:55:52 AM »
I allso had that problem?! It´s not so cool to take out the batteri from time to time...
But all the other new stuff was superb!

Mt Spokane Photography

  • 1D X
  • *******
  • Posts: 7714
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #6 on: August 14, 2012, 11:20:13 AM »
Canon tells you to reset the camera after upgrading firmware.  It can end up with a combination of settings that no longer exist in the new firmware and cause some weird thinngs to happen.  I've had no issues with mine after the update, other than restoring all the settings after resetting it.

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #6 on: August 14, 2012, 11:20:13 AM »

tiger82

  • EOS M2
  • ****
  • Posts: 303
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #7 on: August 15, 2012, 10:02:32 AM »
It's time for my 7D's annual CPS clean and check.  I think I will ask them to upgrade the firmware before they do their system checks.  Then it's their problem (and mine too if there are issues, but they will be responsible for the problems caused by the upgrade).
1D3 with 70-200 IS f/2.8L, 5D2 with 24-70 f/2.8L

Trovador

  • Canon AE-1
  • ***
  • Posts: 65
    • View Profile
    • Photography Portfolio
Re: EOS 7D FW2.0: Problems anyone?
« Reply #8 on: August 15, 2012, 10:28:29 AM »
So far so good.
Canon 6D+7D; 17-40L, 24-70L, 70-200L 2.8 IS II, 100-400L IS, 50 1.4, 100L 2.8 IS, Rokinon 8mm fisheye
www.ruddyflorentino.com

RLPhoto

  • 1D X
  • *******
  • Posts: 3120
  • Gear doesn't matter, Just a Matter of Convenience.
    • View Profile
    • My Portfolio
Re: EOS 7D FW2.0: Problems anyone?
« Reply #9 on: August 15, 2012, 10:55:22 AM »
Nope. Like a Rock or should I say? Magnesium Alloy?
24LII - 50L - 135L
---------------------------------
www.RamonLperez.com

Goshdern

  • PowerShot G16
  • **
  • Posts: 15
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #10 on: August 15, 2012, 11:30:59 AM »
Has worked like advertised for me too...  Lovin auto iso at 400!
Tamrac 5592; Canon 5D Mark II, 7D, 16-35mm 2.8L II, 85mm 1.2L II, 70-200mm 2.8L IS II, 580EX II (x2), PCBuff Einstein-Vagabond Mini & reflectors, Sekonic 758DR, Trigmaster tx and rx's & lots of eneloops

Bruce Photography

  • Rebel T5i
  • ****
  • Posts: 184
  • Landscapes, 5D/5D2/5D3,7D,60D,EOS-M,D800/E,D7100
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #11 on: August 15, 2012, 01:17:19 PM »
I wish to give Canon my highest commendation on a free feature upgrade to a mature product.  I want to believe that they are just being nice.  I know they have their reasons but I'm at a loss to really understand it.  For my 7D I put in the new Lexar 1000x udma7 card for a quick shot of my kitchen in auto iso mode and I was getting 33 to 34 shots before it took a breath.  My reading before shooting said a buffer of 22 (not 25), but when I actually began shooting it was 34 shots.  I reformatted the card and reapeated the experiment six times and every time it was at least 33.  I tried the same experiment on the 5d3 and got 29 to 33.  Both impressive!!!!!! 

Good going Canon.

viggen61

  • Rebel T5i
  • ****
  • Posts: 148
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #12 on: August 15, 2012, 02:24:45 PM »
The only issue I noted was a "blank" line on the "My Menu" screen where I had date & time before. Had to go in and remove it and replace it with Date/Time/Zone.

Other than that, it seems just fine. I'm even pleasantly surprised that the star ratings you can now set in camera via the Quick menu also copy over in the RAW file to Apple Aperture.  :D
Canon 7D

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #12 on: August 15, 2012, 02:24:45 PM »

1255

  • PowerShot G1 X II
  • ***
  • Posts: 54
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #13 on: August 15, 2012, 03:10:00 PM »
been working fine for me

AprilForever

  • 5D Mark III
  • ******
  • Posts: 710
    • View Profile
    • AprilForever.com
Re: EOS 7D FW2.0: Problems anyone?
« Reply #14 on: August 15, 2012, 03:19:08 PM »
Works like a boss!!!

I love my 7D even more now.
What is truth?

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #14 on: August 15, 2012, 03:19:08 PM »