November 26, 2014, 07:14:23 PM

Author Topic: EOS 7D FW2.0: Problems anyone?  (Read 17999 times)

Paul W. H

  • Power Shot G7X
  • **
  • Posts: 16
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #30 on: August 27, 2012, 02:15:57 AM »
I have had the freezing problem twice and at first thought that it might be that my CF card could not keep up with the increased speed in burst mode, since then this problem has appeared on a few websites.

The battery level indicator also showed 50.00% when it was almost full ??

Removing and replacing the battery for a few seconds solved the problem.

I have re-installed FW 2.0.0 and removed the battery for a few seconds after completion as per the instructions. I missed this bit in the instructions first time round.

I have not had a chance to use the camera since.

The story continues, we went out today and had 3 more lockups, followed by 2 "Er 30's" and then it just died. Tried removing the CR1616 battery to do a reset and nothing.

It had a genuine Canon battery in & Canon Lens on so god knows what has happened. To say that I am not a happy bunny is a complete understatement as we are going away at the weekend so I need this like a bloody hole in the head.

To finish the story. I sent the 7D off to a Canon Repair Centre in the UK (CPS Silver Member) and got it back a week later after having the Printed Circuit Board (PCB) replaced at a total cost of £234.00 UKP (370.00 USD), they originally thought that it was the Shutter Mechanism causing the problem.

Did the firmware update cause the fault, who knows !!
2x EOS 5D3 + 2x EOS 7D
EF 24-70II, 24-105, 28-300L, 70-200L, 2x100-400L, 500L, 10-22, 15-85, 17-55, 70-300, 1.4x II, 2.0x II And More

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #30 on: August 27, 2012, 02:15:57 AM »

azamiruddin

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #31 on: August 27, 2012, 03:59:55 AM »
Hi all, good day,

I dont know whether this problem exist with previous firmware, but, everytime I switch ON my 7D, i need to enable AF Micro Adjustment every time --> by lens. i does not stay enable even though i not changing the lens.

mucher

  • Power Shot G7X
  • **
  • Posts: 10
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #32 on: August 27, 2012, 04:52:02 AM »
1) in flash menu, auto detecting lense length doesn't work, like 50mm lense suppose to let my 580ex zoom to 85mm, but it didn't happen, the flash stayed at 50mm
2) my 50L, are completely two lenses when in low light and in ourdoor ambient light, in low light I have to add +10 in microadjust lense shift, in good light there is no problem.
3) 7D might not be able to focus objects over 25 meters, but I don't have longer lense, for in 50L's f/1.2, all that is over 25meters might be in hyperfocal distance so I really couldnt tell, but my two 50/1.8 lenses couldn't focus over that distance, and that occurs 100%.

mustafa

  • PowerShot G1 X II
  • ***
  • Posts: 48
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #33 on: August 27, 2012, 06:58:36 AM »
I didn't get the articulated LCD I was hoping for. ::)

marek.sykora

  • Power Shot G7X
  • **
  • Posts: 15
    • View Profile
Re: 7D firmware upgrade problems
« Reply #34 on: August 27, 2012, 03:03:30 PM »
No issue found in my 7D.

Image preview is faster, image rating is fine feature, but too deeply nested, so I don't use it. Max auto ISO works as expected, but I don't use it because to slow times are offerred when shooting with 85/1.8, I need to keep 1/200s and faster, no way to set up it ;( I don't use any other new features.

Timothy_Bruce

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: 7D firmware upgrade problems
« Reply #35 on: August 27, 2012, 03:10:23 PM »
all fine :)

papa-razzi

  • Rebel T5i
  • ****
  • Posts: 146
    • View Profile
Re: 7D firmware upgrade problems
« Reply #36 on: August 27, 2012, 03:41:32 PM »
No problems at all.   8)
6D | 7D  | EF-S 17-55mm f/2.8 IS USM | EF 24-105mm f/4L IS USM | EF 70-200 f/2.8L IS USM | EF 70-300 f/4-5.6L IS USM |
EF 35mm f/2 | EF 50mm f/1.4 | EF 85mm f/1.8

canon rumors FORUM

Re: 7D firmware upgrade problems
« Reply #36 on: August 27, 2012, 03:41:32 PM »

jsexton

  • PowerShot G1 X II
  • ***
  • Posts: 50
    • View Profile
    • Raw Light Photos
Re: 7D firmware upgrade problems
« Reply #37 on: August 27, 2012, 04:41:48 PM »
Only issue I've seen was my intervalometer (Promaster 3070 I believe) now only works as a standard remote shutter release and only if the device is in the off position.  I can set the device for delay, exposure time etc, but the camera only takes a single image based on the last settings I used.  Strange, but it's a 3rd party so I'm not exactly surprised and I guess it's a change you take. 
4 Canon bodies and a bunch of lenses.

Click

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 3448
    • View Profile
Re: 7D firmware upgrade problems
« Reply #38 on: August 27, 2012, 04:57:54 PM »
No problems here so far.

Mt Spokane Photography

  • EF 50mm F 0.7 IS
  • *********
  • Posts: 9177
    • View Profile
Re: 7D firmware upgrade problems
« Reply #39 on: August 27, 2012, 08:34:19 PM »
I haven't seen a problem.  Try a complete camera reset. 

DianeK

  • EOS M2
  • ****
  • Posts: 161
    • View Profile
Re: 7D firmware upgrade problems
« Reply #40 on: August 28, 2012, 06:42:30 PM »
I haven't seen a problem.  Try a complete camera reset.

Is that the "clear all camera settings" option right above the firmware version in the menu?

viggen61

  • EOS M2
  • ****
  • Posts: 167
    • View Profile
Re: 7D firmware upgrade problems
« Reply #41 on: August 28, 2012, 10:11:40 PM »
No issue with mine, either. Note the instructions call for the main battery (or batteries if you have a grip, as I do)  to be removed from the camera for a brief time to allow the new firmware to take full effect.
Canon 7D

Timothy_Bruce

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #42 on: August 29, 2012, 07:41:48 AM »
no problems but that  the SET-Button and the Upperdial  are absolutely functionless  in the new Playback-Q-Menu are  really annoying.
The dial could easily be used to change between the options or to cycle truth pictures.
And every time I rate a picture or protect one I hit the Set-button and nothing happens.
Also this Menu is really not practical to protect or rate more than ONE picture because I have to close it go to next picture and have to reopen it ... CANON please that is far away from elegant !!!

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #42 on: August 29, 2012, 07:41:48 AM »

hoacker

  • Power Shot G7X
  • **
  • Posts: 6
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #43 on: August 29, 2012, 10:26:22 AM »
Thanks to anybody who responded so far. Canon New Zealand has kind of confirmed the freeze issue with firmware 2.0. Read on here: http://photography-on-the.net/forum/showthread.php?t=1222669

Pieces Of E

  • Rebel T5i
  • ****
  • Posts: 139
  • Canon owners and operators
    • View Profile
    • Pieces Of E, LLC
Re: EOS 7D FW2.0: Problems anyone?
« Reply #44 on: August 29, 2012, 12:20:15 PM »
My 7D quit displaying the shot image for the 4 second setting I had it on. After turning off then on again, it started displaying the shot image again. Otherwise, I believe it is performing better than it did prior to the firmware update.
EOS 7D, BG-E7, EF 300L IS f4, EF 100L IS f2.8 macro, EF 24-105L IS f4 , EF 1.4 extender MKIII, EF-S 10-22 f3.5-5.6, 70-200L IS f2.8 II, EOS-M, 22 f2 STM, EF-S 18-135 IS STM, EF 85 f1.8

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #44 on: August 29, 2012, 12:20:15 PM »