April 24, 2014, 01:15:29 PM

Author Topic: EOS 7D FW2.0: Problems anyone?  (Read 16440 times)

Paul W. H

  • PowerShot G16
  • **
  • Posts: 14
    • View Profile
Re: 7D firmware upgrade problems
« Reply #45 on: August 30, 2012, 05:46:26 PM »
2x EOS 7D, EOS 600D
EF 28-300L, 70-200L, 2x100-400L, 500L, 10-22, 15-85, 17-55, 70-300, 1.4x II, 2.0x II And More

canon rumors FORUM

Re: 7D firmware upgrade problems
« Reply #45 on: August 30, 2012, 05:46:26 PM »

offcamber

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #46 on: September 21, 2012, 02:27:22 AM »
Found this thread while googling "dead 7d after firmware 2.0 update". So I updated my 7d a couple of days ago to FW 2.0. It seemed to work fine and then tonight I turn it on and an error flashed on the LCD. I turned it off and then when I turned it back on, nothing happens. It's dead as a rock. I'm a little pissed right now. Tried removing the backup battery and letting it sit, but it's still dead after putting them back in. Replaced the CR1616 and nothing.  I'm guessing there is no way to remove the new firmware since I can't even get the camera to turn on. I guess I'll call Canon tomorrow and see what they say.

Paul W. H

  • PowerShot G16
  • **
  • Posts: 14
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #47 on: September 21, 2012, 02:47:03 AM »
Found this thread while googling "dead 7d after firmware 2.0 update". So I updated my 7d a couple of days ago to FW 2.0. It seemed to work fine and then tonight I turn it on and an error flashed on the LCD. I turned it off and then when I turned it back on, nothing happens. It's dead as a rock. I'm a little pissed right now. Tried removing the backup battery and letting it sit, but it's still dead after putting them back in. Replaced the CR1616 and nothing.  I'm guessing there is no way to remove the new firmware since I can't even get the camera to turn on. I guess I'll call Canon tomorrow and see what they say.

The trouble is that you will never know if the F/W caused the problem or if it was pure coincidence.

All I know is that it cost me a lot of money (£234.00 UKP / 370.00 USD) to repair my 7D
« Last Edit: September 21, 2012, 02:49:36 AM by Paul W. H »
2x EOS 7D, EOS 600D
EF 28-300L, 70-200L, 2x100-400L, 500L, 10-22, 15-85, 17-55, 70-300, 1.4x II, 2.0x II And More

serendipidy

  • 1D X
  • *******
  • Posts: 1261
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #48 on: September 21, 2012, 03:09:24 AM »
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.
EOS 5D miii, EOS 7D, 70-200mm f/2.8L IS ii, 100-400mmL IS

ishdakuteb

  • EOS M2
  • ****
  • Posts: 324
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #49 on: September 21, 2012, 03:48:54 AM »
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.


i am not sure if this is the case but update a new version 2.0.3 will probably solve your problem "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect."

here is little more details about it http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/

Paul W. H

  • PowerShot G16
  • **
  • Posts: 14
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #50 on: September 21, 2012, 03:59:35 AM »
Have had my 7D for over a year without any problems. Shortly after it was released, I installed FW2.0. I don't get out very often to shoot and it worked OK for awhile. Last time out the 7D just stopped working and would NOT turn on. Remembered this thread and took out and then put back the battery and the camera came back on. I'm absolutely sure this is due to the FW 2.0 update. Haven't installed the newest update yet.


i am not sure if this is the case but update a new version 2.0.3 will probably solve your problem "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect."

here is little more details about it http://www.canonrumors.com/2012/09/canon-eos-7d-firmware-2-0-3/


If it is like mine and dead you cannot turn it on to do the 2.0.3 update.

2x EOS 7D, EOS 600D
EF 28-300L, 70-200L, 2x100-400L, 500L, 10-22, 15-85, 17-55, 70-300, 1.4x II, 2.0x II And More

Heavyweight67

  • PowerShot G1 X II
  • ***
  • Posts: 56
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #51 on: September 21, 2012, 04:28:40 AM »
I updated to FW 2.0 and had no problems, I noticed the thread re 2.0.3...initially I thought Nahhhhh, won't update as I had no issues with 2.0, in the end I succumbed and decided to update to 2.0.3...
The update completed with no apparent issues...

The next day I went out shooting, when reviewing some pics the quick selector/toggle button started to play up, I couldn't scroll up from the central position, I couldn't scroll diagonally, going into the menu, I couldn't scroll left or right or up.

I removed and replaced the batteries, which did nothing, turned the camera on and off again nothing..

After about 20 minutes trying various remedies I gave up and was reconsidering reinstalling 2.0 or 2.0.3 when I returned home.

I left the camera for another 20 minutes or so, checked it again and noticed that the "glitch" had repaired itself and the toggle button now worked....

I've had my 7D for a little over a year now, it is used every day, I've had no issues until the 2.0.3 update...

I haven't been able to repeat this issue (nor do I want to)...guess will have to wait and see if it occurs again..

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #51 on: September 21, 2012, 04:28:40 AM »

Danielle

  • Rebel T5i
  • ****
  • Posts: 131
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #52 on: September 21, 2012, 04:45:20 AM »
I went to use the pop up flash a few days ago, for fill during my partner's exposure of all things. It came up with an error, which I too preoccupied to catch the exact text and restarted as if I turned it off and back on (in manual mode if one wants to know).

However it hasn't done anything else odd, nor has it done it again (just played with the pop up thing just then to make sure). So I have no idea. It has 2.0.3 installed.

I guess it needed anti anxiety pills that day, thats all. *shrugs*

2n10

  • EOS M2
  • ****
  • Posts: 278
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #53 on: September 21, 2012, 05:29:12 AM »
I have had no issues with either update.  I just followed the instructions exactly to include removing the battery for at least 2 seconds.  I am knocking on wood nothing shows up.  I hope all who have experienced glitches with a recovery see no more issues and those who have lost use let us know what the issue was so that everyone will know what to do to correct the issue and hopefully avoid it.
Canon EOS 7D, EF-S 10-22, EF-S 17-55, EF 100 Macro, EF 50 1.4, EF 70-300, EF 100-400L

ud4steve

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #54 on: October 09, 2012, 07:47:28 AM »
My camera has been working fine since the update, and I'm loving the new free features.

mucher

  • PowerShot G16
  • **
  • Posts: 9
    • View Profile
Re: EOS 7D FW2.0: Problems anyone?
« Reply #55 on: December 13, 2012, 05:37:12 AM »
With firmware 2.0.3, 7D cannot register focus points anymore

Lorraine

  • Guest
Re: EOS 7D FW2.0: Problems anyone?
« Reply #56 on: January 04, 2013, 02:10:24 PM »
Right from the beginning my 7d, 2 months old with firmware 2.0.3 had the freezing problem. No action possible after it went in sleep mode. Have to take the battery out. Is in repair now. So it is not true that the newest firmware tackles this problem, although canon claims that the version 2.0.3. "fixes a phenomenon in which the camera stops working when the auto power off setting takes effect.". No way!!! I think it is about time that canon solves this problem now for once and for all. It's really annoying that I had tot take back my 7d after 2 months. 
« Last Edit: January 07, 2013, 02:58:14 PM by Lorraine »

canon rumors FORUM

Re: EOS 7D FW2.0: Problems anyone?
« Reply #56 on: January 04, 2013, 02:10:24 PM »