April 18, 2014, 06:18:17 PM

Author Topic: Yongnuo RF-600 won't work in live View  (Read 1998 times)

Bennymiata

  • Rebel T5i
  • ****
  • Posts: 175
    • View Profile
Yongnuo RF-600 won't work in live View
« on: August 26, 2012, 06:18:08 AM »
I just got a set of the Yongnuo RF-600 TX and 4 receivers which work well with my 60D and 5D3, EXCEPT when I have either camera in live View, and then they just don't work.

When Live View is switched off, using the OVF, they work perfectly, but when I switch to Live View, it won't trigger the falshes.

Anyone have any ideas as to why, and how to get around this problem?

canon rumors FORUM

Yongnuo RF-600 won't work in live View
« on: August 26, 2012, 06:18:08 AM »

Timothy_Bruce

  • Rebel T5i
  • ****
  • Posts: 116
    • View Profile
Re: Yongnuo RF-600 won't work in live View
« Reply #1 on: August 26, 2012, 09:19:26 AM »
try to deactivate  silent mode in the live view menu. That is what is needed in the 7D.
 I think it hast something to do with electronic first curtain.

keithfullermusic

  • 7D
  • *****
  • Posts: 364
    • View Profile
    • k2focus.com
Re: Yongnuo RF-600 won't work in live View
« Reply #2 on: August 29, 2012, 02:14:24 AM »
It's a camera setting, not a problem with the flash.
5Diii - 50D - 100mm f/2.8, 50mm f/1.4, 20mm f/2.8, 100-400mm f/4.5-5.6L IS, 430 EX II, YN560
---
Pics - http://k2focus.com | Tunes - http://keithfullermusic.com | For Fun - http://thewalkingdeadrumors.com

dmbrown

  • PowerShot G16
  • **
  • Posts: 1
    • View Profile
Re: Yongnuo RF-600 won't work in live View
« Reply #3 on: September 14, 2013, 12:10:47 AM »
I have a 60D and they won't work in any of the live view settings either. I am not able to control the flash through the camera external flash settings. It says the flash is incompatible. I can shoot fine with a 430ex ii and a Yongnuo YN-560 II, both controlled by the RF-600, but all settings with the flashes are manual. Shouldn't the TTL work with the RF-600?

emag

  • EOS M2
  • ****
  • Posts: 309
    • View Profile
Re: Yongnuo RF-600 won't work in live View
« Reply #4 on: September 14, 2013, 12:35:31 AM »
try to deactivate  silent mode in the live view menu. That is what is needed in the 7D.
 I think it hast something to do with electronic first curtain.
Turn off exposure simulation also?

Rienzphotoz

  • 1D X
  • *******
  • Posts: 3255
  • Peace unto all ye Canon, Nikon & Sony shooters
    • View Profile
Re: Yongnuo RF-600 won't work in live View
« Reply #5 on: September 14, 2013, 03:28:01 AM »
I have a 60D and they won't work in any of the live view settings either. I am not able to control the flash through the camera external flash settings. It says the flash is incompatible. I can shoot fine with a 430ex ii and a Yongnuo YN-560 II, both controlled by the RF-600, but all settings with the flashes are manual. Shouldn't the TTL work with the RF-600?
With the Yonguno RF-600, you cannot control the flash through the camera, it is meant only to communicate with the receiver to trigger the flash, that's all it can do i.e. you need to manually set the flash output on the flash unit itself.
If you want to control the flash through the camera, you need the newer Yongnuo flash trigger YN-622C (for Canon) or YN-622N (for Nikon).
« Last Edit: September 14, 2013, 03:45:31 AM by Rienzphotoz »
Canon 5DMK3 70D G1X | Nikon D610 | Sony a7 | 16-35/2.8LII | 70-200/2.8LISII | 100/2.8LIS | 100-400LIS | 40/2.8 | 50/1.4 | 85/1.8 | 600EX-RTx2 | ST-E3-RT | 24/3.5 T-S | 24-70OSS | 28-300VR | HVL-F43M | Metabones EF adapter | GoPro Black 3+ | DJI Quadcopter | Manfrotto+Gorilap

canon rumors FORUM

Re: Yongnuo RF-600 won't work in live View
« Reply #5 on: September 14, 2013, 03:28:01 AM »