November 22, 2014, 07:00:12 AM

Author Topic: How to enable 50 iso on 5DIII?  (Read 1969 times)

Briand

  • Guest
How to enable 50 iso on 5DIII?
« on: September 05, 2012, 07:39:40 PM »
Is there a setting I have on by default that is disabling this feature?

canon rumors FORUM

How to enable 50 iso on 5DIII?
« on: September 05, 2012, 07:39:40 PM »

neuroanatomist

  • CR GEEK
  • **********
  • Posts: 14926
    • View Profile
Re: How to enable 50 iso on 5DIII?
« Reply #1 on: September 05, 2012, 07:42:46 PM »
Yes, you need to enable the expanded ISOs, they're off by default.
EOS 1D X, EOS M, and lots of lenses
______________________________
Flickr | TDP Profile/Gear List

keithfullermusic

  • Canon 6D
  • *****
  • Posts: 387
    • View Profile
    • k2focus.com | photography
Re: How to enable 50 iso on 5DIII?
« Reply #2 on: September 05, 2012, 08:28:00 PM »
Expanded ISO in the menu. 

It will show up as "L" when you select it.
5Diii - 50D - 100mm f/2.8, 85mm f/1.2 vii - 50mm f/1.4, 20mm f/2.8, 70-200 f/2.8 vii - 100-400mm f/4.5-5.6L IS, 430 EX II, YN560, YN568, Bowen's 500R's
---
Pics - http://k2focus.com | Tunes - http://keithfullermusic.com

Dylan777

  • Canon EF 400mm f/2.8L IS II
  • *******
  • Posts: 4271
    • View Profile
Re: How to enable 50 iso on 5DIII?
« Reply #3 on: September 05, 2012, 08:44:13 PM »

Step by step:

1. Under "Menu" - select "ISO Speed Setting"
2. Select "ISO Speed Range"
3. Set "Minimum" ISO to 50 - click "OK"

Body: 1DX -- 5D III
Zoom: 16-35L f4 IS -- 24-70L II -- 70-200L f2.8 IS II
Prime: 40mm -- 85L II -- 135L -- 200L f2 IS -- 400L f2.8 IS II

Briand

  • Guest
Re: How to enable 50 iso on 5DIII?
« Reply #4 on: September 06, 2012, 12:47:09 AM »
Great thanks for all your help, much appreciated.

canon rumors FORUM

Re: How to enable 50 iso on 5DIII?
« Reply #4 on: September 06, 2012, 12:47:09 AM »