July 29, 2014, 10:47:50 AM

Author Topic: Canon 5D MKII Mode Problems  (Read 1367 times)

LeeBrownPhoto

  • Guest
Canon 5D MKII Mode Problems
« on: September 15, 2012, 05:12:47 AM »
Shot a wedding yesterday and found that halfway during my MKII decided to switch itself from Manual to Program whilst the mode dial was still set to M.

I then quickly cycled through the other modes using the dial and found that Bulb came up as Program, Manual was Program, AV on the dial was now TV and TV on the dial was still TV. CV was still CV and Full Auto still Full Auto.

I was effectively left with Full Auto, Creative Auto, Program and Shutter Priority :(

I shot what I could and moved to my back up for the rest of the evening. On my break I reset all settings, removed batteries and rested it without success. Day after I upgraded the firmware to 2.1.2 but still without success.

Sending it off to Canon this week for service, has anyone else had this problem and solved it?

canon rumors FORUM

Canon 5D MKII Mode Problems
« on: September 15, 2012, 05:12:47 AM »

Mt Spokane Photography

  • Canon EF 600mm f/4L IS II
  • ********
  • Posts: 8272
    • View Profile
Re: Canon 5D MKII Mode Problems
« Reply #1 on: September 15, 2012, 10:54:10 AM »
Cameras break and have issues.  Thats why a backup is always recommended.  Imagine doing a wedding and your camera quits entirely.  If you were being paid, and had no backup camera, you could be sued for negligence.

LeeBrownPhoto

  • Guest
Re: Canon 5D MKII Mode Problems
« Reply #2 on: September 15, 2012, 11:11:23 AM »
Ok well that wasn't very helpful............ :o

This is a technical question only, if you read my post carefully you can see that I used my back up when my primary broke down.

I just want to know if anyone else has experienced this problem.

swampler

  • Rebel T5i
  • ****
  • Posts: 134
    • View Profile
Re: Canon 5D MKII Mode Problems
« Reply #3 on: September 15, 2012, 12:18:53 PM »
Sounds like a short in the dial. And no, I haven't experienced that problem.

And-Rew

  • Guest
Re: Canon 5D MKII Mode Problems
« Reply #4 on: September 15, 2012, 02:31:00 PM »
Owned 2 5D2's and know of many other owners and never heard of it happening.

Did have the Grid Focus Screen break mid shoot though - and despite trying pin hole photography, i was unable to achieve anything acceptable. Though that was a leisure shoot, so only loss of pride in front of all the Nikonista's.

To my knowledge, the 5D2's were built extremely well and in this, it appears you were just plain unlucky.

CharlieB

  • Canon 70D
  • ****
  • Posts: 302
    • View Profile
Re: Canon 5D MKII Mode Problems
« Reply #5 on: September 15, 2012, 02:56:27 PM »
Sure sounds like a problem in the dial itself, hardware not firmware.

Maybe consider the $100 upgrade to the lockable dial...

Heck, if you just send it in for the lockable dial, the "problem" may just get fixed as part of that......

LeeBrownPhoto

  • Guest
Re: Canon 5D MKII Mode Problems
« Reply #6 on: September 16, 2012, 04:28:28 AM »
Great thanks for the advice, might go for the dial lock :)

canon rumors FORUM

Re: Canon 5D MKII Mode Problems
« Reply #6 on: September 16, 2012, 04:28:28 AM »