October 25, 2014, 09:58:35 AM

Author Topic: Canon 5D Mark II and Error 80!  (Read 4088 times)

bruce544

  • Guest
Canon 5D Mark II and Error 80!
« on: September 21, 2012, 08:59:15 AM »
Dear Friends, i have a problem with my canon 5d mark II.
 I bought it in August 2011. When i open camera, i cant see tru my lcd. So i take a picture from the vizor. And here is a picture taken like that.


Later freezes and nothing happens. I close and open, nothing again. I put out the battery and put it back. Then camera opens but same repeats. I read  error 80 on the top screen of the camera.

I searched on web but i cant find a solution. I called Canon but they dont care because i bought camera in USA and now im in Turkiye.

Is there anyone can help out there please? Im stucked in my project...

Best Regards...
Actionturkey@gmail.com

canon rumors FORUM

Canon 5D Mark II and Error 80!
« on: September 21, 2012, 08:59:15 AM »

Caps18

  • Canon 70D
  • ****
  • Posts: 286
    • View Profile
Re: Canon 5D Mark II and Error 80!
« Reply #1 on: September 21, 2012, 09:57:24 AM »
http://tallyns.blogspot.com/2009/10/canon-error-codes-revealed.html

Looks like it might have something to do with the compact flash card or the pins.

Or it is shutter related based on this site's error code list.

Quote
ERR 80: SHUTTER
DESCRIPTION: This error occurs in the following conditions.
    When the CAMERA self-check system detects that the shutter has not been fully charged (ready to shoot).
    When the CAMERA self-check system detects that the shutter operation sequence has not been completed correctly.
    When the built-in flash cannot be recharged after the E-TTL preflash but before the main exposure.
REMEDIAL MEASURE: Try clearing the error by turning the main power switch OFF and then back ON.
« Last Edit: September 21, 2012, 09:59:33 AM by Caps18 »
5D mark 2, 16-35mm f/2.8, 17mm TS-E f/4, 85mm f/1.8, 300mm f/4 + 1.4x, 580 EX Flash

bruce544

  • Guest
Re: Canon 5D Mark II and Error 80!
« Reply #2 on: September 21, 2012, 10:05:18 AM »
Thank you for your post!

I tried to close/open.
I tried battery off/on.

I tried to off card, battery and little bios battery and wait for an hour, then put them back. But the same things happens, camera is not shooting and later giving me error 80!

Please help!

canon rumors FORUM

Re: Canon 5D Mark II and Error 80!
« Reply #2 on: September 21, 2012, 10:05:18 AM »