November 22, 2014, 09:25:49 AM

Author Topic: EOS Utility quitting with Mac OS X version 10.7.5  (Read 15297 times)

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
EOS Utility quitting with Mac OS X version 10.7.5
« on: September 24, 2012, 09:05:50 AM »
My version of EOS Utility is quitting with Mac OS 10.7.5. It will launch, but when one of my cameras is connected via USB it quits. I have Version 2.11.4 on a Mac Pro and on my MacBook Pro. Cameras where 1D X, 5D Mark III and 7D. Has anyone else seen this?

canon rumors FORUM

EOS Utility quitting with Mac OS X version 10.7.5
« on: September 24, 2012, 09:05:50 AM »

HighHeelTech

  • Guest
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #1 on: September 24, 2012, 09:12:31 PM »
I'm having the same problem.  It worked fine last week, today I can open EOS Utility 2.11.4, but once I connect my 7D to the computer (macbook pro - OSx 10.7.5), I get a message that EOS closed unexpectedly.  I even deleted the software and reinstalled it, obviously didn't help. Does anyone know what's going on??   

Peter

  • Guest
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #2 on: September 25, 2012, 11:59:02 AM »
I'm having the same problem (Macbook Pro OS X 10.7.5, EOS Utility 2.11.4. and EOS 5D MarkIII). Got the same message and did the same actions. I cannot download correction data EF 50 mm f/1.4 now. Please help.

wallybarthman

  • Power Shot G7X
  • **
  • Posts: 25
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #3 on: September 25, 2012, 12:34:08 PM »
Ditto here - Mac Mini, 7D, 5D Mark III

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #4 on: September 25, 2012, 12:35:41 PM »
I've sent a report to Canon. I advise please do the same. Maybe it will then get noticed.

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #5 on: September 25, 2012, 10:44:46 PM »
The reply from Canon:

"Thank you for contacting Canon product support about your EOS-1D X.  I am sorry to hear you are having difficulty with EOS Utility.

We did start receiving reports of customers having issues with the new update to Mac OS 10.7 and using EOS Utility.  Unfortunately, the only suggestion I can make to work around the issue at this point is to revert back to 10.7.4.  Customers that have done this, have regained full function of EOS Utility and do not experience the crashing you are describing.

I wish I had a better response for you, but we hope to have an update or a better workaround very soon.

I hope this information is helpful to you. Please let us know if we can be of any further assistance with your EOS-1D X. Thank you for choosing Canon."

pwp

  • 1D X
  • *******
  • Posts: 1613
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #6 on: September 26, 2012, 01:10:06 AM »
I'm in the same boat and really starting to tear my hair out. Hardly a dream team, OS X 10.7.5, EOS Utility 2.11.4. and EOS 5D3.

The solution I'm ready to go with is to install Parallels http://www.parallels.com/au/products/desktop/ or Bootcamp http://www.pcworld.com/article/249059/how_to_install_boot_camp_and_run_windows_on_your_mac.html so I can run Windows 7 on my MBP. EOS Utility runs 100% stable on Windows 7.

Still in the checking out stage, I'll post when it's up & running. But got to be very soon, the instability of OS X 10.7.5, EOS Utility 2.11.4. and EOS 5D3 is big enough to lose clients over. Arrrrgh!!!

-PW

canon rumors FORUM

Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #6 on: September 26, 2012, 01:10:06 AM »

Peter

  • Guest
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #7 on: September 26, 2012, 05:23:47 AM »
Canon blames Apple, Apple blames Canon. The one is is waiting for the other to fix the problem. Please react to both companies. It's a bloody shame you have to install 10.7.4 or Windows.

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #8 on: September 26, 2012, 10:27:37 AM »
Apple automatically gets the "crash report". Lets hope they see lots of them and respond.

I guess the next question I have is: Does EOS Utility work with OS X 10.8.X Mountain Lion? Does anyone have some experience to share? I've held off updating just to let the dust settle in case there are other incompatibilities.

Crapking

  • Canon 6D
  • *****
  • Posts: 379
  • "Whatever you are....be a good one." AL
    • View Profile
    • Crapking Photos
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #9 on: September 26, 2012, 11:41:34 AM »
Unfortunately us 'early MAC adopters' still cannot use EOS Utility with Mountain Lion  OS 10.8.X, though the Canon website says an "early October" release for compatability??

http://www.usa.canon.com/cusa/consumer/products/cameras/slr_cameras/eos_1d_x?selectedName=DriversAndSoftware
1Dx, 1DIV, 5D3, 7DII, (Sigma 15 FE)
16-35/2.8; 24-70/2.8 II; 70-200/2.8 II, 100-400L
35/1.4, 40/2.8; 50/1.2, 85/1.2, 135/2; 200/2

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #10 on: September 26, 2012, 01:03:31 PM »
So, we wait...........

pedz

  • Guest
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #11 on: September 30, 2012, 11:54:05 AM »
I just got my 1DX and already had 10.7.5 installed.

Question for the others in this boat:

Before the upgrade, when you plugged in the camera via USB, what happened?  Did the Mac ask you for an application?  Did it mount an image of the camera as a disk on your desktop?

I don't see how this can be Canon's fault.  On the other hand, Adobe Lightroom 4 could see the camera and managed to do an import of 12 or so images.

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #12 on: September 30, 2012, 06:19:29 PM »
I always opened EOS Utility first and then with the camera connected via USB would turn it ON. The camera would then show up in EOS Utility.

canon rumors FORUM

Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #12 on: September 30, 2012, 06:19:29 PM »

Waterloo

  • Rebel T5i
  • ****
  • Posts: 117
    • View Profile
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #13 on: October 11, 2012, 03:43:32 PM »
The latest release of EOS Utility (2.12.0) seems to have fixed the problem. Also there was a minor update to Mac OS X 10.7.5.

crasher8

  • Guest
Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #14 on: October 11, 2012, 05:53:24 PM »
It works fine with 10.8.2

canon rumors FORUM

Re: EOS Utility quitting with Mac OS X version 10.7.5
« Reply #14 on: October 11, 2012, 05:53:24 PM »