October 01, 2014, 07:25:28 AM

Author Topic: Lightroom 4.2 update  (Read 14551 times)

mws

  • EOS M2
  • ****
  • Posts: 182
    • View Profile

canon rumors FORUM

Lightroom 4.2 update
« on: October 03, 2012, 08:37:13 AM »

Jim Saunders

  • 1D Mark IV
  • ******
  • Posts: 862
    • View Profile
Re: Lightroom 4.2 update
« Reply #1 on: October 03, 2012, 08:59:13 AM »
See what I see: 6500K, 160 cd/m^2, ICC 2, gamma 2.2.

Viggo

  • Canon EF 300mm f/2.8L IS II
  • *******
  • Posts: 2065
    • View Profile
Re: Lightroom 4.2 update
« Reply #2 on: October 03, 2012, 09:34:21 AM »
So basically nothing to fix the VERYVERY uselessly slow performance.....
« Last Edit: October 03, 2012, 09:42:06 AM by Viggo »
1dx, 24-70 L II, 50 Art, 200 f2.0 L

AmbientLight

  • 6D
  • *****
  • Posts: 492
    • View Profile
Re: Lightroom 4.2 update
« Reply #3 on: October 03, 2012, 09:39:35 AM »
This fixes two minor nuisances I have actually experienced (the gray image placeholder appearing for a short while and the clarity - luminance noise issue). Not that this bothered me too much, but nevertheless I do appreciate things getting better.
« Last Edit: October 03, 2012, 09:44:00 AM by AmbientLight »

crasher8

  • Guest
Re: Lightroom 4.2 update
« Reply #4 on: October 03, 2012, 09:42:55 AM »
Well that certainly went smoother than the last Aperture update.

loetleen

  • Guest
Re: Lightroom 4.2 update
« Reply #5 on: October 03, 2012, 09:53:59 AM »
At last tethered shooting with the 5dMkIII is working!!!!

suburbia

  • Guest
Re: Lightroom 4.2 update
« Reply #6 on: October 03, 2012, 11:08:52 AM »
the flickr publish authentication issue is also fixed in this release

canon rumors FORUM

Re: Lightroom 4.2 update
« Reply #6 on: October 03, 2012, 11:08:52 AM »

Lee Jay

  • 1D X
  • *******
  • Posts: 1028
    • View Profile
Re: Lightroom 4.2 update
« Reply #7 on: October 03, 2012, 11:34:42 AM »
So basically nothing to fix the VERYVERY uselessly slow performance.....

There were several performance enhancements put in to this release.

Mt Spokane Photography

  • Canon EF 600mm f/4L IS II
  • ********
  • Posts: 8750
    • View Profile
Re: Lightroom 4.2 update
« Reply #8 on: October 03, 2012, 12:38:22 PM »
So basically nothing to fix the VERYVERY uselessly slow performance.....
I don't have a performance problem.  Sounds like a configuration issue if you have a PC.

rmt3rd

  • Power Shot G16
  • **
  • Posts: 12
    • View Profile
    • Richard Thigpen Photography
Re: Lightroom 4.2 update
« Reply #9 on: October 03, 2012, 02:01:14 PM »
So basically nothing to fix the VERYVERY uselessly slow performance.....
I don't have a performance problem.  Sounds like a configuration issue if you have a PC.

I have a PC (with plenty of RAM, etc.) and maybe someone can answer my problem about loading photos into Lightroom.  Once I import photos from my harddrive into LR, before I go into the Develop module, I wait for all the photos to "load", by waiting for the 3 tiny dots to disappear from each photo, indicating the photo is loaded.  The problem is, only the photos that are displayed on the screen actually "load", so I then have to scroll down to have the next line(s) of photos to show on the screen before they actually load.  I have the thumbnails set to the smallest setting so more photos are on the screen at once in the Library module.  Is there something I'm missing or I'm doing wrong.  I would rather have all the photos load on their own and go do something useful, instead of having to scroll down every 30 seconds until my 1,000 photos or so are finished loading.  The reason I make sure all the photos are loaded, meaning the 3 dots have disappeared, is so that in the Develop module it doesn't take forever for a single photo to become ready for adjustments.

keithfullermusic

  • 7D
  • *****
  • Posts: 373
    • View Profile
    • k2focus.com
Re: Lightroom 4.2 update
« Reply #10 on: October 03, 2012, 02:03:52 PM »
LR runs fairly slow on my computer too.  I have a quadcore iMac (i7) with 12GBs of RAM.  I also convert to .dng

The only thing that is slow is when the photo actually loads up.  Other than that there are usually tiny delays after adjustments.  Maybe i'm expecting too much, but Aperture didn't run this slow.  However, LR punishes Aperture in just about every other regard, so I can live with it.
5Diii - 50D - 100mm f/2.8, 85mm f/1.2 vii - 50mm f/1.4, 20mm f/2.8, 70-200 f/2.8 vii - 100-400mm f/4.5-5.6L IS, 430 EX II, YN560, YN568, Bowen's 500R's
---
Pics - http://k2focus.com | Tunes - http://keithfullermusic.com

Zlatko

  • Guest
Re: Lightroom 4.2 update
« Reply #11 on: October 03, 2012, 02:09:52 PM »
Once I import photos from my harddrive into LR, before I go into the Develop module, I wait for all the photos to "load", by waiting for the 3 tiny dots to disappear from each photo, indicating the photo is loaded.  The problem is, only the photos that are displayed on the screen actually "load", so I then have to scroll down to have the next line(s) of photos to show on the screen before they actually load.
You don't have to do this.  It sounds like you have LR set to build "minimal" previews on import.  Then it has to work hard to load them later.  Instead, set LR to build "1:1" or "standard" previews on import.  This way the import process takes longer, but the previews are all built when it's done.  This setting (called "Render Previews") is in the top right of the Import screen. 

Also, I've heard it's good to give LR a big cache for Camera Raw Settings.  This is done in LR Preferences, under File Handling.
« Last Edit: October 03, 2012, 02:13:22 PM by Zlatko »

rmt3rd

  • Power Shot G16
  • **
  • Posts: 12
    • View Profile
    • Richard Thigpen Photography
Re: Lightroom 4.2 update
« Reply #12 on: October 03, 2012, 02:17:17 PM »
Once I import photos from my harddrive into LR, before I go into the Develop module, I wait for all the photos to "load", by waiting for the 3 tiny dots to disappear from each photo, indicating the photo is loaded.  The problem is, only the photos that are displayed on the screen actually "load", so I then have to scroll down to have the next line(s) of photos to show on the screen before they actually load.
You don't have to do this.  It sounds like you have LR set to build "minimal" previews on import.  Then it has to work hard to load them later.  Instead, set LR to build "1:1" or "standard" previews on import.  This way the import process takes longer, but the previews are all built when it's done.  This setting (called "Render Previews") is in the top right of the Import screen. 

Also, I've heard it's good to give LR a big cache for Camera Raw Settings.  This is done in LR Preferences, under File Handling.

Awesome, I'll take a look when I get home today.  Thank you.

canon rumors FORUM

Re: Lightroom 4.2 update
« Reply #12 on: October 03, 2012, 02:17:17 PM »

Gothmoth

  • Guest
Re: Lightroom 4.2 update
« Reply #13 on: October 03, 2012, 02:24:21 PM »
compare the LR demosaicing with this new RAW converter:

http://www.picturecode.com/index.php


you may be suprised.....

AtSea

  • PowerShot G1 X II
  • ***
  • Posts: 31
    • View Profile
Re: Lightroom 4.2 update
« Reply #14 on: October 03, 2012, 02:59:46 PM »
shareholder?

canon rumors FORUM

Re: Lightroom 4.2 update
« Reply #14 on: October 03, 2012, 02:59:46 PM »