Anyone finding non-responsive touch sensor? (and other half-baked EOS R implementations you'd like fixed?)

mangobutter

EOS 80D
Dec 11, 2014
101
14
www.e46mango.com
I set my left side of the touch pad to activate auto-ISO. I'll tap it and nothing happens. I suspect this is what DP Review found when they said they found when the camera meter to be running, touchpad use is disabled. But yet it still lights up as you touch it, indicating you touched it. But just ignores your input/doesn't do the thing you programmed it to do. but then gives no warning it's because it's the meter is running. Just kinda leaves you to figure that out. Kind of frustrating Canon. Seems half baked. Please fix this for firmware 2.

What's stranger is you can actually set the camera to auto iso manually by simply touching "ISO" on the LCD screen at ANY time. but you just can't do it using the touchpad WHILE the meter is running.. really? Why?!

Any other sloppy behaviors you guys notice for this camera?
 

Mt Spokane Photography

I post too Much on Here!!
Mar 25, 2011
15,110
445
I assume you mean the Multi Function Bar? I have no problem setting Auto ISO with it. The ISO indicator turns orange and says Auto ISO and then indicates the ISO it has automatically been set to when you half press the shutter. It changes as the lighting or other settings change. That is the correct behavior.

I'm also not sure as to what you mean about a Meter running.
 

mangobutter

EOS 80D
Dec 11, 2014
101
14
www.e46mango.com
Meter running when camera is evaluating exposure levels. And yep the bar does the same thing for me for auto iso but not always. i'm sitting there tapping it 5-10x before it does what I programmed it to. The meter has to stop running. Meaning the change to auto ISO is locked out (touch bar wise) until the camera is done metering. (metering is started with half press of the shutter button)

You can however revert to auto iso (from manual ISO) at any time by simply tapping the screen.

I shoot efficiently and fast. I don't like to wait
 

Mt Spokane Photography

I post too Much on Here!!
Mar 25, 2011
15,110
445
I verified the issue if I understand what you were doing.

First, metering is always on on my camera even while half pressing the shutter button or AF ON, it responds to light changes, tapping the bar works fine when not pressing the shutter or AF-ON buttons.

Tapping the Multi-Function bar to change ISO definitely does not work while I am half pressing the shutter or pressing the AF-on button. The * button locks exposure, so I did not try it.

This is either a bug or intended function. I'm not good enough to press that bar and the AF ON button at the same time, but its barely possible for me to half press the shutter and tap the bar with my thumb. I just have little control left in my fingers.

I'd call Canon and tell them of the issue. They may be aware of it and working on a fix, or they may have it as a planned feature but if they get complaints, they might change it.