Canon EOS R - Error 070

killswitch

EOS RP
Aug 26, 2012
265
9
I have a question for you folks. When I turned on my R for the first time with the Lexar 32GB UHS-I SD card, I got the Error 070. It would ask me to shutdown and restart, or remove the battery and put it back on. The only way to get rid of that error was to remove and reinstall the battery (with that said SD card still installed).

Having used Canon for 8 years now, I have had a run in with such issues before, so I immediately thought ok 1)Obviously I need to reformat this SD card on the R as it was formatted for use with the 5D3. 2) Try the other SD cards I had which were used on 5D3 as well to see if they give the same error. Surprisingly I didnt get the error from the other two SD cards at all. When I reformatted that first SD card in EOS R, it worked and stopped getting the dreaded Error 070.

My question you all is, have any of you faced similar issues with your EOS R? Should I return the camera for a different copy? Argh, the fact that I have to go through the waiting game again for the new copy to be delivered is annoying.
 

killswitch

EOS RP
Aug 26, 2012
265
9
If a low level format does not work, toss the card and get a UHS II card that the R supports. I would not return the camera because a $10 card did not work with it.

https://www.amazon.com/SanDisk-Ultra-Class-Memory-SDSDUNC-032G-GN6IN/dp/B0143RT8OY/ref=sr_1_2?ie=UTF8&qid=1547006715&sr=8-2&keywords=32+gb+sd+card
I immediately did the low level format on that card, and all others as well. Have not gotten that error since, and have been taking test shots here and there. Thanks for the link, I have placed an order for a couple of UHS-II !