EOS R + Speedlite @ F1.8

random.lt

people photographer
Sep 1, 2018
6
4
Lithuania
www.random.lt
Hello All,
Could anyone try to replicate my problem with E-TTL??

I'm using bounced flash (580EXII) and if aperture is less than F2.0 (1.8/1.6/1.4) TTL is not metering right and pictures come out VERY dark. Tried with 2 different flash units, tried with all lens faster than F2.0 I'm also using "control" adapter.
So I narrowed it down to:
When the aperture is set to lower than F2.0 then:
- if ISO set to AUTO, then during flash exposure ISO drops dramatically (e.g. from 1600 to 250)
- if ISO set to some value, ISO doesn't drop but exposure is still too dark (flash firing is much weaker)

Basically I cannot get properly exposed shot with flash and aperture lower than F2.0.

- EOS R
- 580 EX II
- Control Ring mount adapter
- Lenses: Sigma 35/1.4 Art / Sigma 50/1.4 / Sigma 85/1.4 << could be miscommunication here?
- Av, Tv, Fv, M modes (basically - doesn't matter)
 
Last edited:

Viggo

EOS 5D SR
Dec 13, 2010
3,837
392
Just tried in Av with ETTL and f1.2 with the RF and it’s properly exposed. Have you changed exposure compensation for the flash?

I unfortunately have no EF lenses to test with the adapter.
 

random.lt

people photographer
Sep 1, 2018
6
4
Lithuania
www.random.lt
Just tried in Av with ETTL and f1.2 with the RF and it’s properly exposed. Have you changed exposure compensation for the flash?

I unfortunately have no EF lenses to test with the adapter.
No, no FEC applied. Once I change aperture to F2.0 - image is properly exposed.
Don't have RF lenses to test. Maybe I'll go to the camera shop to try that.
 
Last edited:
Reactions: Viggo